Bug 996139 - taskjuggler appears to require the "tins" rubygem
taskjuggler appears to require the "tins" rubygem
Status: CLOSED DUPLICATE of bug 972544
Product: Fedora
Classification: Fedora
Component: rubygem-taskjuggler (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tomas Dabašinskas
Fedora Extras Quality Assurance
:
Depends On: 972544 996489
Blocks: 993365
  Show dependency treegraph
 
Reported: 2013-08-12 09:40 EDT by Ankur Sinha (FranciscoD)
Modified: 2013-08-13 10:03 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-13 10:03:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ankur Sinha (FranciscoD) 2013-08-12 09:40:54 EDT
Description of problem:
It doesn't appear to work at all here. I haven't used it for a while so I'm not certain when this issue cropped up:

[asinha@localhost  03_planning(master *)]$ tj3 plan.tjp
/usr/share/rubygems/rubygems/dependency.rb:296:in `to_specs': Could not find 'tins' (~> 0.8) among 18 total gem(s) (Gem::LoadError)
        from /usr/share/rubygems/rubygems/specification.rb:1194:in `block in activate_dependencies'
        from /usr/share/rubygems/rubygems/specification.rb:1183:in `each'
        from /usr/share/rubygems/rubygems/specification.rb:1183:in `activate_dependencies'
        from /usr/share/rubygems/rubygems/specification.rb:1165:in `activate'
        from /usr/share/rubygems/rubygems/specification.rb:1197:in `block in activate_dependencies'
        from /usr/share/rubygems/rubygems/specification.rb:1183:in `each'
        from /usr/share/rubygems/rubygems/specification.rb:1183:in `activate_dependencies'
        from /usr/share/rubygems/rubygems/specification.rb:1165:in `activate'
        from /usr/share/rubygems/rubygems/core_ext/kernel_gem.rb:48:in `gem'
        from /usr/bin/tj3:22:in `<main>'
[asinha@localhost  03_planning(master *)]$


Version-Release number of selected component (if applicable):
rubygem-taskjuggler-3.4.0-3.fc19.noarch

How reproducible:
Always

Steps to Reproduce:
1. tj3 <tjp file>
2.
3.

Actual results:
Doesn't run. Gives above mentioned error.

Expected results:
Should run as expected.


Additional info:
I see a rubygem called "tins" here: http://rubygems.org/gems/tins  Is this what it's looking for?


It's worth noting that 3.5.0 is available, so the update could be clubbed up with this bugfix.  

https://groups.google.com/forum/?fromgroups#!topic/taskjuggler-announce/6zMuw5zlrU4

Would the Ruby2.0 rebuild have caused this?

Thanks,
Ankur
Comment 1 Ankur Sinha (FranciscoD) 2013-08-12 09:43:18 EDT
The FTBFS in rawhide also appears to be caused by the same issue. Not sure why it built correctly for F19.

http://kojipkgs.fedoraproject.org//work/tasks/2897/5772897/build.log
Comment 2 Ankur Sinha (FranciscoD) 2013-08-12 10:00:48 EDT
Workaround:

[asinha@ankur-pc  ~]$ gem install tins
Fetching: tins-0.8.3.gem (100%)
Successfully installed tins-0.8.3
Parsing documentation for tins-0.8.3
Installing ri documentation for tins-0.8.3
Done installing documentation for tins after 1 seconds
1 gem installed


Looks like the "tins" rubygem needs to be packaged up and added as both "Requires:" and "BuildRequires:".
Comment 3 Achilleas Pipinellis 2013-08-12 18:52:31 EDT
This is not a bug of taskjuggler rather than term-ansicolor which is a dependency of taskjuggler. Latest term-ansicolor(1.2.2) Requires tins[0] which is not stated in spec[1], therefore the error. 

It built correctly to f19, because the version in f19 is term-ansicolor-1.0.7, which does not require tins. Rawhide on the other hand has term-ansicolor-1.2.2 which requires tins.

I quickly crafted a working rubygem-tins.spec if needed[2], ready for BZ submission :)


[0] https://rubygems.org/gems/term-ansicolor/versions/1.2.2
[1] http://pkgs.fedoraproject.org/cgit/rubygem-term-ansicolor.git/tree/rubygem-term-ansicolor.spec
[2] http://axilleas.fedorapeople.org/tmp/rubygem-tins.spec
Comment 4 Josef Stribny 2013-08-13 04:30:15 EDT
This is already filled, adding depends on rhbz#972544.

Axilleas: Since you already started, can you please submit the spec and SRPM for a review? We can then add depends on that review. Thank you.
Comment 5 Achilleas Pipinellis 2013-08-13 05:35:26 EDT
(In reply to Josef Stribny from comment #4)
> Axilleas: Since you already started, can you please submit the spec and SRPM
> for a review? We can then add depends on that review. Thank you.

Done in https://bugzilla.redhat.com/show_bug.cgi?id=996489
Comment 6 Vít Ondruch 2013-08-13 10:03:39 EDT

*** This bug has been marked as a duplicate of bug 972544 ***

Note You need to log in before you can comment on or make changes to this bug.