Bug 972580 - google-guice-3.1.8 is available
Summary: google-guice-3.1.8 is available
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: google-guice   
(Show other bugs)
Version: rawhide
Hardware: Unspecified Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Mikolaj Izdebski
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: FutureFeature, Triaged
: 955522 (view as bug list)
Depends On: 815394
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-06-10 07:21 UTC by Upstream Release Monitoring
Modified: 2013-11-25 06:36 UTC (History)
4 users (show)

Fixed In Version: 3.1.8-1
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-25 06:36:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Upstream Release Monitoring 2013-06-10 07:21:39 UTC
Latest upstream release: 3.1.5
Current version in Fedora Rawhide: 3.1.3
URL: http://repo2.maven.org/maven2/org/sonatype/sisu/sisu-guice/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring

Comment 1 Mat Booth 2013-07-31 13:44:43 UTC
*** Bug 955522 has been marked as a duplicate of this bug. ***

Comment 2 Upstream Release Monitoring 2013-08-09 08:50:08 UTC
Latest upstream release: 3.1.6
Current version/release in Fedora Rawhide: 3.1.3-4.fc20
URL: http://repo2.maven.org/maven2/org/sonatype/sisu/sisu-guice/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring

Comment 3 Upstream Release Monitoring 2013-09-13 09:12:34 UTC
Latest upstream release: 3.1.7
Current version/release in Fedora Rawhide: 3.1.3-6.fc21
URL: http://repo2.maven.org/maven2/org/sonatype/sisu/sisu-guice/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring

Comment 4 Upstream Release Monitoring 2013-10-23 18:24:26 UTC
Latest upstream release: 3.1.8
Current version/release in Fedora Rawhide: 3.1.3-9.fc21
URL: http://repo2.maven.org/maven2/org/sonatype/sisu/sisu-guice/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring

Comment 5 Mikolaj Izdebski 2013-11-11 15:39:24 UTC
Newer versions of guice require cglib 3.x with the following patch:
http://sourceforge.net/p/cglib/bugs/42/
cglib also needs mvn alias: org.sonatype.sisu.inject:cglib

Comment 6 Mikolaj Izdebski 2013-11-12 10:28:17 UTC
Fixed in google-guice-3.1.8-1

Comment 7 Mikolaj Izdebski 2013-11-25 06:36:12 UTC
I believe that this bug is fixed in google-guice-3.1.8-1,
which is available in Fedora Rawhide, so I am closing this bug now.

The build containing the fix can be found at Koji:
http://koji.fedoraproject.org/koji/buildinfo?buildID=478086


Note You need to log in before you can comment on or make changes to this bug.