Bug 815394 - cglib - update to 3.0 (uses asm4)
cglib - update to 3.0 (uses asm4)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: cglib (Show other bugs)
rawhide
Unspecified Unspecified
medium Severity unspecified
: ---
: ---
Assigned To: Mikolaj Izdebski
Fedora Extras Quality Assurance
: FutureFeature
: 815390 (view as bug list)
Depends On:
Blocks: 972580
  Show dependency treegraph
 
Reported: 2012-04-23 10:07 EDT by gil cattaneo
Modified: 2013-11-25 01:36 EST (History)
2 users (show)

See Also:
Fixed In Version: 3.0-1
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-25 01:36:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
cglib 2.2 - 2.2.2 diff (10.09 KB, patch)
2012-04-23 10:07 EDT, gil cattaneo
no flags Details | Diff
remove jarjar reference (928 bytes, patch)
2012-04-23 10:11 EDT, gil cattaneo
no flags Details | Diff
use system jars (515 bytes, patch)
2012-04-23 10:11 EDT, gil cattaneo
no flags Details | Diff
ant gid (360 bytes, patch)
2012-04-23 10:12 EDT, gil cattaneo
no flags Details | Diff
spec file (3.46 KB, text/x-rpm-spec)
2012-04-23 17:26 EDT, gil cattaneo
no flags Details
cglib 2.2 - 2.2.2 diff (3.87 KB, patch)
2012-04-27 09:23 EDT, gil cattaneo
no flags Details | Diff
update to 2.2.2 (8.72 KB, patch)
2012-05-04 10:33 EDT, gil cattaneo
no flags Details | Diff
update to 2.2.2 (8.72 KB, patch)
2012-05-04 10:34 EDT, gil cattaneo
no flags Details | Diff
update to 3.0 (in complete) (3.75 KB, patch)
2012-10-23 06:38 EDT, Mikolaj Izdebski
no flags Details | Diff

  None (edit)
Description gil cattaneo 2012-04-23 10:07:54 EDT
Created attachment 579548 [details]
cglib 2.2 - 2.2.2 diff

Description of problem:
update to 2.2.2

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 gil cattaneo 2012-04-23 10:09:52 EDT
Resolves rhbz#806571
Comment 2 gil cattaneo 2012-04-23 10:11:07 EDT
Created attachment 579561 [details]
remove jarjar reference
Comment 3 gil cattaneo 2012-04-23 10:11:46 EDT
Created attachment 579562 [details]
use system jars
Comment 4 gil cattaneo 2012-04-23 10:12:23 EDT
Created attachment 579564 [details]
ant gid
Comment 5 gil cattaneo 2012-04-23 11:11:23 EDT
*** Bug 815390 has been marked as a duplicate of this bug. ***
Comment 6 gil cattaneo 2012-04-23 17:26:22 EDT
Created attachment 579698 [details]
spec file
Comment 7 gil cattaneo 2012-04-27 09:23:40 EDT
Created attachment 580767 [details]
cglib 2.2 - 2.2.2 diff
Comment 8 gil cattaneo 2012-05-04 10:33:36 EDT
Created attachment 582132 [details]
update to 2.2.2
Comment 9 gil cattaneo 2012-05-04 10:34:02 EDT
Created attachment 582133 [details]
update to 2.2.2
Comment 10 Mikolaj Izdebski 2012-10-23 06:38:34 EDT
Created attachment 632020 [details]
update to 3.0 (in complete)

Version 3.0 is available, it uses asm4 instead of asm3.

Note: Update to 3.0 needs to be synchronized with migrating other maven dependencies to asm4. Migrating only part of dependecies could break maven (asm3 and asm4 are incompatible, but use the same package name). Update carefully!
Comment 11 Mikolaj Izdebski 2013-11-12 05:27:54 EST
Fixed in cglib-3.0-1
Comment 12 Mikolaj Izdebski 2013-11-25 01:36:03 EST
I believe that this bug is fixed in cglib-3.0-1,
which is available in Fedora Rawhide, so I am closing this bug now.

The build containing the fix can be found at Koji:
http://koji.fedoraproject.org/koji/buildinfo?buildID=477845

Note You need to log in before you can comment on or make changes to this bug.