Bug 97259 - neat or rhc-network encouter unhandled exception and dies
neat or rhc-network encouter unhandled exception and dies
Status: CLOSED DUPLICATE of bug 88147
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-12 00:28 EDT by Joe Sauer
Modified: 2007-04-18 12:54 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:56:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe Sauer 2003-06-12 00:28:12 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20030131

Description of problem:
normally I've just used netconfig or edited
/etc/sysconfig/network-scripts/ifcfg-ethX to get the specific network setting I
want. But I tried running neat to see how it was. It died and caused the
following output:

Component: redhat-config-network
Version: 1.2.0
Summary: TB
/usr/src/build/228093-i386/install/usr/lib/python2.2/sre.py:137:search:TypeError:
expected string or buffer
Traceback (most recent call last):
  File "/usr/sbin/redhat-config-network-gui", line 154, in ?
    window = mainDialog()
  File
"/usr/src/build/226257-noarch/install/usr/share/redhat-config-network/netconfpkg/gui/maindialog.py",
line 154, in __init__
  File
"/usr/src/build/226257-noarch/install/usr/share/redhat-config-network/netconfpkg/gui/maindialog.py",
line 225, in load
  File
"/usr/src/build/226257-noarch/install/usr/share/redhat-config-network/netconfpkg/gui/maindialog.py",
line 232, in loadDevices
  File
"/usr/src/build/226257-noarch/install/usr/share/redhat-config-network/netconfpkg/NCDeviceList.py",
line 210, in getDeviceList
  File
"/usr/src/build/226257-noarch/install/usr/share/redhat-config-network/netconfpkg/NCDeviceList.py",
line 117, in load
  File
"/usr/src/build/226257-noarch/install/usr/share/redhat-config-network/netconfpkg/plugins/NCDevWireless.py",
line 34, in load
  File
"/usr/src/build/226257-noarch/install/usr/share/redhat-config-network/netconfpkg/NCWireless.py",
line 52, in load
  File "/usr/src/build/228093-i386/install/usr/lib/python2.2/sre.py", line 137,
in search
    return _compile(pattern, flags).search(string)
TypeError: expected string or buffer

After this I tried editing the ifcfg-eth0 files and it just would not work
properly since ifup appeard to be using /etc/sysconfig/networking files instead.
(I have not had time to look into this part yet) As of now I've had to manually
set network setting w/ ifconfig and route add in order to get connectivity. I'll
try editing the networking profiles file and see about fixing this for me, but
the exception is probably the key that needs fixing
It looks like during the build it somehow got the build dirs in the path to the
application when it should have been chrooted, maybe? 


Version-Release number of selected component (if applicable):
redhat-config-network-1.2.0-2 redhat-config-network-tui-1.2.0-2

How reproducible:
Always

Steps to Reproduce:
1. manually edit /etc/sysconfig/network-scripts/ifcfg-ethX 
2. run neat or rhc-network, and it happens every tie
3.I haven't reproduced it on an other sytem but at least one other person I've
spoken to has seen similar behaviour and bug 97252 has some similarities...
    

Actual Results:  same error as seen in description. 

Additional info:
Comment 1 Harald Hoyer 2003-06-16 07:23:18 EDT

*** This bug has been marked as a duplicate of 88147 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:56:40 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.