Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 972602 - Unable to start RHQ Storage Node
Summary: Unable to start RHQ Storage Node
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: RHQ Project
Classification: Other
Component: Installer
Version: 4.8
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ER01
: RHQ 4.10
Assignee: Stefan Negrea
QA Contact: Mike Foley
URL:
Whiteboard:
Depends On:
Blocks: 951619
TreeView+ depends on / blocked
 
Reported: 2013-06-10 08:11 UTC by Filip Brychta
Modified: 2014-03-25 20:54 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-25 20:54:55 UTC


Attachments (Terms of Use)
rhq-storage-installer-sh.log (2.15 KB, text/x-log)
2013-08-27 08:08 UTC, Armine Hovsepyan
no flags Details
rhq-storage-installer.log (1018 bytes, text/x-log)
2013-08-27 08:09 UTC, Armine Hovsepyan
no flags Details

Description Filip Brychta 2013-06-10 08:11:17 UTC
Description of problem:
$Summary

Version-Release number of selected component (if applicable):
http://hudson.qa.jboss.com/hudson/view/RHQ/job/rhq-master-gwt-locales/738/

How reproducible:
Always

Steps to Reproduce:
1. create /var/lib/rhq with relevant permissions for non-root user
2. unzip rhq-server-4.8.0-SNAPSHOT.zip
3. cd rhq-server-4.8.0-SNAPSHOT/bin
4. ./rhq-storage-installer.sh


Actual results:
Starting RHQ Storage Installer ...
04:03:25,862 INFO  [org.jboss.modules] JBoss Modules version 1.2.0.CR1
04:03:25,961 INFO  [org.rhq.storage.installer.StorageInstaller] Running RHQ Storage Node installer...
04:03:25,998 INFO  [org.rhq.cassandra.Deployer] Unzipping storage node to ${rhq.rootDir}
04:03:26,529 INFO  [org.rhq.cassandra.Deployer] Applying configuration changes to ${rhq.rootDir}/conf/cassandra.yaml
04:03:26,658 INFO  [org.rhq.cassandra.Deployer] Applying configuration changes to ${rhq.rootDir}/conf/log4j-server.properties
04:03:26,666 INFO  [org.rhq.cassandra.Deployer] Applying configuration changes to ${rhq.rootDir}/conf/cassandra-env.sh
04:03:26,700 INFO  [org.rhq.cassandra.Deployer] Updating file permissions in ${rhq.rootDir}/bin
04:03:26,706 INFO  [org.rhq.storage.installer.StorageInstaller] Finished installing RHQ Storage Node.
04:03:26,708 INFO  [org.rhq.storage.installer.StorageInstaller] Updating rhq-server.properties...
04:03:26,717 INFO  [org.rhq.storage.installer.StorageInstaller] Starting RHQ Storage Node
Exception in thread "main" org.apache.commons.exec.ExecuteException: Process exited with an error: 1 (Exit value: 1)
	at org.apache.commons.exec.DefaultExecutor.executeInternal(DefaultExecutor.java:377)
	at org.apache.commons.exec.DefaultExecutor.execute(DefaultExecutor.java:160)
	at org.apache.commons.exec.DefaultExecutor.execute(DefaultExecutor.java:147)
	at org.rhq.storage.installer.StorageInstaller.exec(StorageInstaller.java:565)
	at org.rhq.storage.installer.StorageInstaller.startNode(StorageInstaller.java:545)
	at org.rhq.storage.installer.StorageInstaller.run(StorageInstaller.java:381)
	at org.rhq.storage.installer.StorageInstaller.main(StorageInstaller.java:671)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:616)
	at org.jboss.modules.Module.run(Module.java:262)
	at org.jboss.modules.Main.main(Main.java:329)

Expected results:
Storage node is started without errors.

Additional info:
content of rhq-server-4.8.0-SNAPSHOT/logs/rhq-storage-installer.log:

04:03:25,862 INFO  [org.jboss.modules] JBoss Modules version 1.2.0.CR1
04:03:25,961 INFO  [org.rhq.storage.installer.StorageInstaller] Running RHQ Storage Node installer...
04:03:25,998 INFO  [org.rhq.cassandra.Deployer] Unzipping storage node to ${rhq.rootDir}
04:03:26,529 INFO  [org.rhq.cassandra.Deployer] Applying configuration changes to ${rhq.rootDir}/conf/cassandra.yaml
04:03:26,658 INFO  [org.rhq.cassandra.Deployer] Applying configuration changes to ${rhq.rootDir}/conf/log4j-server.properties
04:03:26,666 INFO  [org.rhq.cassandra.Deployer] Applying configuration changes to ${rhq.rootDir}/conf/cassandra-env.sh
04:03:26,700 INFO  [org.rhq.cassandra.Deployer] Updating file permissions in ${rhq.rootDir}/bin
04:03:26,706 INFO  [org.rhq.storage.installer.StorageInstaller] Finished installing RHQ Storage Node.
04:03:26,708 INFO  [org.rhq.storage.installer.StorageInstaller] Updating rhq-server.properties...
04:03:26,717 INFO  [org.rhq.storage.installer.StorageInstaller] Starting RHQ Storage Node


Is there any other storage node log where could i find the cause of the problem?

Comment 1 Filip Brychta 2013-06-11 13:45:15 UTC
Lowering severity. This is no longer blocking issue for our automation.

Comment 2 Stefan Negrea 2013-08-26 21:09:16 UTC
Please retest with the latest code available. Also, if the problem persists please attach the full rhq-storage-installer.log and rhq-storage.log if the issue persists. 

Most likely the information about why the server did not start is in the rhq-storage.log file.

Comment 3 Armine Hovsepyan 2013-08-27 08:06:45 UTC
please get rhq-storage-installer.log attached. There is no rhq-storage.log created.

please get attached also the log after rhq-storage-installer.sh run.

Comment 4 Armine Hovsepyan 2013-08-27 08:08:12 UTC
Created attachment 790833 [details]
rhq-storage-installer-sh.log

Comment 5 Armine Hovsepyan 2013-08-27 08:09:35 UTC
Created attachment 790834 [details]
rhq-storage-installer.log

Comment 6 Stefan Negrea 2013-09-10 17:10:43 UTC
Moving this post RHQ 4.9 because the rhqctl is the main script to be used to install RHQ Storage Nodes.

Comment 7 Stefan Negrea 2014-02-21 14:45:03 UTC
This issue has been resolved because the rhq-storage-installer no longer exists. The functionality has been consolidated and fixed in the main rhqctl utility.


Note You need to log in before you can comment on or make changes to this bug.