Bug 972739 - Default time zone in New VM dialog
Summary: Default time zone in New VM dialog
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine   
(Show other bugs)
Version: 3.1.0
Hardware: Unspecified Unspecified
unspecified
medium
Target Milestone: ---
: 3.2.1
Assignee: Martin Betak
QA Contact: Jiri Belka
URL:
Whiteboard: virt
Keywords: Improvement, ZStream
Depends On: 873795
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-06-10 13:58 UTC by Idith Tal-Kohen
Modified: 2018-12-02 18:11 UTC (History)
18 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Default time zone behavior in the "New Virtual Machine" window has been updated.
Story Points: ---
Clone Of: 873795
Environment:
Last Closed: 2013-07-16 13:41:44 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1048 normal SHIPPED_LIVE rhevm 3.2.1 bug fix update 2013-07-19 05:45:47 UTC
oVirt gerrit 14248 None None None Never
Red Hat Knowledge Base (Solution) 451253 None None None Never

Comment 1 Michal Skrivanek 2013-06-11 05:50:20 UTC
note: this is actually about applying defaults set in engine-config. By default new VMs will be created with GMT(UTC) initial timezone setting which is what most people want for Linux OSes

Comment 5 Jiri Belka 2013-06-17 10:17:41 UTC
ok, rhevm-3.2.1-0.31.el6ev.noarch.

engine=> select * from vdc_options where option_name like '%TimeZone%';
 option_id |      option_name       |   option_value    | version 
-----------+------------------------+-------------------+---------
       372 | DefaultWindowsTimeZone | GMT Standard Time | general
       373 | DefaultGeneralTimeZone | Etc/GMT           | general
(2 rows)

* related issues:

1) engine-config part is not done yet, but this can be solved by adding option_name(s) into /etc/ovirt-engine/engine-config/engine-config.properties, restarting ovirt-engine. then one can use rhevm-config to define its own TZ. (BZ974982)

2) if one would put "incorrect" TZ, the value in UI dialog does not show original default fallback but it does show - default: null
(BZ974985)

# rhevm-config -g DefaultWindowsTimeZone
DefaultWindowsTimeZone: Europe/Prague version: general

this shows mentioned - default:null

Comment 8 errata-xmlrpc 2013-07-16 13:41:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1048.html


Note You need to log in before you can comment on or make changes to this bug.