Bug 974985 - When incorrect TZ is set, Time Zone select box in UI does not show default fallback but 'default: null'
When incorrect TZ is set, Time Zone select box in UI does not show default fa...
Status: CLOSED DUPLICATE of bug 988259
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity medium
: ---
: 3.3.0
Assigned To: Martin Betak
Jiri Belka
virt
: Triaged
: 996519 (view as bug list)
Depends On: 988259 1000034
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-17 06:16 EDT by Jiri Belka
Modified: 2015-09-22 09 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-14 03:36:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiri Belka 2013-06-17 06:16:43 EDT
Description of problem:
BZ972739 introduces/correct TZs handling but there's issue when one defines a value which is not valid TZ. Instead of showing default fallback value in UI dialog, there's 'default: null'.

# rhevm-config -g DefaultWindowsTimeZone
DefaultWindowsTimeZone: Europe/Prague version: general

this shows mentioned - default:null

Version-Release number of selected component (if applicable):
sf18

How reproducible:
100%

Steps to Reproduce:
1. set some stupid value as TZ
2. check Vm dialog in Admin portal
3.

Actual results:
defualt: null

Expected results:
default: (GMT) GMT Standard Time

Additional info:
Comment 1 Jiri Belka 2013-06-25 08:55:40 EDT
FYI (sf18.1) I tried to update the DB directly and I set time_zone for a vm to 'foobar'. In UI, TZ value is empty and the text box is white (thus it means, there is no 'default:...' in the text box). Although when starting such VM, its TZ is set to GMT for qemu-kvm process:

# ps ax | grep '[q]emu-kvm.*w2k3-02' | sed 's/ /\n/g;' | egrep "^w2k|^base"
w2k3-02
base=2013-06-25T12:45:51,driftfix=slew

# egrep "<name>|adjustment" /var/log/vdsm/vdsm.log | tail -n2
        <name>w2k3-02</name>
        <clock adjustment="0" offset="variable">

So maybe the UI should check if values in the DB are valid...
Comment 2 Jiri Belka 2013-06-25 08:59:44 EDT
Clarification:
TZ value has 'defualt:null' in UI when such VM is down.
TZ value has no value in UI when such VM is running.
Comment 3 Michal Skrivanek 2013-08-14 03:34:23 EDT
*** Bug 996519 has been marked as a duplicate of this bug. ***
Comment 4 Michal Skrivanek 2013-08-14 03:36:10 EDT
This issue is being addressed as a part of large timezone-related code refactoring in bug 988259
Comment 5 Michal Skrivanek 2013-08-14 03:36:38 EDT

*** This bug has been marked as a duplicate of bug 988259 ***

Note You need to log in before you can comment on or make changes to this bug.