Bug 972740 - Some bad PPDs
Some bad PPDs
Status: CLOSED DUPLICATE of bug 866476
Product: Fedora
Classification: Fedora
Component: foomatic-db (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-10 09:59 EDT by Tim Waugh
Modified: 2013-12-18 09:06 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-18 09:06:35 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2013-06-10 09:59:40 EDT
Description of problem:
Testing each PPD declared by the 'foomatic' driver to see if it can be generated and opened, and checking for availability of referenced binaries, revealed some issues.

These PPDs reference binaries which don't seem to be available in Fedora:
  foomatic:Lexmark-1100-lm1100.ppd
  foomatic:Lexmark-1020-lm1100.ppd
  foomatic:Lexmark-1000-lm1100.ppd
  foomatic:Pentax-PocketJet_200-pentaxpj.ppd
  foomatic:Pentax-PocketJet_II-pentaxpj.ppd
  foomatic:Lexmark-2030-pbm2l2030.ppd
  foomatic:Lexmark-7200-pbm2l7k.ppd
  foomatic:Lexmark-Z51-pbm2l7k.ppd
  foomatic:Lexmark-Z82-pbm2l7k.ppd
  foomatic:Compaq-IJ900-pbm2l7k.ppd
  foomatic:Lexmark-5700-pbm2l7k.ppd
  foomatic:Lexmark-5000-pbm2l7k.ppd
  foomatic:Lexmark-7000-pbm2l7k.ppd
  foomatic:Lexmark-2050-c2050.ppd
  foomatic:Lexmark-2070-c2070.ppd
  foomatic:Canon-LBP-8A1-cjet.ppd
  foomatic:Canon-LBP-4U-cjet.ppd

These PPDs cannot be generated at all:
  foomatic:HP-Business_Inkjet_9100-Postscript.ppd
  foomatic:Oce-3165-Postscript.ppd

e.g.
$ /usr/lib/cups/driver/foomatic list | grep foomatic:HP-Business_Inkjet_9100-Postscript.ppd
"foomatic:HP-Business_Inkjet_9100-Postscript.ppd" en "HP" "HP Business Inkjet 9100 Foomatic/Postscript" "DRV:DPostscript,M0,TP;"
$ /usr/lib/cups/driver/foomatic cat foomatic:HP-Business_Inkjet_9100-Postscript.ppd
ERROR: Could not determine driver name for HP-Business_Inkjet_9100-Postscript.ppd!

Version-Release number of selected component (if applicable):
foomatic-4.0.9-2.fc19.x86_64
foomatic-db-4.0-38.20130604.fc19.noarch

How reproducible:
100%
Comment 1 Jiri Popelka 2013-06-10 10:14:33 EDT
(In reply to Tim Waugh from comment #0)
> These PPDs reference binaries which don't seem to be available in Fedora:

These binaries were in recently deprecated printing packages. What do you suggest ? Remove all references ?

> These PPDs cannot be generated at all:
>   foomatic:HP-Business_Inkjet_9100-Postscript.ppd
>   foomatic:Oce-3165-Postscript.ppd

bug #866476, we should fix it - upstream has not responded yet.
Comment 2 Tim Waugh 2013-06-10 10:37:35 EDT
(In reply to Jiri Popelka from comment #1)
> (In reply to Tim Waugh from comment #0)
> > These PPDs reference binaries which don't seem to be available in Fedora:
> 
> These binaries were in recently deprecated printing packages. What do you
> suggest ? Remove all references ?

I think we probably should, yes, similarly to how we do it for drivers provided in rpmfusion: i.e. remove our XML files altogether and let the 3rd party packages provide them.
Comment 3 Jiri Popelka 2013-12-18 09:06:35 EST

*** This bug has been marked as a duplicate of bug 866476 ***

Note You need to log in before you can comment on or make changes to this bug.