Bug 972764 - superfluous dots after "via" preposition in man pages
superfluous dots after "via" preposition in man pages
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: man-pages-overrides (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Peter Schiffer
Iveta Wiedermann
: ManPageChange, Patch
Depends On:
Blocks: 1011237
  Show dependency treegraph
 
Reported: 2013-06-10 10:33 EDT by Jan Pokorný
Modified: 2013-11-21 17:57 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
No documentation needed
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 17:57:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Pokorný 2013-06-10 10:33:52 EDT
# zcat -v $(rpm -qd yum | grep -E '\.gz$') 2>&1 \
  | sed -ne 's|^\(/usr/share/man/.*\.gz\).*|\1:|;ta;/.* via\. .*/p;d;:a;p;'
> /usr/share/man/man5/yum.conf.5.gz:
> protected via. Obsoletes as well as user/plugin removals.
> altered via. tokeep.
> /usr/share/man/man8/yum-shell.8.gz:
> /usr/share/man/man8/yum.8.gz:
> In "history list" you can change the behaviour of the 2nd column via. the
> "yum -q history addon-info last saved_tx" or via. the automatic saves in

# rpm -f yum
> yum-3.2.29-40.el6.noarch


Unexpected dot after "via" decreases parsability, especially if followed by
a capitalized word.
Comment 1 Jan Pokorný 2013-06-10 10:47:53 EDT
Patch proposed to upstream [1] (implies Fedora releases so far are also
affected).

[1] sorry, but as per yum-devel-bounces I got to moderation queue with
    the reason "Post by non-member to a members-only list", which is bogus
    as I've registered few minutes ahead of post :-/
Comment 2 Jan Pokorný 2013-06-10 13:20:03 EDT
update:

[1] http://lists.baseurl.org/pipermail/yum-devel/2013-June/010188.html
Comment 3 Jan Pokorný 2013-06-10 15:16:37 EDT
re [comment 1]:
indeed my bad -- first time I used fedoraproject.org alias for ML
                 and forgot... (sorry for my whining)
Comment 4 Zdeněk Pavlas 2013-06-11 03:52:12 EDT
Applied, thanks!
Comment 10 errata-xmlrpc 2013-11-21 17:57:49 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1695.html

Note You need to log in before you can comment on or make changes to this bug.