Bug 972771 - storage node table is not being updated when new storage is inventoried
storage node table is not being updated when new storage is inventoried
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Database (Show other bugs)
JON 3.2
Unspecified Unspecified
unspecified Severity medium
: ER01
: JON 3.2.0
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On:
Blocks: 951619
  Show dependency treegraph
 
Reported: 2013-06-10 10:42 EDT by Armine Hovsepyan
Modified: 2015-09-02 20:01 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-02 15:36:19 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
storage_node_datamodel (332.22 KB, image/png)
2013-06-27 06:48 EDT, Armine Hovsepyan
no flags Details

  None (edit)
Description Armine Hovsepyan 2013-06-10 10:42:17 EDT
Description of problem:
storage node table is not being updated when new storage is inventoried 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. install rhq storage on ip1
2. install rhq server and agent on ip1
3. install rhq storage and agent on ip2 and connect to server in ip1

Actual results:
storage node table is not being updated when new storage is inventoried 

Expected results:
storage node table is updated when new storage is inventoried (new storage is visible in db)

Additional info:
http://d.pr/i/JOVB
Comment 1 John Sanda 2013-06-26 14:18:59 EDT
Armine, can you retest this? The relevant code has undergone a few iterations since  you opened this bug, and a new storage node entity should get created when the corresponding resource is auto-imported into inventory.
Comment 2 Armine Hovsepyan 2013-06-27 06:48:07 EDT
Created attachment 766055 [details]
storage_node_datamodel
Comment 3 Armine Hovsepyan 2013-06-27 08:59:09 EDT
verified,

please get attached verification screen-shot.

Note You need to log in before you can comment on or make changes to this bug.