Bug 972914 - Portlet Skinning in Portal Extension does not work
Summary: Portlet Skinning in Portal Extension does not work
Status: CLOSED NOTABUG
Alias: None
Product: JBoss Enterprise Portal Platform 6
Classification: JBoss
Component: Portal (Show other bugs)
(Show other bugs)
Version: 6.1.0
Hardware: Unspecified Unspecified
unspecified
unspecified
Target Milestone: ER02
: 6.1.0
Assignee: Peter Palaga
QA Contact:
URL:
Whiteboard:
Keywords:
: 974117 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-06-10 19:23 UTC by Peter Palaga
Modified: 2013-11-01 08:24 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-11 15:27:17 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Peter Palaga 2013-06-10 19:23:22 UTC
Description of problem:
CSS files defined in Portal Extension Quickstart are not sent to client. 

Version-Release number of selected component (if applicable):
JPP 6.1.0 ER01

How reproducible:
1. Cold deploy the productized Portal Extension Quickstart:
git clone https://github.com/ppalaga/gatein-portal-quickstart.git
cd gatein-portal-quickstart
git checkout prod-6.1
cd gatein-portal-extension
mvn clean install
2. Cold deploy ear/target/gatein-portal-extension.ear
3. Visit http://127.0.0.1:8080/portal/classic

Actual results:
For BannerPortlet and HomePagePortlet, the Portal sends CSS files declared in jpp-branding instead of CSS files declared in Portal Extension

Expected results:
For BannerPortlet and HomePagePortlet, the Portal shoudl send CSS files declared in Portal Extension.

Additional info:
When the skin for the whole portal is changed from JppSkin to Default, one would expect to get Default CSS declated in Portal Extension for both BannerPortlet and HomePagePortlet. Actually only BannerPortlet behaves as expected. For HomePagePortlet, the CSS from jpp-branding is sent. Note that BannerPortlet has no definition for Default skin in jpp-branding and to the very opposite, HomePagePortlet has a definition for Default skin in jpp-branding. It seems that jpp-branding always wins.

This seems to be a regression against JPP 6.0 where the CSS were loaded properly from Portal Extension.

Comment 1 Peter Palaga 2013-06-11 15:27:17 UTC
This is not a bug in portal. The experienced behavior was caused by a missing entry in configuration.xml dependencies:
<value>
  <string>jpp-branding-skin</string>
</value>

Comment 2 Peter Palaga 2013-06-21 13:24:36 UTC
*** Bug 974117 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.