Bug 974736 - Anaconda Fedora 19 TC3 Live Crash on Custom Partitioning Using es_ES language
Anaconda Fedora 19 TC3 Live Crash on Custom Partitioning Using es_ES language
Status: CLOSED DUPLICATE of bug 973019
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
All Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-15 02:07 EDT by Nix\
Modified: 2013-06-20 02:55 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-17 22:17:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda Crash trying delete a pre-existent partition using Spanish Language, if en_US is used no happen (66.61 KB, image/png)
2013-06-15 02:07 EDT, Nix\
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 973019 None None None Never

  None (edit)
Description Nix\ 2013-06-15 02:07:28 EDT
Created attachment 761512 [details]
Anaconda Crash trying delete a pre-existent partition using Spanish Language, if en_US is used no happen

Description of problem:

Using es_ES language for installation, Anaconda crash when a custom partitioning is selected, in the moment that I select (-) for remove a pre-existent partition, all turn grey and crash with a message about unicode.
The backtrace and reporting from the live medium is reported here: 

https://bugzilla.redhat.com/show_bug.cgi?id=973019

The conditions for reproduce it are 2:
1.- That the HDD must be a previous primary partition / ext and swap
2.- Select Spanish for language in installation, and only repeat step by step commented in "Steps to Reproduce" item here.

NOTE: If en_US is used for the installation, the bug no happen.

Version-Release number of selected component (if applicable):

Fedora 19 TC3 Live KDE
Anaconda-19.30.5-1.fc19

How reproducible:

Always

Steps to Reproduce:

0.Create a primary partition in a disk, / ext4 and swap using any live distro
1.Boot a Live CD with Fedora 19 TC3 KDE Spin or other spin
2.Start anaconda, select Spanish as language for installing
3.Select destination, select custom partitioning (The hdd must be a previous partition of another installation, / ext4 and swap, point 0), select / partition, press "-" symbol for delete it, Anaconda crash and a message of error is displayed.

Actual results:
If a previous partition is in the HDD for installation of Fedora 19 TC3, and language selected is Spanish, custom partitioning crash always when you try to delete a previous / partition.

Expected results:
No crash Anaconda.

Additional info:

Attach a screenshot and the bug report auto-generated by anaconda and reported in bugzilla for me

https://bugzilla.redhat.com/show_bug.cgi?id=973019
Comment 1 Nix\ 2013-06-15 02:20:40 EDT
Is a regression instroduced in Anaconda 19.30.3-1, i can confirm it
Comment 2 Adam Williamson 2013-06-17 22:17:31 EDT
No need to report it twice...

*** This bug has been marked as a duplicate of bug 973019 ***
Comment 3 Nix\ 2013-06-20 02:55:32 EDT
(In reply to Adam Williamson from comment #2)
> No need to report it twice...
> 
> *** This bug has been marked as a duplicate of bug 973019 ***

Sorry Adam, i repliqued the bug because i don't see any change in the other bug, so, I opened this bug.

Note You need to log in before you can comment on or make changes to this bug.