Bug 973161 - cannot change theme to anything but Adwaita
cannot change theme to anything but Adwaita
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: lxappearance (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Christoph Wickert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-11 08:01 EDT by Marcus Moeller
Modified: 2015-06-16 16:02 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-13 12:16:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marcus Moeller 2013-06-11 08:01:39 EDT
Description of problem:
I am trying to change the GTK Theme to something else than Adwaita on a icewm desktop. To do so I have tried gtk-chtheme and lxappearance which both worked in the path. 

No theme change seems to be applied.
Comment 1 Christoph Wickert 2013-06-13 11:43:45 EDT
Are we talking about gtk2 or gtk3 here?
Comment 2 Marcus Moeller 2013-06-13 11:57:20 EDT
I have only tested GTK2 applications, but I am going to try to set up another reproducer to see if it also affects GTK3.
Comment 3 Christoph Wickert 2013-06-13 12:16:40 EDT
Not necessary, it will not work anyway. lxappearance just writes values to ~/.config/lxsession/LXDE/desktop.conf but doesn't apply them. For that you need an XSETTINGS manager, e.g, gnome-settings-manager or lxsession. Or you need something that directly writes to ~/.gtkrc for gtk2 (or ~/.gtkrc-2.0?) and ~/.config/gtk-3.0/settings.ini, but these changes are then only applied when an app is started.
Comment 4 Marcus Moeller 2013-06-14 02:51:17 EDT
Thanks for pointing that out, but the problem also occurs using gtk-chtheme which is writing to ~/.gtkrc-2.0 correctly.

Besides that lxappearance is causing a segfault right now, but that might be another bug.
Comment 5 Marcus Moeller 2013-06-14 03:04:40 EDT
I have noticed that: https://bugzilla.redhat.com/show_bug.cgi?id=953945 has already been reported on the lxappearance segfault. I am going to re-open this one and change the comp to gtk-chtheme.
Comment 6 Marcus Moeller 2013-06-14 04:56:17 EDT
After some additional debugging with the help of Christoph, I was able to figure out that gtk-chtheme does not write:

gtk-theme-name="THEME_NAME"

to .gtkrc-2.0. After adding it manually, the theme is adopted correctly. I am going to talk to the upstream developer of gtk-chtheme on that.

Note You need to log in before you can comment on or make changes to this bug.