Bug 973238 - pki upgrade 3.2->3.2 - do not overwrite apache certificate and key
pki upgrade 3.2->3.2 - do not overwrite apache certificate and key
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-setup (Show other bugs)
3.2.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.2.1
Assigned To: Alon Bar-Lev
Jiri Belka
integration
: ZStream
Depends On: 969755
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-11 10:11 EDT by Idith Tal-Kohen
Modified: 2013-11-27 19:07 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, upgrading from pre-release Red Hat Enterprise Virtualization Manager 3.2 to Red Hat Enterprise Virtualization Manager 3.2 caused the Apache certificate and key to be overwritten. Upgrading from pre-release Red Hat Enterprise Virtualization 3.2 to Red Hat Enterprise Virtualization 3.2 no longer causes the Apache certificate and key to be overwritten.
Story Points: ---
Clone Of: 969755
Environment:
Last Closed: 2013-07-16 09:42:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 15265 None None None Never
oVirt gerrit 15266 None None None Never
oVirt gerrit 15267 None None None Never
Red Hat Product Errata RHBA-2013:1048 normal SHIPPED_LIVE rhevm 3.2.1 bug fix update 2013-07-19 01:45:47 EDT

  None (edit)
Comment 2 Jiri Belka 2013-06-21 07:16:54 EDT
OK sf18.1. The files are not regenarated but copied.

# ls /etc/pki/ovirt-engine/*/{apache,engine}* | xargs cksum | sort
110928004 1704 /etc/pki/ovirt-engine/keys/apache.key.nopass
110928004 1704 /etc/pki/ovirt-engine/keys/engine_id_rsa
1144614670 5190 /etc/pki/ovirt-engine/certs/apache.cer
1144614670 5190 /etc/pki/ovirt-engine/certs/engine.cer
2144107499 388 /etc/pki/ovirt-engine/keys/engine.ssh.key.txt
2262392643 1177 /etc/pki/ovirt-engine/certs/engine.der
2571934565 4242 /etc/pki/ovirt-engine/keys/apache.p12
2571934565 4242 /etc/pki/ovirt-engine/keys/engine.p12
494774542 1067 /etc/pki/ovirt-engine/requests/engine.req
Comment 7 errata-xmlrpc 2013-07-16 09:42:24 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1048.html

Note You need to log in before you can comment on or make changes to this bug.