Bug 973317 - Firstboot back button behavior
Firstboot back button behavior
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.10
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: candlepin-bugs
IDM QE LIST
:
Depends On:
Blocks: rhsm-rhel510
  Show dependency treegraph
 
Reported: 2013-06-11 12:43 EDT by Sharath Dwaral
Modified: 2015-03-22 21:14 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-01 10:40:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sharath Dwaral 2013-06-11 12:43:32 EDT
Description of problem:
Clicking back-button immediately after registering takes you back to "Choose Service" screen and you can re-register again.

But clicking on back-button after navigating to create user take you back to "enter server url and port" screen.

Version-Release number of selected component (if applicable):
# rpm -qa | egrep "subscription-manager|python-rhsm" 
subscription-manager-migration-data-1.11.3.1-1.git.1.78afd75.el5
subscription-manager-debuginfo-1.8.8-1.el5
python-rhsm-1.8.12-1.git.0.d747a65.el5
subscription-manager-firstboot-1.8.10-1.git.27.c1dbb63.el5
subscription-manager-gui-1.8.10-1.git.27.c1dbb63.el5
subscription-manager-1.8.10-1.git.27.c1dbb63.el5
subscription-manager-migration-1.8.10-1.git.27.c1dbb63.el5


How reproducible:
Always

Steps to Reproduce:
1. Launch firstboot
2. Register using firstboot
3. Click on back-button after registering 
4. You navigate to "Choose Service"
5. Register
6. Click Forward till you reach "Create User" menu
7. Click back-button

Actual results:
You are navigated back to "Enter server url and port" screen

Expected results:
Should either navigate to the the screen before "Create User" or to "Choose service"

Additional info:
Comment 1 RHEL Product and Program Management 2013-06-25 11:18:13 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 2 RHEL Product and Program Management 2013-07-24 00:06:26 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 3 Devan Goodwin 2013-08-01 10:40:43 EDT
This is actually expected behaviour and somewhat of a "best we could do" situation. On RHEL 5 specifically, we cannot go from the next firstboot module (Create User) back to the last screen of our module due to limitations with firstboot. We were unable to locate the bug where this behaviour was decided upon but it's been through a number of iterations and this was where we had to settle with it. 

If this were to resurface on RHEL 6 we *may* be able to do something there, but not on EL5. Closing for now.

Note You need to log in before you can comment on or make changes to this bug.