Bug 973379 - wrong python-kerberos version specified in egg-info
wrong python-kerberos version specified in egg-info
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: python-kerberos (Show other bugs)
6.4
Unspecified All
medium Severity unspecified
: rc
: ---
Assigned To: Rob Crittenden
Namita Soman
:
Depends On:
Blocks: 975202 1061410 1112374
  Show dependency treegraph
 
Reported: 2013-06-11 15:35 EDT by John A. Barbuto
Modified: 2014-10-14 04:27 EDT (History)
2 users (show)

See Also:
Fixed In Version: python-kerberos-1.1-7.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 975202 1112374 (view as bug list)
Environment:
Last Closed: 2014-10-14 04:27:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John A. Barbuto 2013-06-11 15:35:43 EDT
Description of problem:

Although the packaged python-kerberos version is 1.1, according to its egg-info it's 1.0.  This prevents module dependency resolution from working properly.

$ rpm -q python-kerberos
python-kerberos-1.1-6.2.el6.x86_64
$ rpm -ql python-kerberos | head -n 1
/usr/lib64/python2.6/site-packages/kerberos-1.0-py2.6.egg-info
$ python
>>> import pkg_resources
>>> pkg_resources.require('kerberos >= 1.1')
Traceback (most recent call last):
  File "<console>", line 1, in <module>
  File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 648, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 550, in resolve
    raise VersionConflict(dist,req) # XXX put more info here
VersionConflict: (kerberos 1.0 (/usr/lib64/python2.6/site-packages), Requirement.parse('kerberos>=1.1'))

Version-Release number of selected component (if applicable):

python-kerberos-1.1-6.2.el6.x86_64

How reproducible:

Every time.

Steps to Reproduce:

$ python
>>> import pkg_resources
>>> pkg_resources.get_distribution('kerberos').version

Actual results:

'1.0'

Expected results:

'1.1'
Comment 6 Kaleem 2014-06-30 09:11:00 EDT
Verified.

rpm version:
============
[root@rhel66-master ~]# rpm -q python-kerberos
python-kerberos-1.1-7.el6.x86_64
[root@rhel66-master ~]#

Verification steps and console output:
======================================
[root@rhel66-master ~]# rpm -q python-kerberos
python-kerberos-1.1-7.el6.x86_64
[root@rhel66-master ~]# rpm -ql python-kerberos|head -n 1
/usr/lib64/python2.6/site-packages/kerberos-1.1-py2.6.egg-info
[root@rhel66-master ~]# python
Python 2.6.6 (r266:84292, Nov 21 2013, 10:50:32) 
[GCC 4.4.7 20120313 (Red Hat 4.4.7-4)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import pkg_resources
>>> pkg_resources.require('kerberos >= 1.1')
[kerberos 1.1 (/usr/lib64/python2.6/site-packages)]
>>>
Comment 7 errata-xmlrpc 2014-10-14 04:27:29 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1600.html

Note You need to log in before you can comment on or make changes to this bug.