Bug 975202 - wrong python-kerberos version specified in egg-info
wrong python-kerberos version specified in egg-info
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-kerberos (Show other bugs)
19
Unspecified All
unspecified Severity unspecified
: ---
: ---
Assigned To: Rob Crittenden
Fedora Extras Quality Assurance
:
Depends On: 973379 1112374
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-17 15:41 EDT by Rob Crittenden
Modified: 2014-06-23 14:50 EDT (History)
3 users (show)

See Also:
Fixed In Version: python-kerberos-1.1-11.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 973379
Environment:
Last Closed: 2013-06-26 21:53:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rob Crittenden 2013-06-17 15:41:51 EDT
+++ This bug was initially created as a clone of Bug #973379 +++

Description of problem:

Although the packaged python-kerberos version is 1.1, according to its egg-info it's 1.0.  This prevents module dependency resolution from working properly.

$ rpm -q python-kerberos
python-kerberos-1.1-6.2.el6.x86_64
$ rpm -ql python-kerberos | head -n 1
/usr/lib64/python2.6/site-packages/kerberos-1.0-py2.6.egg-info
$ python
>>> import pkg_resources
>>> pkg_resources.require('kerberos >= 1.1')
Traceback (most recent call last):
  File "<console>", line 1, in <module>
  File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 648, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 550, in resolve
    raise VersionConflict(dist,req) # XXX put more info here
VersionConflict: (kerberos 1.0 (/usr/lib64/python2.6/site-packages), Requirement.parse('kerberos>=1.1'))

Version-Release number of selected component (if applicable):

python-kerberos-1.1-6.2.el6.x86_64

How reproducible:

Every time.

Steps to Reproduce:

$ python
>>> import pkg_resources
>>> pkg_resources.get_distribution('kerberos').version

Actual results:

'1.0'

Expected results:

'1.1'

--- Additional comment from RHEL Product and Program Management on 2013-06-11 15:41:38 EDT ---

Since this bug report was entered in bugzilla and this package is
not scheduled to be updated in the current release, the release
flag has been set to ? to ensure that it is properly evaluated
for the next release.
Comment 1 Fedora Update System 2013-06-17 16:28:12 EDT
python-kerberos-1.1-10.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/python-kerberos-1.1-10.fc18
Comment 2 Fedora Update System 2013-06-17 16:28:21 EDT
python-kerberos-1.1-11.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/python-kerberos-1.1-11.fc19
Comment 3 Fedora Update System 2013-06-18 15:41:27 EDT
Package python-kerberos-1.1-11.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-kerberos-1.1-11.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-11170/python-kerberos-1.1-11.fc19
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2013-06-26 21:53:19 EDT
python-kerberos-1.1-10.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Fedora Update System 2013-06-29 14:35:31 EDT
python-kerberos-1.1-11.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.