Bug 973476 - Devel::Cover support
Devel::Cover support
Status: CLOSED NOTABUG
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
4.4
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ---
: ---
Assigned To: Jeff Fearn
tools-bugs
: Reopened
: 975288 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-11 22:32 EDT by Jeff Fearn
Modified: 2013-10-23 23:53 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-23 23:53:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Fearn 2013-06-11 22:32:04 EDT
Description of problem:
Add support for Devel::Cover to allow test coverage results to be tracked.
Comment 1 Jeff Fearn 2013-06-17 23:21:03 EDT
*** Bug 975288 has been marked as a duplicate of this bug. ***
Comment 3 Jason McDonald 2013-08-07 20:12:49 EDT
This change has been abandoned, as desribed in the gerrit review.
Comment 4 Jeff Fearn 2013-08-07 20:21:10 EDT
Why is this abandoned? There is no reason you can't use Devel::Cover with the solution chosen.
Comment 5 Jason McDonald 2013-08-08 03:00:53 EDT
The commit was abandoned, though it looks like two-thirds of it got into the product via different means.....

[11:30:04] <jmcdonal> simon: what do you want to do about https://code.engineering.redhat.com/gerrit/#/c/9273/ ?
[11:31:16] <simon> If it was my call, I'd abandon it.
[11:31:49] <simon> The change for t/004template.t is incorrect, I submitted the correct one upstream.
[11:32:29] <simon> The change in bugzilla.spec.in means we would never be able to submit a RHEL 5 RPM any time soon, due to missing deps.
[11:33:07] <simon> And the change for extensions/RedHat/template/en/default/pages/component-templates.html.tmpl was submitted in a different bug.

Besides those pieces, what else would need to be done?
Comment 6 Jeff Fearn 2013-08-08 03:09:12 EDT
Make the spec file pull in the deps and tweak the prove command line to set it up.

This should be close:

HARNESS_PERL_SWITCHES=-MDevel::Cover prove
Comment 7 Jason McDonald 2013-08-08 03:25:24 EDT
It appears that the dependencies aren't available for RHEL5, and there is a significant cost to rectify that.  Therefore I propose to revisit this once the production Bugzilla is on RHEL6.
Comment 8 Jeff Fearn 2013-08-08 19:47:51 EDT
All the deps are in rhel 6, it is trivial to add those packages to the rhel 5 brew root.

Note You need to log in before you can comment on or make changes to this bug.