Bug 975288 - Fix runtests.pl script
Fix runtests.pl script
Status: CLOSED DUPLICATE of bug 973476
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
4.4
All All
medium Severity medium (vote)
: ---
: ---
Assigned To: PnT DevOps Devs
tools-bugs
: CodeChange, MoveUpstream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-17 23:07 EDT by Simon Green
Modified: 2014-10-12 18:51 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-17 23:21:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Simon Green 2013-06-17 23:07:56 EDT
Description of problem:
The upstream runtest.pl script generates two errors, because we have templates in our extension code. This is perfectly valid, so the test script needs to be modified to support this.

Version-Release number of selected component (if applicable):
4.4

How reproducible:
Always

Steps to Reproduce:
1. Create an extension that calls a template page that is in the extensions/X/template/en/default/ directory
2. Run ./runtests.pl

Actual results:
An error

Expected results:
No error.
Comment 2 Jeff Fearn 2013-06-17 23:21:03 EDT
This will be handled in the Devel::Cover fix

*** This bug has been marked as a duplicate of bug 973476 ***

Note You need to log in before you can comment on or make changes to this bug.