Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 973503 - DBusException: org.freedesktop.NetworkManager.AgentManager.SessionNotFound: Session not found
Summary: DBusException: org.freedesktop.NetworkManager.AgentManager.SessionNotFound: S...
Keywords:
Status: CLOSED DUPLICATE of bug 973068
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 19
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:b7c0c88d4a23bc1448e7c6611af...
Depends On:
Blocks: F19Blocker, F19FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2013-06-12 04:58 UTC by Dan Mashal
Modified: 2013-06-12 05:08 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-06-12 05:02:51 UTC
Type: ---


Attachments (Terms of Use)
File: anaconda-tb (146.83 KB, text/plain)
2013-06-12 04:58 UTC, Dan Mashal
no flags Details
File: anaconda.log (4.04 KB, text/plain)
2013-06-12 04:58 UTC, Dan Mashal
no flags Details
File: backtrace (1.62 KB, text/plain)
2013-06-12 04:58 UTC, Dan Mashal
no flags Details
File: environ (441 bytes, text/plain)
2013-06-12 04:58 UTC, Dan Mashal
no flags Details
File: ifcfg.log (490 bytes, text/plain)
2013-06-12 04:58 UTC, Dan Mashal
no flags Details
File: lsblk_output (1.00 KB, text/plain)
2013-06-12 04:58 UTC, Dan Mashal
no flags Details
File: nmcli_dev_list (3.49 KB, text/plain)
2013-06-12 04:58 UTC, Dan Mashal
no flags Details
File: packaging.log (10.45 KB, text/plain)
2013-06-12 04:58 UTC, Dan Mashal
no flags Details
File: program.log (14.92 KB, text/plain)
2013-06-12 04:58 UTC, Dan Mashal
no flags Details
File: storage.log (26.85 KB, text/plain)
2013-06-12 04:58 UTC, Dan Mashal
no flags Details
File: syslog (74.64 KB, text/plain)
2013-06-12 04:59 UTC, Dan Mashal
no flags Details

Description Dan Mashal 2013-06-12 04:58:17 UTC
Description of problem:
Fresh boot of F19 TC2.1 netinstall with 4GB of RAM
The following was filed automatically by anaconda:
anaconda 19.30.4-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/dbus/connection.py", line 651, in call_blocking
    message, timeout)
  File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 145, in __call__
    **keywords)
  File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 70, in __call__
    return self._proxy_method(*args, **keywords)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/network.py", line 1249, in register_secret_agent
    proxy.Register("anaconda", dbus_interface=AGENT_MANAGER_IFACE)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/network.py", line 1349, in initialize
    register_secret_agent(self)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 201, in _createBox
    spoke.initialize()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 353, in refresh
    self._createBox()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/__init__.py", line 479, in _on_continue_clicked
    nextAction.refresh()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/__init__.py", line 68, in _on_continue_clicked
    cb()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/welcome.py", line 356, in _on_continue_clicked
    StandaloneSpoke._on_continue_clicked(self, cb)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/__init__.py", line 72, in <lambda>
    self.window.connect("continue-clicked", lambda *args: self._on_continue_clicked(cb))
DBusException: org.freedesktop.NetworkManager.AgentManager.SessionNotFound: Session not found

Version-Release number of selected component:
anaconda-19.30.4-1

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2019-TC2.1\x20x86_64 quiet BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.4-301.fc19.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19-TC2.1

Truncated backtrace:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/__init__.py", line 72, in <lambda>
    self.window.connect("continue-clicked", lambda *args: self._on_continue_clicked(cb))
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/welcome.py", line 356, in _on_continue_clicked
    StandaloneSpoke._on_continue_clicked(self, cb)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/__init__.py", line 68, in _on_continue_clicked
    cb()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/__init__.py", line 479, in _on_continue_clicked
    nextAction.refresh()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 353, in refresh
    self._createBox()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 201, in _createBox
    spoke.initialize()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/network.py", line 1349, in initialize
    register_secret_agent(self)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/network.py", line 1249, in register_secret_agent
    proxy.Register("anaconda", dbus_interface=AGENT_MANAGER_IFACE)
  File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 70, in __call__
    return self._proxy_method(*args, **keywords)
  File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 145, in __call__
    **keywords)
  File "/usr/lib/python2.7/site-packages/dbus/connection.py", line 651, in call_blocking
    message, timeout)
DBusException: org.freedesktop.NetworkManager.AgentManager.SessionNotFound: Session not found

Comment 1 Dan Mashal 2013-06-12 04:58:23 UTC
Created attachment 759946 [details]
File: anaconda-tb

Comment 2 Dan Mashal 2013-06-12 04:58:27 UTC
Created attachment 759947 [details]
File: anaconda.log

Comment 3 Dan Mashal 2013-06-12 04:58:31 UTC
Created attachment 759948 [details]
File: backtrace

Comment 4 Dan Mashal 2013-06-12 04:58:35 UTC
Created attachment 759949 [details]
File: environ

Comment 5 Dan Mashal 2013-06-12 04:58:38 UTC
Created attachment 759950 [details]
File: ifcfg.log

Comment 6 Dan Mashal 2013-06-12 04:58:41 UTC
Created attachment 759951 [details]
File: lsblk_output

Comment 7 Dan Mashal 2013-06-12 04:58:45 UTC
Created attachment 759952 [details]
File: nmcli_dev_list

Comment 8 Dan Mashal 2013-06-12 04:58:49 UTC
Created attachment 759953 [details]
File: packaging.log

Comment 9 Dan Mashal 2013-06-12 04:58:53 UTC
Created attachment 759954 [details]
File: program.log

Comment 10 Dan Mashal 2013-06-12 04:58:56 UTC
Created attachment 759955 [details]
File: storage.log

Comment 11 Dan Mashal 2013-06-12 04:59:00 UTC
Created attachment 759956 [details]
File: syslog

Comment 12 Dan Mashal 2013-06-12 05:01:03 UTC
This is causing problems distro wide. Anaconda crash, MATE crashes, and  I think Gnome crashes have been reported too.

Comment 13 Adam Williamson 2013-06-12 05:02:51 UTC

*** This bug has been marked as a duplicate of bug 973068 ***

Comment 14 Adam Williamson 2013-06-12 05:08:04 UTC
"This is causing problems distro wide. Anaconda crash, MATE crashes, and  I think Gnome crashes have been reported too."

I don't think there's any particular indication that any MATE or GNOME crashes are related to this bug? I don't see any other reports with "org.freedesktop.NetworkManager.AgentManager.SessionNotFound" in them.


Note You need to log in before you can comment on or make changes to this bug.