Bug 973068 - DBusException: org.freedesktop.NetworkManager.AgentManager.SessionNotFound: Session not found
DBusException: org.freedesktop.NetworkManager.AgentManager.SessionNotFound: S...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
19
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
abrt_hash:b7c0c88d4a23bc1448e7c6611af...
:
: 973503 974049 (view as bug list)
Depends On:
Blocks: F19Blocker/F19FinalBlocker
  Show dependency treegraph
 
Reported: 2013-06-11 04:26 EDT by Radek Vykydal
Modified: 2013-06-18 02:13 EDT (History)
16 users (show)

See Also:
Fixed In Version: NetworkManager-0.9.8.2-2.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-18 02:13:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (247.74 KB, text/plain)
2013-06-11 04:26 EDT, Radek Vykydal
no flags Details
File: anaconda.log (3.39 KB, text/plain)
2013-06-11 04:26 EDT, Radek Vykydal
no flags Details
File: backtrace (1.44 KB, text/plain)
2013-06-11 04:26 EDT, Radek Vykydal
no flags Details
File: environ (614 bytes, text/plain)
2013-06-11 04:26 EDT, Radek Vykydal
no flags Details
File: ifcfg.log (317 bytes, text/plain)
2013-06-11 04:26 EDT, Radek Vykydal
no flags Details
File: lsblk_output (1.19 KB, text/plain)
2013-06-11 04:26 EDT, Radek Vykydal
no flags Details
File: nmcli_dev_list (11.25 KB, text/plain)
2013-06-11 04:26 EDT, Radek Vykydal
no flags Details
File: packaging.log (11.60 KB, text/plain)
2013-06-11 04:27 EDT, Radek Vykydal
no flags Details
File: program.log (42.97 KB, text/plain)
2013-06-11 04:27 EDT, Radek Vykydal
no flags Details
File: storage.log (83.53 KB, text/plain)
2013-06-11 04:27 EDT, Radek Vykydal
no flags Details
File: syslog (101.11 KB, text/plain)
2013-06-11 04:27 EDT, Radek Vykydal
no flags Details
Log from working installation F19 TC2 + anaconda Secret Agent patch + NM downgraded to 0.9.8.1-1.git20130327.f19 (26.21 KB, text/plain)
2013-06-11 06:11 EDT, Radek Vykydal
no flags Details

  None (edit)
Description Radek Vykydal 2013-06-11 04:26:11 EDT
Description of problem:
Happens when testing Anaconda Secret Agent patch with Fedora 19 TC2 (NM 0.9.8.1-4.git20130515.f19). The patch worked with F19 Beta (NM 0.9.8.1-1.git20130327.f19). I also checked that it works if I use the older NM in Fedora 19 TC2.

In NM changelog I see some changes of NMSecretgAgent and nm_conneciton_need_secrets() so perhaps it may be related?
The following was filed automatically by anaconda:
anaconda 19.30.3-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/dbus/connection.py", line 651, in call_blocking
    message, timeout)
  File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 145, in __call__
    **keywords)
  File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 70, in __call__
    return self._proxy_method(*args, **keywords)
  File "/tmp/updates/pyanaconda/ui/gui/spokes/network.py", line 1249, in register_secret_agent
    proxy.Register("anaconda", dbus_interface=AGENT_MANAGER_IFACE)
  File "/tmp/updates/pyanaconda/ui/gui/spokes/network.py", line 1349, in initialize
    register_secret_agent(self)
  File "/tmp/updates/pyanaconda/ui/gui/hubs/__init__.py", line 201, in _createBox
    spoke.initialize()
  File "/tmp/updates/pyanaconda/ui/gui/hubs/__init__.py", line 353, in refresh
    self._createBox()
  File "/tmp/updates/pyanaconda/ui/gui/__init__.py", line 479, in _on_continue_clicked
    nextAction.refresh()
  File "/tmp/updates/pyanaconda/ui/gui/spokes/__init__.py", line 68, in _on_continue_clicked
    cb()
  File "/tmp/updates/pyanaconda/ui/gui/spokes/welcome.py", line 354, in _on_continue_clicked
    StandaloneSpoke._on_continue_clicked(self, cb)
  File "/tmp/updates/pyanaconda/ui/gui/spokes/__init__.py", line 72, in <lambda>
    self.window.connect("continue-clicked", lambda *args: self._on_continue_clicked(cb))
DBusException: org.freedesktop.NetworkManager.AgentManager.SessionNotFound: Session not found

Version-Release number of selected component:
anaconda-19.30.3-1

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=test/rv/f19tc2/initrd.img debug=1 root=live:http://10.34.39.2/trees/rv/f19tc2/squashfs.img repo=http://download.englab.brq.redhat.com/pub/fedora/linux/development/19/i386/os/ updates=http://10.34.39.2/ks/rv/updates.agenterrorf19.img  BOOT_IMAGE=test/rv/f19tc2/vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.4-301.fc19.i686
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19-TC2

Truncated backtrace:
Traceback (most recent call last):
  File "/tmp/updates/pyanaconda/ui/gui/spokes/__init__.py", line 72, in <lambda>
    self.window.connect("continue-clicked", lambda *args: self._on_continue_clicked(cb))
  File "/tmp/updates/pyanaconda/ui/gui/spokes/welcome.py", line 354, in _on_continue_clicked
    StandaloneSpoke._on_continue_clicked(self, cb)
  File "/tmp/updates/pyanaconda/ui/gui/spokes/__init__.py", line 68, in _on_continue_clicked
    cb()
  File "/tmp/updates/pyanaconda/ui/gui/__init__.py", line 479, in _on_continue_clicked
    nextAction.refresh()
  File "/tmp/updates/pyanaconda/ui/gui/hubs/__init__.py", line 353, in refresh
    self._createBox()
  File "/tmp/updates/pyanaconda/ui/gui/hubs/__init__.py", line 201, in _createBox
    spoke.initialize()
  File "/tmp/updates/pyanaconda/ui/gui/spokes/network.py", line 1349, in initialize
    register_secret_agent(self)
  File "/tmp/updates/pyanaconda/ui/gui/spokes/network.py", line 1249, in register_secret_agent
    proxy.Register("anaconda", dbus_interface=AGENT_MANAGER_IFACE)
  File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 70, in __call__
    return self._proxy_method(*args, **keywords)
  File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 145, in __call__
    **keywords)
  File "/usr/lib/python2.7/site-packages/dbus/connection.py", line 651, in call_blocking
    message, timeout)
DBusException: org.freedesktop.NetworkManager.AgentManager.SessionNotFound: Session not found
Comment 1 Radek Vykydal 2013-06-11 04:26:19 EDT
Created attachment 759453 [details]
File: anaconda-tb
Comment 2 Radek Vykydal 2013-06-11 04:26:25 EDT
Created attachment 759454 [details]
File: anaconda.log
Comment 3 Radek Vykydal 2013-06-11 04:26:30 EDT
Created attachment 759455 [details]
File: backtrace
Comment 4 Radek Vykydal 2013-06-11 04:26:35 EDT
Created attachment 759456 [details]
File: environ
Comment 5 Radek Vykydal 2013-06-11 04:26:43 EDT
Created attachment 759457 [details]
File: ifcfg.log
Comment 6 Radek Vykydal 2013-06-11 04:26:50 EDT
Created attachment 759458 [details]
File: lsblk_output
Comment 7 Radek Vykydal 2013-06-11 04:26:56 EDT
Created attachment 759459 [details]
File: nmcli_dev_list
Comment 8 Radek Vykydal 2013-06-11 04:27:01 EDT
Created attachment 759460 [details]
File: packaging.log
Comment 9 Radek Vykydal 2013-06-11 04:27:08 EDT
Created attachment 759461 [details]
File: program.log
Comment 10 Radek Vykydal 2013-06-11 04:27:19 EDT
Created attachment 759462 [details]
File: storage.log
Comment 11 Radek Vykydal 2013-06-11 04:27:25 EDT
Created attachment 759463 [details]
File: syslog
Comment 12 Radek Vykydal 2013-06-11 06:07:03 EDT
Passing to NM for ideas, please see the Description.

Related Anaconda patch: https://git.fedorahosted.org/cgit/anaconda.git/commit/?h=f19-branch&id=d45dbcc6424cb9d925f8f48536332c2e8dae7b55
Comment 13 Radek Vykydal 2013-06-11 06:11:21 EDT
Created attachment 759545 [details]
Log from working installation F19 TC2 + anaconda Secret Agent patch + NM downgraded to 0.9.8.1-1.git20130327.f19
Comment 14 Radek Vykydal 2013-06-11 06:18:41 EDT
Adding Adam Williamson to CC so that he knows about potential crash of F19 TC3 installation (GUI after Welcome Spoke).

Adam, to sum up: the anaconda patch going to TC3 is in comment #12, it stopped working with current update of NetworkManager to 0.9.8.1-4.git20130515.f19.
Comment 15 Adam Williamson 2013-06-11 18:42:34 EDT
radek: thanks for the heads up. The current stable NM, however, is neither of those two, but NetworkManager-0.9.8.2-1.fc19 :

https://admin.fedoraproject.org/updates/FEDORA-2013-10357/NetworkManager-0.9.8.2-1.fc19,network-manager-applet-0.9.8.2-1.fc19

do you know if it works or fails with that? Obviously I don't want to request a TC3 that will be DOA.
Comment 16 Adam Williamson 2013-06-12 01:02:52 EDT
*** Bug 973503 has been marked as a duplicate of this bug. ***
Comment 17 Adam Williamson 2013-06-12 01:06:28 EDT
The smoke test image we built with anaconda 19.30.4 and NM 0.9.8.2-1 does hit this crash, so it's clearly still a problem. Dan, can you please check on this? Thanks.

Proposing as a final blocker, this appears to be a showstopper.
Comment 18 Manfred Blankenfeld 2013-06-12 04:18:21 EDT
Description of problem:
I used netinstall-iso FC19-TC2.1 and LiveCD-FC19-TC2.1

I started both in VirtualBox-4.2.12

After choosing the language, I prefer, there comes a bug-window.

I click Report and send the bug to bugzilla.

Then I click Debug, the bug-window closes and now I see tty1 or tty2 text.

TC2-netinstall and TC2-LiveCD have no problems - no bug

Manfred

Version-Release number of selected component:
anaconda-19.30.4-1

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2019-TC2.1\x20x86_64 rd.live.check quiet BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.4-301.fc19.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19-TC2.1

Truncated backtrace:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/__init__.py", line 72, in <lambda>
    self.window.connect("continue-clicked", lambda *args: self._on_continue_clicked(cb))
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/welcome.py", line 356, in _on_continue_clicked
    StandaloneSpoke._on_continue_clicked(self, cb)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/__init__.py", line 68, in _on_continue_clicked
    cb()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/__init__.py", line 479, in _on_continue_clicked
    nextAction.refresh()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 353, in refresh
    self._createBox()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 201, in _createBox
    spoke.initialize()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/network.py", line 1349, in initialize
    register_secret_agent(self)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/network.py", line 1249, in register_secret_agent
    proxy.Register("anaconda", dbus_interface=AGENT_MANAGER_IFACE)
  File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 70, in __call__
    return self._proxy_method(*args, **keywords)
  File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 145, in __call__
    **keywords)
  File "/usr/lib/python2.7/site-packages/dbus/connection.py", line 651, in call_blocking
    message, timeout)
DBusException: org.freedesktop.NetworkManager.AgentManager.SessionNotFound: Session not found
Comment 19 Dan Mashal 2013-06-12 04:39:29 EDT
TC2.1 crashed instantly, I ran TC2 right after that and it was fine. (netinstall)

I don't know if that was the answer you were looking for.
Comment 20 Dan Mashal 2013-06-12 04:40:48 EDT
I would take the TC2.1 smoke image off the mirrors.
Comment 21 Adam Williamson 2013-06-12 12:35:48 EDT
Discussed at 2013-06-12 blocker review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-06-12/f19final-blocker-review-5.2013-06-12-16.01.log.txt . Accepted as a blocker per Final criterion "The installer must be able to complete an installation using all supported interfaces" (or any one of lots of others, this is just a showstopper).
Comment 22 Dan Winship 2013-06-12 13:14:43 EDT
The error means that (a) you're not running as root, and (b) systemd doesn't know of any login session involving your uid, so NM decides you're a background process and doesn't let you register an agent. The reason it worked before is because there was a bug in configure.ac that was causing systemd support to get disabled, so NM didn't bother to do session tracking...

Anyway, the fix is to make sure that anaconda is in a systemd login session... I don't really know exactly what that entails.
Comment 23 Adam Williamson 2013-06-12 14:17:27 EDT
So it's back on anaconda? Re-assigning back to Radek, then. Thanks.
Comment 24 Adam Williamson 2013-06-12 14:18:35 EDT
The anaconda patch was reverted in commit fa1d8ece6e62f101519fb910e168a6db31972da3 , which effectively resolves the 'blocker' status of this bug. But we probably don't want to mark it as MODIFIED since really we should fix the patch, not revert it, so just recording the state of play.
Comment 25 Radek Vykydal 2013-06-13 06:01:37 EDT
(In reply to Dan Winship from comment #22)

Ah, I was looking at wrong NM branch (master) which made me think private dbus socket support plus the commit below are in for F19:

commit 10dc8e78cad7835301669dadc2dceb985b0e6d26
Author: Dan Williams <dcbw@redhat.com>
Date:   Sun Dec 16 11:46:06 2012 -0600

    agents: don't require root agents to be part of a login session
    
    Which they won't always be in minimal environments.

diff --git a/src/settings/nm-agent-manager.c b/src/settings/nm-agent-manager.c
index e61c7f1..2992354 100644
--- a/src/settings/nm-agent-manager.c
+++ b/src/settings/nm-agent-manager.c
@@ -280,10 +280,11 @@ impl_agent_manager_register (NMAgentManager *self,
                goto done;
        }
 
-       if (!nm_session_monitor_uid_has_session (priv->session_monitor,
-                                                sender_uid,
-                                                NULL,
-                                                &local)) {
+       if (   0 != sender_uid
+           && !nm_session_monitor_uid_has_session (priv->session_monitor,
+                                                   sender_uid,
+                                                   NULL,
+                                                   &local)) {
                error = g_error_new_literal (NM_AGENT_MANAGER_ERROR,
                                             NM_AGENT_MANAGER_ERROR_SESSION_NOT_FOUND,
                                             local && local->message ? local->message : "Session not found");


... This code would work (anaconda's sender_uid being 0), but actually as you said, anaconda's Secret Agent actually worked in my tests with F19Beta because nm_session_monitor_uid_has_session using systemd was not plugged in.


> Anyway, the fix is to make sure that anaconda is in a systemd login
> session... I don't really know exactly what that entails.

We'll wait till the mentioned NM patch (not requiring the session) gets in.
Comment 26 Radek Vykydal 2013-06-13 07:32:59 EDT
*** Bug 974049 has been marked as a duplicate of this bug. ***
Comment 27 Radek Vykydal 2013-06-13 07:43:23 EDT
(In reply to Adam Williamson from comment #24)
> The anaconda patch was reverted in commit
> fa1d8ece6e62f101519fb910e168a6db31972da3

The revert didn't make it in TC3 (it will be in anaconda-19.30.5-1), updates image with revert for TC3:
http://rvykydal.fedorapeople.org/updates.f19tc3revertSessionNotFound.img
Comment 28 Kamil Páral 2013-06-13 08:25:07 EDT
Description of problem:
I booted F19 TC3 netinst x86_64 and hit Continue on the initial screen. Then this bug appeared. Reproduced 2 out of 2 attempts.

Version-Release number of selected component:
anaconda-19.30.4-1

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2019-TC3\x20x86_64 quiet BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.4-301.fc19.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19-TC3

Truncated backtrace:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/__init__.py", line 72, in <lambda>
    self.window.connect("continue-clicked", lambda *args: self._on_continue_clicked(cb))
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/welcome.py", line 356, in _on_continue_clicked
    StandaloneSpoke._on_continue_clicked(self, cb)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/__init__.py", line 68, in _on_continue_clicked
    cb()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/__init__.py", line 479, in _on_continue_clicked
    nextAction.refresh()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 353, in refresh
    self._createBox()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 201, in _createBox
    spoke.initialize()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/network.py", line 1349, in initialize
    register_secret_agent(self)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/network.py", line 1249, in register_secret_agent
    proxy.Register("anaconda", dbus_interface=AGENT_MANAGER_IFACE)
  File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 70, in __call__
    return self._proxy_method(*args, **keywords)
  File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 145, in __call__
    **keywords)
  File "/usr/lib/python2.7/site-packages/dbus/connection.py", line 651, in call_blocking
    message, timeout)
DBusException: org.freedesktop.NetworkManager.AgentManager.SessionNotFound: Session not found
Comment 29 Kamil Páral 2013-06-13 08:29:52 EDT
(In reply to Radek Vykydal from comment #27)
> The revert didn't make it in TC3 (it will be in anaconda-19.30.5-1), updates
> image with revert for TC3:
> http://rvykydal.fedorapeople.org/updates.f19tc3revertSessionNotFound.img

TC3 with this updates.img seems to work fine. A shorter name would be appreciated :-)
Comment 30 Radek Vykydal 2013-06-13 08:37:31 EDT
(In reply to Kamil Páral from comment #29)
 
> TC3 with this updates.img seems to work fine. A shorter name would be
> appreciated :-)

http://rvykydal.fedorapeople.org/updates.rsession.img
Comment 31 Manfred Blankenfeld 2013-06-13 09:19:42 EDT
TC3-netinstall is unusable, because 3 packages need beta2-progs, these are only in updates-testing.

But including updates-testing shows conflicts between sssd and other sssd-progs.

ManfredB
Comment 32 Adam Williamson 2013-06-13 11:39:10 EDT
manfred: that's just an issue in the repos. It should be resolved soon. Nothing wrong with the image.

rvykydal: TC3 is supposed to include 19.30.5, that's what I listed in the compose request:

https://fedorahosted.org/rel-eng/ticket/5623#comment:5

did it get missed?
Comment 33 Kamil Páral 2013-06-13 12:01:59 EDT
TC3 contains 19.30.4
Comment 34 Adam Williamson 2013-06-13 12:04:25 EDT
Andre says his has 19.30.5...are you sure you don't have TC2.1?
Comment 35 Kamil Páral 2013-06-13 12:32:46 EDT
Unfortunately after a day-long testing I found out that my TC3 is not your TC3 :-/ It was and old version that have been replaced, with no name change or announcement. Probably many people in Brno were affected.
Comment 36 Adam Williamson 2013-06-13 14:55:12 EDT
The 'old' version was never announced. Release engineering specifically state that you should not download images until they give the all-clear and Andre sends out the release announcement; up to that point, they are still working on the compose. At the very least, if you're going to download images early, check in #fedora-releng with dgilmore that they are good.
Comment 37 Dan Winship 2013-06-13 15:01:36 EDT
We are no longer planning to get NM 0.9.10 into F19, but we can backport the features that anaconda needs. For F19 that ended up only being the "root doesn't have to be in a session" patches, right? (And in particular, *not* the changes to allow using a private dbus bus instead of running dbus-daemon.)
Comment 38 Adam Williamson 2013-06-13 15:06:38 EDT
It would be nice to have this feature in anaconda, if the NM change isn't too disruptive. For the record, you have five days till the final freeze (06-18); we probably wouldn't want to poke NM after the freeze just to take this change.
Comment 39 Radek Vykydal 2013-06-14 03:32:24 EDT
Yes, those "root doesn't have to be in session" patches should be sufficient for Anaconda. We'd like to have them in F19 if it seems safe from NM side at this point. On the optimistic note, the change has already get some testing from Anaconda side thanks to the behaviour of nmce in F19 Beta having (IMHO) the same effect for Anaconda: passing the "has a session" condition mentioned in comment #25.
Comment 40 Fedora Update System 2013-06-14 13:19:39 EDT
NetworkManager-0.9.8.2-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/NetworkManager-0.9.8.2-2.fc19
Comment 41 Fedora Update System 2013-06-15 13:06:07 EDT
Package NetworkManager-0.9.8.2-2.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing NetworkManager-0.9.8.2-2.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-10907/NetworkManager-0.9.8.2-2.fc19
then log in and leave karma (feedback).
Comment 42 Radek Vykydal 2013-06-17 04:55:24 EDT
Thanks, I can confirm F19 TC3 with anaconda secret agent patch and NetworkManager-0.9.8.2-2.fc19 works.
Comment 43 Fedora Update System 2013-06-18 02:13:09 EDT
NetworkManager-0.9.8.2-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.