Bug 973543 - libvirtd 1.0.6 refuses to start
libvirtd 1.0.6 refuses to start
Status: CLOSED NEXTRELEASE
Product: Virtualization Tools
Classification: Community
Component: libvirt (Show other bugs)
unspecified
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Ján Tomko
:
Depends On:
Blocks: 975378
  Show dependency treegraph
 
Reported: 2013-06-12 04:07 EDT by Franky Van Liedekerke
Modified: 2013-06-18 06:16 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-12 05:10:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Franky Van Liedekerke 2013-06-12 04:07:02 EDT
Description of problem:

I just downloaded and compiled libvirtd on the same EL6 server as I did 1.0.4. Upon updating, libvirtd refuses to start, with this in the logfile (obfuscated the hostname by xxx's):

2013-06-11 13:43:49.154+0000: 3336: info : libvirt version: 1.0.6, package: 1.el6 (Unknown, 2013-06-06-14:57:07, xxxxxxxx)
2013-06-11 13:43:49.154+0000: 3336: error : virFileReadAll:1195 : Failed to open file '/sys/class/fc_host//host0/max_npiv_vports': No such file or directory
2013-06-11 13:43:49.159+0000: 3336: error : detect_scsi_host_caps:87 : Failed to read max_npiv_vports for host1
2013-06-11 13:43:49.163+0000: 3336: error : virFileReadAll:1195 : Failed to open file '/sys/class/fc_host//host0/max_npiv_vports': No such file or directory
2013-06-11 13:43:49.163+0000: 3336: error : detect_scsi_host_caps:87 : Failed to read max_npiv_vports for host2
2013-06-11 13:43:49.386+0000: 3336: error : virLockManagerPluginNew:175 : Failed to load plugin /usr/lib64/libvirt/lock-driver/lockd.so: /usr/lib64/libvirt/lock-driver/lockd.so: undefined symbol: virProcessGetStartTime
2013-06-11 13:43:49.386+0000: 3336: error : virStateInitialize:831 : Initialization of QEMU state driver failed
2013-06-11 13:43:49.386+0000: 3336: error : daemonRunStateInit:887 : Driver state initialization failed

So it seems two issues are present here:

1) it searches for /sys/class/fc_host//host0/max_npiv_vports for both host1 and host2. Imho this path needs to be /sys/class/fc_host//host1/max_npiv_vports and /sys/class/fc_host//host2/max_npiv_vports respectively.

2) the undefined symbol problem: seems a linking issue, no? The build worked just fine on rhel6 with all patches applied.

For now I reverted back to 1.0.4. Hope this helps to debug :-)

Also: I created a bug report for 1.0.4/1.0.6 concerning the init scripts:
https://bugzilla.redhat.com/show_bug.cgi?id=971408
Part of it (the virtlock socket) seems to be in the latest code already, but I believe the other issues mentioned are valid as well.

With friendly regards,

Franky
Comment 1 Ján Tomko 2013-06-12 04:53:56 EDT
1) I've posted patch that should fix this:
https://www.redhat.com/archives/libvir-list/2013-June/msg00515.html

2) Fix for this is already committed upstream:
commit cbb3b71d3f537ead2b3081a06abd12292d0ceef3
Author:     Ján Tomko <jtomko@redhat.com>
AuthorDate: 2013-06-12 10:13:29 +0200
Commit:     Ján Tomko <jtomko@redhat.com>
CommitDate: 2013-06-12 10:13:29 +0200

    libvirt_private.syms: add virProcessGetStartTime
    
    https://bugzilla.redhat.com/show_bug.cgi?id=973543

git describe: v1.0.6-64-gcbb3b71
Comment 2 Ján Tomko 2013-06-12 05:10:20 EDT
Fix for 1) is now committed upstream and will be a part of 1.0.7:

commit 371c15517c919e9d7d2ea3f66e490bd49b6db384
Author:     Ján Tomko <jtomko@redhat.com>
AuthorDate: 2013-06-12 10:30:13 +0200
Commit:     Ján Tomko <jtomko@redhat.com>
CommitDate: 2013-06-12 11:08:45 +0200

    nodedev: fix vport detection for FC HBA
    
    Use the host number as the host number when constructing the sysfs path
    instead of the variable we are trying to fill.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=973543

git describe: v1.0.6-65-g371c155

Note You need to log in before you can comment on or make changes to this bug.