Bug 9736 - maildir patch for Pine is bogus
maildir patch for Pine is bogus
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: pine (Show other bugs)
6.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: pine
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-02-24 01:47 EST by wingc
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-04-27 11:52:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description wingc 2000-02-24 01:47:37 EST
The 'maildir' patch included in the Red Hat 6.1 and 6.2beta pine RPM causes
some very undesirable behavior. It causes pine to do a recursive stat of
files in your home directory.

If you have a recursive symlink in your home directory, Pine will die
instantly when you ask for a folder list:


redhat6.2% cd
redhat6.2% ln -s ~ maildirsucks
redhat6.2% pine

[ press 'l' ]



Problem detected: "Received abort signal".
Pine Exiting.



If you strace pine, you will notice that it is trying to recursively stat
every file in your home directory up to 3 levels deep.

This is bad.

If your home directory has a lot of files in it, and is mounted over a
network, this is unbelieveably bad.



This either needs to get fixed, or else the maildir patch should be removed
from Pine. (isn't the patch really intended to be used on the server end,
anyway?)


Thanks,

Chris Wing
wingc@engin.umich.edu
Comment 1 Trond Eivind Glomsrxd 2000-04-11 12:24:59 EDT
I can't reproduce it like that, but:

Add a new user

Make a symlink, "ln -s ~ foobar"

Run pine to create the mail directory

exit pine

Go to $HOME/mail

Make a new symlink:

ln -s ~ foobar

Go to your home directory

Run pine, use "l"
Comment 2 Trond Eivind Glomsrxd 2000-04-27 11:52:59 EDT
I've removed the maildir patches - look for 4.21-13 or higher in the next
rawhide
Comment 3 david 2000-10-01 18:11:11 EDT
Fixed in Bug # 18038.

Note You need to log in before you can comment on or make changes to this bug.