Bug 18038 - Maildir patches taken out of RedHat 7 because of bug: Now fixed.
Maildir patches taken out of RedHat 7 because of bug: Now fixed.
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: pine (Show other bugs)
7.0
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Mike A. Harris
http://summersoft.fay.ar.us/pub/linux...
Enhancement request
: FutureFeature
: 30948 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-01 18:05 EDT by david
Modified: 2008-05-01 11:37 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-18 04:21:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description david 2000-10-01 18:05:56 EDT
I noticed that the Maildir patches were taken out of RedHat 7
(pine-4.21-23) because of a bug (Bug # 9736) in recursive stat'ing of
files.  I have verified this bug and provided a fix for it at
http://summersoft.fay.ar.us/pub/linux/RPMS/src/pine-4.21-23mdir2.src.rpm. 
This fix takes
care of the problem reported in Bug # 9736.  Please re-add the maildir
patches (with the appropriate fix provided here).  They are useful for
client as well as server systems. 

Thanks also for making it so that sendmail doesn't get installed over
another MTA in RedHat 7.0.  That  really makes things a lot easier.
Comment 1 Trond Eivind Glomsrxd 2000-10-02 15:53:39 EDT
Thanks, I'll look into it.
Comment 2 Trond Eivind Glomsrxd 2000-10-04 18:01:13 EDT
The site is hard to connect to...
Comment 3 Trond Eivind Glomsrxd 2000-10-17 17:29:48 EDT
Can't find it there.
Comment 4 david 2000-10-18 17:19:37 EDT
Woops, I probably moved them to another directory.  The link is now there 
again. Sorry for the problems.
Comment 5 Mike A. Harris 2000-12-08 17:13:41 EST
Are these patches still valid for PINE 4.31?
If so, please email me them, with details as I'm not familiar with
what they are for, etc.. but if it is useful, I will consider putting
it in my PINE 4.31 packages.
Comment 6 david 2000-12-10 04:06:17 EST
Please check out http://summersoft.fay.ar.us/pub/qmail/qmail-pine for the
current
pine-4.30-2mdir1 and imap-2000-3mdir2 source and binary RPMS.  These patches
allow QMAIL users to have a qmail Mailbox file or Maildir directory.  You might
decide
not to put the patch in that changes the default mailbox to ~/Mailbox and
instead let
the user configure that in his /etc/pine* files or ~/.pinerc file.  But if you
put in the Maildir
patches then people can configure for "regular" mail or for qmail Mailbox file
or
Maildir directory.
Let me know if I can answer any more questions.
Comment 7 Mike A. Harris 2001-03-08 10:49:20 EST
*** Bug 30948 has been marked as a duplicate of this bug. ***
Comment 8 Need Real Name 2001-03-09 15:19:31 EST
A patch for version 4.33 is avail:
http://qmail.org/pine-maildir-4.33
Comment 9 Philip Guenther 2001-03-26 00:35:59 EST
Both of the patches linked to by previous comments are *broken*.  They're both
based on the same patch originally written by Mattias Larsson <ml@techno.org>
for imap-4.5.  Having stared at the patch I see at least the following problems:

1) maildir_append() must be updated to match the new driver interface in
imap-2000 (may crash server right now because the call doesn't match the
declaration)

2) the sorting code incorrectly sorts on the filename of the messages.  This
violates the maildir standard (http://cr.yp.to/proto/maildir.html).  It should
sort first on the UID (if already assigned), then on the mtime of the message
file, putting messages that haven't been assigned a UID last.  If you doubt the
correctness of that, then email Dan Bernstein and ask him how to do it, but the
current code is definitely wrong.

3) It doesn't always check return codes (for example, of stat())

4) Speaking of stat(), when scanning a maildir it stat()s every file twice.  It
should cache the needed info from when it first sorts the messages.

5) The original version of the patch used a non-standard 'info' component for
the message files ":3,".  That caused interoperability problems so it now works
with the standard ":2,".  However, it still gives new messages the ":3," bit
instead of the ":2,", i.e., the change over wasn't complete.
Comment 10 Mike A. Harris 2001-05-18 04:30:11 EDT
After looking into this several times, reading the various patches and
comments noted above, and playing with the code a bit, I am not satisfied
with the results.  The patch seems hackish to me, and hasn't had a very
good track record from my findings.  It was removed because it was broken,
among other reasons, and IMHO it is still broken as commented above.
The IMAP 2000 documentation discusses Maildir, and the reasoning of why
it isn't included in the first place.  It also mentions that cyrus-imapd
has Maildir support, and as such it is recommended that if you need Maildir
to use cyrus-imapd instead.

We include cyrus-imapd on our powertools CD, although I do not know if it
is built to support Maildir or not as I know nothing about it.

Considering these many factors, along with recommendations of people whom
I've discussed this request with, have made me decide that the Maildir
patch is not a viable feature to add to our imap packages at this time.

Please use cyrus-imapd instead if you require Maildir support.

Thanks.

Note You need to log in before you can comment on or make changes to this bug.