This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 973703 - RHEL-7/F-19 does not work on 6.4 qemu-kvm + spice: assert "red_create_surface: Untested path stride >= 0" failed
RHEL-7/F-19 does not work on 6.4 qemu-kvm + spice: assert "red_create_surface...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: spice-server (Show other bugs)
6.4
Unspecified Unspecified
high Severity medium
: rc
: ---
Assigned To: Uri Lublin
Desktop QE
: ZStream
Depends On: 952666
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-12 10:17 EDT by Jan Kurik
Modified: 2013-07-10 08:07 EDT (History)
19 users (show)

See Also:
Fixed In Version: spice-server-0.12.0-12.el6_4.2
Doc Type: Bug Fix
Doc Text:
Previously, qemu-kvm terminated with the following error message, "((null):3635): SpiceWorker-CRITICAL **: red_worker.c:9306:red_create_surface: Untested path stride >= 0." The spice-server did not allow creation of a surface with "stride >= 0," as this path of code was untested, and no qxl driver did this before. On some systems, spice-server terminated when the qxl driver tried creating a surface with the "stride >= 0" path. With this update, spice-server no longer checks for the "stride >=0" path, and VMs with qxl devices are able to run and use their qxl driver.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-10 08:07:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Kurik 2013-06-12 10:17:12 EDT
This bug has been copied from bug #952666 and has been proposed
to be backported to 6.4 z-stream (EUS).
Comment 4 Uri Lublin 2013-06-20 04:56:27 EDT
Using the exact same patch that fixed the original bug.
Comment 8 errata-xmlrpc 2013-07-10 08:07:04 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1037.html

Note You need to log in before you can comment on or make changes to this bug.