Bug 973765 - Guided Editor overflows window width in Google Chrome
Guided Editor overflows window width in Google Chrome
Status: CLOSED CURRENTRELEASE
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
high Severity medium
: ER5
: 6.0.0
Assigned To: Toni Rikkola
Jiri Locker
:
: 975917 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-12 12:20 EDT by Jiri Locker
Modified: 2014-08-06 16:16 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Summary: While using Google Chrome, the Guided Editor overflows window width and prevents the user from being able to view the right-side buttons for adding, moving, and deleting LHS and RHS elements. Cause: While opening an existing .gre.drl or .gre.dslr rule in the Guided Editor, the Chrome browser hides the right-side buttons for LHS and RHS elements. When creating a new .gre.drl or .gre.dslr rule, the green plus buttons are visible within the visible window in Google Chrome; however, adding any LHS (WHEN) or RHS (THEN) element will move the green plus buttons outside of the visible window. Consequence: The overflowed window width in the Google Chrome browser encumbers the user from being able to select the LHS and RHS element buttons. Workaround: A current workaround is to open Guided Editor with a Firefox browser while working with .gre.drl or .gre.dslr rules. Result: Using the Firefox browser allows the user to select the right-side buttons for adding, moving, and deleting LHS and RHS elements.
Story Points: ---
Clone Of:
Environment:
Google Chrome 27 @ Fedora 17, Safari 5.1.3 @ Mac OS 10.7.3
Last Closed: 2014-08-06 16:16:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
CreditApproval.png (65.83 KB, image/png)
2013-06-12 12:20 EDT, Jiri Locker
no flags Details

  None (edit)
Description Jiri Locker 2013-06-12 12:20:28 EDT
Created attachment 760255 [details]
CreditApproval.png

Description of problem:
The right-side buttons for adding, moving and removing LHS and RHS elements are out of the browser window and cannot be clicked at.

Version-Release number of selected component (if applicable):
DR5 (Beta3)

How reproducible:
always (in Google Chrome)

Steps to Reproduce:
1. open existing .gre.drl or .gre.dslr rule

OR

1. create a new one (green plus buttons are visible)
2. add any LHS (WHEN) or RHS (THEN) element, buttons will be moved outside the window
Comment 1 manstis 2013-06-13 06:44:09 EDT
FF seems OK. Need to check Chrome.

Jiri, are you able to try any other browsers?
Comment 2 Jiri Locker 2013-06-13 08:37:14 EDT
Same issue with Safari 5. I will probably not be able to check IE anytime soon.
Comment 3 Jiri Locker 2013-06-26 09:32:43 EDT
*** Bug 975917 has been marked as a duplicate of this bug. ***
Comment 7 Jiri Locker 2013-10-15 10:17:59 EDT
Still reproducing (with Chrome updated to 29.0.1547.76).

Note You need to log in before you can comment on or make changes to this bug.