Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 973792 - [abrt] colord-1.0.0-1.fc19: cd_main_start_calibration_cb: Process /usr/libexec/colord-session was killed by signal 11 (SIGSEGV)
[abrt] colord-1.0.0-1.fc19: cd_main_start_calibration_cb: Process /usr/libexe...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: colord (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
abrt_hash:b404b8c6637de8c949938b70a90...
:
: 995351 1026727 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-12 14:30 EDT by Paul Finnigan
Modified: 2013-12-27 00:59 EST (History)
3 users (show)

See Also:
Fixed In Version: colord-1.1.5-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-16 17:59:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (83.17 KB, text/plain)
2013-06-12 14:30 EDT, Paul Finnigan
no flags Details
File: cgroup (140 bytes, text/plain)
2013-06-12 14:30 EDT, Paul Finnigan
no flags Details
File: core_backtrace (551 bytes, text/plain)
2013-06-12 14:30 EDT, Paul Finnigan
no flags Details
File: dso_list (2.81 KB, text/plain)
2013-06-12 14:30 EDT, Paul Finnigan
no flags Details
File: environ (1.00 KB, text/plain)
2013-06-12 14:30 EDT, Paul Finnigan
no flags Details
File: limits (1.29 KB, text/plain)
2013-06-12 14:30 EDT, Paul Finnigan
no flags Details
File: maps (13.76 KB, text/plain)
2013-06-12 14:31 EDT, Paul Finnigan
no flags Details
File: open_fds (607 bytes, text/plain)
2013-06-12 14:31 EDT, Paul Finnigan
no flags Details
File: proc_pid_status (931 bytes, text/plain)
2013-06-12 14:31 EDT, Paul Finnigan
no flags Details
File: var_log_messages (320 bytes, text/plain)
2013-06-12 14:31 EDT, Paul Finnigan
no flags Details

  None (edit)
Description Paul Finnigan 2013-06-12 14:30:35 EDT
Description of problem:
I was attemting to create a profile for my printer using a Color-Munki.

Version-Release number of selected component:
colord-1.0.0-1.fc19

Additional info:
reporter:       libreport-2.1.4
backtrace_rating: 4
cmdline:        /usr/libexec/colord-session
crash_function: cd_main_start_calibration_cb
executable:     /usr/libexec/colord-session
kernel:         3.9.4-301.fc19.x86_64
runlevel:       N 5
uid:            1000

Truncated backtrace:
Thread no. 1 (1 frames)
 #0 cd_main_start_calibration_cb at cd-main.c:1539
Comment 1 Paul Finnigan 2013-06-12 14:30:39 EDT
Created attachment 760287 [details]
File: backtrace
Comment 2 Paul Finnigan 2013-06-12 14:30:41 EDT
Created attachment 760288 [details]
File: cgroup
Comment 3 Paul Finnigan 2013-06-12 14:30:44 EDT
Created attachment 760289 [details]
File: core_backtrace
Comment 4 Paul Finnigan 2013-06-12 14:30:50 EDT
Created attachment 760290 [details]
File: dso_list
Comment 5 Paul Finnigan 2013-06-12 14:30:53 EDT
Created attachment 760291 [details]
File: environ
Comment 6 Paul Finnigan 2013-06-12 14:30:58 EDT
Created attachment 760292 [details]
File: limits
Comment 7 Paul Finnigan 2013-06-12 14:31:01 EDT
Created attachment 760293 [details]
File: maps
Comment 8 Paul Finnigan 2013-06-12 14:31:04 EDT
Created attachment 760294 [details]
File: open_fds
Comment 9 Paul Finnigan 2013-06-12 14:31:06 EDT
Created attachment 760295 [details]
File: proc_pid_status
Comment 10 Paul Finnigan 2013-06-12 14:31:09 EDT
Created attachment 760296 [details]
File: var_log_messages
Comment 11 Ferry Huberts 2013-07-03 06:32:08 EDT
Tried to calibrate my W520 laptop screen with a ColorMunki
Comment 12 Ferry Huberts 2013-07-18 09:26:52 EDT
Newest update still doesn't work.
After being told to turn off calibration mode on the ColorMunki and pressing resume it sets there doing nothing. Pressing cancel makes it crash.

Richard, please make this work ;-)
Comment 13 Ferry Huberts 2013-07-18 09:27:50 EDT
sets --> sits
Comment 14 kartochka22 2013-10-21 15:21:34 EDT
Got same in F19 and just updated F20 Beta. Please, Color Munki unusable  with standard GNOME color tools, command line argillcms work ok, but I want glamour "from box" of GNOME 3. Scenario is same, as soon as it ask to switch device to "self calibration" position and press next, it just do nothing (after pressing "Next"). After many time waiting i press only visible "cancel" button and got that crash. please fix it or make hints what debug steps I must do to help to solve it.
Comment 15 kartochka22 2013-11-27 11:10:22 EST
Tested with F20 TC3 (colord-1.1.4-1.fc20), same issue.
Comment 16 Richard Hughes 2013-12-10 03:35:20 EST
*** Bug 1026727 has been marked as a duplicate of this bug. ***
Comment 17 Richard Hughes 2013-12-10 04:22:00 EST
commit e7602b18193c1101661b3034da6ae5b81935a9fd
Author: Richard Hughes <richard@hughsie.com>
Date:   Tue Dec 10 09:21:33 2013 +0000

    session-helper: Do not crash when moving the sensor position
    
    Hopefully fixes: https://bugzilla.redhat.com/show_bug.cgi?id=973792

:100644 100644 6aa2826... 9d35f2c... M  contrib/session-helper/cd-main.c
Comment 18 Richard Hughes 2013-12-10 04:38:34 EST
Can you try with the packages here please? http://koji.fedoraproject.org/koji/taskinfo?taskID=6275126
Comment 19 Richard Hughes 2013-12-10 05:02:22 EST
*** Bug 995351 has been marked as a duplicate of this bug. ***
Comment 20 Paul Finnigan 2013-12-10 05:34:16 EST
Richard,

Installed all packages and ran a Low Quality monitor calibration without problems. It all went well.

I have not had time to try anything else out but will as soon as I can.

Thanks
Comment 21 kartochka22 2013-12-10 11:33:09 EST
Confirmed, it works. Rawhide + http://koji.fedoraproject.org/koji/taskinfo?taskID=6275126. Thanks a lot.
Comment 22 Paul Finnigan 2013-12-11 04:24:32 EST
I have now tested it on two machines and it works OK. I have managed to perform Low, Medium and High quality calibrations. 

There are some issues but they appear to be unrelated, for example you need to disconnect the colormunki USB cable before performing a second calibration. I will report these as new bugs as soon as I can.
Comment 23 Ferry Huberts 2013-12-11 04:43:18 EST
Richard, can you roll out this patch on F19 too please?
Comment 24 Richard Hughes 2013-12-11 04:45:25 EST
Great, thanks for the quick testing. I'll roll a new release today.
Comment 25 Fedora Update System 2013-12-11 06:56:27 EST
colord-1.1.5-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/colord-1.1.5-1.fc20
Comment 26 Fedora Update System 2013-12-11 10:37:20 EST
colord-1.0.5-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/colord-1.0.5-2.fc19
Comment 27 Fedora Update System 2013-12-11 11:45:32 EST
Package colord-1.1.5-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing colord-1.1.5-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-23168/colord-1.1.5-1.fc20
then log in and leave karma (feedback).
Comment 28 Fedora Update System 2013-12-16 17:59:26 EST
colord-1.0.5-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 29 Fedora Update System 2013-12-27 00:59:32 EST
colord-1.1.5-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.