Bug 995351 - Color-Munki Not calibrating Screen
Color-Munki Not calibrating Screen
Status: CLOSED DUPLICATE of bug 973792
Product: Fedora
Classification: Fedora
Component: gnome-color-manager (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-09 03:28 EDT by Paul Finnigan
Modified: 2013-12-10 05:02 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-10 05:02:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Finnigan 2013-08-09 03:28:48 EDT
Description of problem:


Version-Release number of selected component (if applicable):3.8.2-1.fc19
and colord 1.0.2-1.fc19


How reproducible:Every time. Tried two installations


Steps to Reproduce:
1.Plug in Clor-Munki
2.Color setting window appears, Select monitor
3.Select calibrate
4.Select default options (Medium,LCD) and continue until prompted to place device on screen.
5.If device in clibrate position prompted to put in surface after initial white box. If in surface prompted to put into calibrate. Both messages say to press continue. No continue on screen but press "Resume" and nothing else happens. 

Actual results:
Nothion

Expected results:
Calibrated monitor

Additional info:
Messages all over the system log re JS error on line 787 eg:
Aug  9 08:03:36 ewing kernel: [ 1523.760210] usb 7-3: new full-speed USB device number 2 using ohci_hcd
Aug  9 08:03:36 ewing kernel: [ 1523.908006] usb 7-3: New USB device found, idVendor=0971, idProduct=2007
Aug  9 08:03:36 ewing kernel: [ 1523.908013] usb 7-3: New USB device strings: Mfr=1, Product=2, SerialNumber=0
Aug  9 08:03:36 ewing kernel: [ 1523.908018] usb 7-3: Product: colormunki
Aug  9 08:03:36 ewing kernel: [ 1523.908022] usb 7-3: Manufacturer: X-Rite
Aug  9 08:03:37 ewing colord: Sensor added: color-munki-photo-00
Aug  9 08:03:37 ewing gnome-session[2227]: JS ERROR: !!!   Invalid work id 6
Aug  9 08:03:37 ewing gnome-session[2227]: JS ERROR: !!!     message = '"Invalid work id 6"'
Aug  9 08:03:37 ewing gnome-session[2227]: JS ERROR: !!!     fileName = '"/usr/share/gnome-shell/js/ui/main.js"'
Aug  9 08:03:37 ewing gnome-session[2227]: JS ERROR: !!!     lineNumber = '787'
Aug  9 08:03:37 ewing gnome-session[2227]: JS ERROR: !!!     stack = '"queueDeferredWork("6")@/usr/share/gnome-shell/js/ui/main.js:787
Aug  9 08:03:37 ewing gnome-session[2227]: ([object GObject_Object],[object GObject_Object])@/home/paul/.local/share/gnome-shell/extensions/dash-to-dock@micxgx.gmail.com/myDash.js:170
Aug  9 08:03:37 ewing gnome-session[2227]: wrapper([object GObject_Object],[object GObject_Object])@/usr/share/gjs-1.0/lang.js:213
Aug  9 08:03:37 ewing gnome-session[2227]: "'
Comment 1 Paul Finnigan 2013-08-15 04:00:29 EDT
Ran in verbose mode:

[#@# ~]$ gnome-control-center --verbose color
** (gnome-control-center:4072): DEBUG: Enabling debugging
** (gnome-control-center:4072): DEBUG: No extra argument
(gnome-control-center:4072): color-cc-panel-DEBUG: device selected
(gnome-control-center:4072): color-cc-panel-DEBUG: selected device is: xrandr-KDS USA-KL2200DW-KDS2200
(gnome-control-center:4072): color-cc-panel-DEBUG: ColorMunki(lcd) is supported
(gnome-control-center:4072): color-cc-panel-DEBUG: ColorMunki(led) is not-supported
(gnome-control-center:4072): color-cc-panel-DEBUG: ColorMunki(crt) is supported
(gnome-control-center:4072): color-cc-panel-DEBUG: ColorMunki(projector) is supported
(gnome-control-center:4072): color-cc-panel-DEBUG: ColorMunki(plasma) is not-supported
(gnome-control-center:4072): color-cc-panel-DEBUG: System inhibitor fd is 17
(gnome-control-center:4072): color-cc-panel-DEBUG: Setting window to 0x0 with size 1680x1050
(gnome-control-center:4072): color-cc-panel-DEBUG: Interaction required type 0: attach the sensor to the screen
(gnome-control-center:4072): color-cc-panel-DEBUG: showing image /usr/share/colord/icons/color-munki-photo-attach.svg
(gnome-control-center:4072): color-cc-panel-DEBUG: Setting window to 0x0 with size 1680x1050
(gnome-control-center:4072): color-cc-panel-DEBUG: Setting window to 0x0 with size 1680x1050
(gnome-control-center:4072): color-cc-panel-DEBUG: Interaction required type 2: move the sensor to the surface position
(gnome-control-center:4072): color-cc-panel-DEBUG: showing image /usr/share/colord/icons/color-munki-photo-screen.svg

(gnome-control-center:4072): color-cc-panel-WARNING **: Failed to send Resume: GDBus.Error:org.freedesktop.ColorHelper.Internal: cannot resume as status is idle

(gnome-control-center:4072): color-cc-panel-WARNING **: Failed to send Cancel: GDBus.Error:org.freedesktop.ColorHelper.Internal: cannot cancel as status is idle
(gnome-control-center:4072): color-cc-panel-DEBUG: Setting window to 0x0 with size 1680x1050


NB the screen calibrated fine in Fedora 18
Comment 2 Richard Hughes 2013-12-10 05:02:22 EST

*** This bug has been marked as a duplicate of bug 973792 ***

Note You need to log in before you can comment on or make changes to this bug.