Bug 973881 - fail to find the install source when install RHEL var the usb stick
fail to find the install source when install RHEL var the usb stick
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.5
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Anaconda Maintenance Team
Release Test Team
:
Depends On:
Blocks: 973884
  Show dependency treegraph
 
Reported: 2013-06-12 23:23 EDT by Sibiao Luo
Modified: 2013-07-01 16:07 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 973884 (view as bug list)
Environment:
Last Closed: 2013-07-01 16:07:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sibiao Luo 2013-06-12 23:23:55 EDT
Description of problem:
this bug was separated from bug 954312 that fail to find the install source when install RHEL var the usb stick.

Version-Release number of selected component (if applicable):
host info:
kernel-2.6.32-369.el6.x86_64
qemu-kvm-0.12.1.2-2.360.el6.x86_64
seabios-0.6.1.2-27.el6.x86_64
guest info:
RHEL6.4-20130123.0-Server-x86_64

How reproducible:
100%

Steps to Reproduce:
1.Insert usb stick to host
# lsusb | grep Kingston
Bus 002 Device 003: ID 0930:6545 Toshiba Corp. Kingston DataTraveler 102 Flash Drive / HEMA Flash Drive 2 GB / PNY Attache 4GB Stick

2.dd a os iso to usb device
# dd if=RHEL6.4-20130123.0-Server-x86_64-DVD1.iso of=/dev/sdb

3.boot qemu-kvm with usb stick(passthrough)
# /usr/libexec/qemu-kvm -S -M rhel6.4.0 -cpu host -enable-kvm -m 2048 -smp 2,sockets=2,cores=1,threads=1 -no-kvm-pit-reinjection -name win8-test -uuid `uuidgen` -rtc base=localtime,clock=host,driftfix=slew -drive file=/home/usb-test.qcow2,if=none,id=drive-system-disk,format=qcow2,cache=none,aio=native,werror=stop,rerror=stop,serial=QEMU-DISK1 -device virtio-blk-pci,scsi=off,bus=pci.0,addr=0x4,drive=drive-system-disk,id=system-disk,bootindex=1 -netdev tap,id=hostnet0,vhost=on,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet0,id=virtio-net-pci0,mac=08:2e:5f:0a:1d:b1,bus=pci.0,addr=0x5,bootindex=2,ioeventfd=off -device virtio-balloon-pci,id=ballooning,bus=pci.0,addr=0x6 -qmp tcp:0:4444,server,nowait -k en-us -boot menu=on -vnc :1 -spice disable-ticketing,port=5931 -vga qxl -monitor stdio -readconfig /home/ich9-ehci-uhci.cfg -device usb-host,hostbus=2,hostaddr=3,id=hostdev0
4.press "F12". 

5.Select "USB MSC Drive Kingstion DT 101 G2 PMAP" device----->Select "Hard drive" installation method----->Select Partition----->Press F2 to select 'Driver Disk Source'(sda)----->Driver Disk Source(/dev/sda1)----->Select driver disk image, Select the file which is your driver disk image (/images/install.img)

Actual results:
after step 5, it fail to install and prompt 'install exited abnormally', like:
Loader exited unexpectedly! Backtrace:
/sbin/loader[0x409c73]
/lib64/libc/so.6(exit+0xe2)[0x766619a44db2]
/sbin/loader[0x4124f4]
/sbin/loader[0x419abb]
/sbin/loader[0x40b496]
/lib64/libc/so.6(__libc_start_main+0xfd)[0x7f6619a2dcdd]
/sbin/loader[0x4079c9]
install exited abnormally [1/1]
The system will be rebooted when you press Ctrl-C or Ctrl-Alt-Delete.

BTW, I also tried the 'isolinux/install.img' driver disk image, it also the same results.

Expected results:
should install RHEL var USB stick successfully.

Additional info:
I tested it that install my physical machine var USB stick can hit the same issue.
Comment 1 Samantha N. Bueno 2013-07-01 16:07:09 EDT
If you want to make a bootable USB key, you need to download the minimal boot.iso file, which is around 230MB or so.

Presently, it looks like you're trying to stick a DVD ISO on a USB key and boot from that--that is not a valid/supported install case. Please refer to the table here: https://access.redhat.com/site/documentation/en-US/Red_Hat_Enterprise_Linux/6/html-single/Installation_Guide/index.html#sn-making-media

Note You need to log in before you can comment on or make changes to this bug.