Bug 973913 - ruleFlow components are missing in BRE
ruleFlow components are missing in BRE
Status: CLOSED CURRENTRELEASE
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: BRE (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity unspecified
: DR6
: 6.0.0
Assigned To: Kris Verlaenen
Marek Winkler
:
Depends On:
Blocks: 974013
  Show dependency treegraph
 
Reported: 2013-06-13 02:12 EDT by Ryan Zhang
Modified: 2014-08-06 16:15 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:15:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ryan Zhang 2013-06-13 02:12:03 EDT
Description of problem:
The ruleFlow related component are missing in BRE, which includes jbpm-flow, jbpm-flow-builder, jbpm-bpmn2, jbpm-persistence-jpa.



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Ryan Zhang 2013-06-13 05:23:52 EDT
Pull request is sented on https://github.com/droolsjbpm/jbpm/pull/168
Comment 2 Kris Verlaenen 2013-06-18 20:25:02 EDT
Ryan,

The pull request doesn't seem to be working for me (note that I did change the name to ruleflow-bin first).  I first get a warning:
[WARNING] The following patterns were never triggered in this artifact inclusion filter:
o  'org.jbpm:jbpm-bpmn2'
o  'org.jbpm:jbpm-flow'
o  'org.jbpm:jbpm-flow-builder'
o  'org.jbpm:jbpm-persistence-jpa'

And it fails with:
[ERROR] Failed to execute goal org.apache.maven.plugins:maven-assembly-plugin:2.3:single (zips) on project jbpm-distribution: Failed to create assembly: Error creating assembly archive ruleflow-bin: You must set at least one file. -> [Help 1]

Could you explain what the result should be?  A zip that contains these 4 jbpm jars?  Or also their dependencies (and if so, inside a lib folder)?  What about all the drools dependencies, also just in the lib folder?

Might it not be easier simply copying these 4 jars somewhere during the product build?

Kris
Comment 3 Ryan Zhang 2013-06-19 00:28:18 EDT
(In reply to Kris Verlaenen from comment #2)
> Ryan,
> 
> The pull request doesn't seem to be working for me (note that I did change
> the name to ruleflow-bin first).  I first get a warning:
> [WARNING] The following patterns were never triggered in this artifact
> inclusion filter:
> o  'org.jbpm:jbpm-bpmn2'
> o  'org.jbpm:jbpm-flow'
> o  'org.jbpm:jbpm-flow-builder'
> o  'org.jbpm:jbpm-persistence-jpa'
> 
> And it fails with:
> [ERROR] Failed to execute goal
> org.apache.maven.plugins:maven-assembly-plugin:2.3:single (zips) on project
> jbpm-distribution: Failed to create assembly: Error creating assembly
> archive ruleflow-bin: You must set at least one file. -> [Help 1]
> 
I run the command under top folder of jbpm by "mvn -Dfull clean install" (mvn >=3.0.3).
If you run it only in "jbpm-distribution", this error might happened. The assembly uses the <moduleSets> which possible requires the build trigger the other modules as well.
> Could you explain what the result should be?  A zip that contains these 4
> jbpm jars?  Or also their dependencies (and if so, inside a lib folder)? 
> What about all the drools dependencies, also just in the lib folder?
The result should be "4 jbpm jars+ dependencies". I didn't put the dependencies into lib since no lib folder is for drools dependencies as well. I suppose it's convinent for classpath setting. But I am ok with both way.
> 
> Might it not be easier simply copying these 4 jars somewhere during the
> product build?
The problem here is that we should include the dependencies for each jar.
Comment 4 Kris Verlaenen 2013-06-19 17:02:21 EDT
Instead of trying to figure out how to combine the existing drools distribution, the jbpm distribution, with now a new jbpm-ruleflow distribution and then still having to figure out how to create a new (bpms and brms version of) droolsjbpm-integration distribution, maybe we could just try to create 2 new distirbutions as part of the droolsjbpm-integration build: one a brms distribution and one a bpms distribution, each containing all the necessary jars + their dependencies from all core repositories?
Comment 5 Ryan Zhang 2013-06-19 22:31:20 EDT
Yep, that would also serve the purpose.
I think the problem we need to consider  is that we pickup the correct of depenencies for drools and jbpm jars no matter how we package them.
Comment 6 Marek Winkler 2013-07-22 09:48:38 EDT
The jboss-brms-engine.zip contains all mentioned jars as expected.

However, jboss-brms-manager (both 'deployable' and 'eap6' variants) lacks jbpm-persistence-jpa-6.0.0.Beta5.jar in WEB-INF/lib. I would expect the jar to be included, please correct me if I am wrong.
Comment 7 Kris Verlaenen 2013-08-07 11:17:33 EDT
Since jboss-brms-manager does not include any runtime capabilities, it seems correct that jbpm-persistence-jpa is not included in that war (only in the zip).  Setting status back to ON_QA as a result.
Comment 8 Marek Winkler 2013-08-08 11:04:54 EDT
Thanks for clarification, then this issue can be considered verified on DR6.

Note You need to log in before you can comment on or make changes to this bug.