Bug 974013 - Add kie-remote into BRE
Add kie-remote into BRE
Status: CLOSED WONTFIX
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: Configuration (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kris Verlaenen
Lukáš Petrovický
:
Depends On: 973913
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-13 05:35 EDT by Ryan Zhang
Modified: 2013-08-07 11:09 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-07 11:09:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rzhang: needinfo+


Attachments (Terms of Use)

  None (edit)
Description Ryan Zhang 2013-06-13 05:35:12 EDT
Description of problem:
kie-remote is also required in BRMS engine.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Ryan Zhang 2013-06-13 05:39:21 EDT
Kris,
Thanks for pointing this out.  I assume that we would include both kie-remote-client and kie-remote-service for both BRE and BPE(BPMS engine).

Could we include these two modules in droolsjbpm-integrtion distribution?
Comment 2 Kris Verlaenen 2013-06-18 20:31:12 EDT
kie-remote-* is currently mostly targeted towards BPMS.  Including it for BRMS as well might not be trivial:

 - kie-remote is based on jbpm-services etc., basically it depends on almost all core jbpm jars, including it would mean including almost all jbpm jars as part of BRMS

 - the session mgmt in jbpm-services is mostly targeted towards process or process+rules use cases, it might not be the best solution for pure rule use cases (as it will persist the session state after each command, which might not be ideal when a session can include a large amount of data

 - kie-remote-service is currently not included in kie-drools-wb (so either we would need to include it there as well, or the user would have to set up the REST service themselves somehow), the REST service itself is also targeted towards processes (rule functionality only available through the generic execute method)

Kris
Comment 3 Kris Verlaenen 2013-08-07 11:09:57 EDT
As discussed on program call, since execution server for BRMS is different, I'll close this issue.

Note You need to log in before you can comment on or make changes to this bug.