Bug 974032 - bug reporting doesn't work from LiveCD
bug reporting doesn't work from LiveCD
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-meh (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Vratislav Podzimek
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F19Blocker/F19FinalBlocker
  Show dependency treegraph
 
Reported: 2013-06-13 06:24 EDT by Kamil Páral
Modified: 2013-06-20 01:59 EDT (History)
10 users (show)

See Also:
Fixed In Version: python-meh-0.25-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-20 01:59:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of frozen dialog (788.11 KB, image/png)
2013-06-13 06:25 EDT, Kamil Páral
no flags Details
anaconda.log (2.55 KB, text/plain)
2013-06-13 06:26 EDT, Kamil Páral
no flags Details
anaconda-tb-GwGqQi (251.67 KB, text/plain)
2013-06-13 06:26 EDT, Kamil Páral
no flags Details
ifcfg.log (486 bytes, text/plain)
2013-06-13 06:26 EDT, Kamil Páral
no flags Details
journalctl output (203.61 KB, text/plain)
2013-06-13 06:26 EDT, Kamil Páral
no flags Details
program.log (27.26 KB, text/plain)
2013-06-13 06:27 EDT, Kamil Páral
no flags Details
storage.log (139.33 KB, text/plain)
2013-06-13 06:27 EDT, Kamil Páral
no flags Details

  None (edit)
Description Kamil Páral 2013-06-13 06:24:59 EDT
Description of problem:
I booted F19 TC3 Live x86_64 and started the installer. I received an error box:

anaconda 19.30.4-1 exception report
Traceback (most recent call first):
IOError: [Errno 9] Bad file descriptor

After I hit Report Bug, the whole window froze. The log shows:

Exception occurred during /var/log/messages file copy:
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/meh/dump.py", line 457, in dump
    ret += line.encode("utf-8")
UnicodeDecodeError: 'ascii' codec can't decode byte 0xe2 in position 67: ordinal not in range(128)

It doesn't seem to happen always, maybe a race condition?

Version-Release number of selected component (if applicable):
anaconda 19.30.4-1

How reproducible:
saw in once, out of 3 attempts

Steps to Reproduce:
1. boot live
2. run installer from the welcome dialog
Comment 1 Kamil Páral 2013-06-13 06:25:45 EDT
Created attachment 760546 [details]
screenshot of frozen dialog
Comment 2 Kamil Páral 2013-06-13 06:26:24 EDT
Created attachment 760548 [details]
anaconda.log
Comment 3 Kamil Páral 2013-06-13 06:26:31 EDT
Created attachment 760549 [details]
anaconda-tb-GwGqQi
Comment 4 Kamil Páral 2013-06-13 06:26:37 EDT
Created attachment 760550 [details]
ifcfg.log
Comment 5 Kamil Páral 2013-06-13 06:26:57 EDT
Created attachment 760551 [details]
journalctl output
Comment 6 Kamil Páral 2013-06-13 06:27:03 EDT
Created attachment 760552 [details]
program.log
Comment 7 Kamil Páral 2013-06-13 06:27:10 EDT
Created attachment 760553 [details]
storage.log
Comment 8 Kamil Páral 2013-06-13 06:41:46 EDT
I have booted the LiveCD several more times and I haven't seen this again.
Comment 9 Kamil Páral 2013-06-13 07:35:29 EDT
Since I can't reproduce the original issue "IOError: [Errno 9] Bad file descriptor", I was asked by vpodzime to use just for the python-meh issue.

I tried to verify if python-meh works well on LiveCD and use our test case for that [1], however, it doesn't seem to work at all. If you trigger the fake exception on DVD, the error dialog is correctly shown. But if you run the fake trigger on LiveCD, no error dialog is shown and hundreds of empty /tmp/anaconda-tb-* files are being created.

Vratislav assumes that bug reporting from LiveCD might be completely broken. Proposing as a FinalBlocker:
"The installer must be able to report failures to Bugzilla, with appropriate information included. "
http://fedoraproject.org/wiki/Fedora_19_Alpha_Release_Criteria

[1] https://fedoraproject.org/wiki/QA:Testcase_Anaconda_save_traceback_to_bugzilla
Comment 10 Vratislav Podzimek 2013-06-17 06:17:26 EDT
Patch sent to anaconda-patches. It is a bit "hacky" one, but let's hope it will be approved.
Comment 11 Adam Williamson 2013-06-17 13:25:41 EDT
Discussed at 2013-06-17 blocker review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-06-17/f19final-blocker-review-6.2013-06-17-16.01.log.txt . Accepted as a blocker per criterion "The installer must be able to report failures to Bugzilla, with appropriate information included."
Comment 12 Fedora Update System 2013-06-18 07:30:37 EDT
python-meh-0.25-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/python-meh-0.25-1.fc19
Comment 13 Fedora Update System 2013-06-18 15:41:55 EDT
Package python-meh-0.25-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-meh-0.25-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-11175/python-meh-0.25-1.fc19
then log in and leave karma (feedback).
Comment 14 Lukas Brabec 2013-06-19 06:09:51 EDT
Fix works for me.
Comment 15 Fedora Update System 2013-06-20 01:59:29 EDT
python-meh-0.25-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.