Bug 974532 - IOError: [Errno 9] Bad file descriptor
IOError: [Errno 9] Bad file descriptor
Status: CLOSED DUPLICATE of bug 963267
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:df74965c5df324160ea429f5870...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-14 07:16 EDT by Kamil Páral
Modified: 2013-06-14 20:21 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-14 20:21:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (324.49 KB, text/plain)
2013-06-14 07:16 EDT, Kamil Páral
no flags Details
File: anaconda.log (3.08 KB, text/plain)
2013-06-14 07:16 EDT, Kamil Páral
no flags Details
File: backtrace (1.16 KB, text/plain)
2013-06-14 07:16 EDT, Kamil Páral
no flags Details
File: environ (441 bytes, text/plain)
2013-06-14 07:16 EDT, Kamil Páral
no flags Details
File: ifcfg.log (490 bytes, text/plain)
2013-06-14 07:16 EDT, Kamil Páral
no flags Details
File: lsblk_output (2.08 KB, text/plain)
2013-06-14 07:16 EDT, Kamil Páral
no flags Details
File: nmcli_dev_list (1.17 KB, text/plain)
2013-06-14 07:16 EDT, Kamil Páral
no flags Details
File: packaging.log (13.61 KB, text/plain)
2013-06-14 07:16 EDT, Kamil Páral
no flags Details
File: program.log (42.23 KB, text/plain)
2013-06-14 07:16 EDT, Kamil Páral
no flags Details
File: storage.log (126.96 KB, text/plain)
2013-06-14 07:16 EDT, Kamil Páral
no flags Details
File: syslog (152.57 KB, text/plain)
2013-06-14 07:17 EDT, Kamil Páral
no flags Details

  None (edit)
Description Kamil Páral 2013-06-14 07:16:10 EDT
Description of problem:
Booted F19 TC3 netinst. I saw already this problem once in a VM, but it's hard to reproduce, probably some race condition.
The following was filed automatically by anaconda:
anaconda 19.30.5-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/babel/localedata.py", line 111, in load
    fileobj.close()
  File "/usr/lib/python2.7/site-packages/babel/core.py", line 231, in _data
    self.__data = localedata.LocaleDataDict(localedata.load(str(self)))
  File "/usr/lib/python2.7/site-packages/babel/core.py", line 293, in languages
    return self._data['languages']
  File "/usr/lib/python2.7/site-packages/babel/core.py", line 250, in get_display_name
    retval = locale.languages.get(self.language)
  File "/usr/lib/python2.7/site-packages/babel/core.py", line 278, in english_name
    return self.get_display_name(Locale('en'))
  File "/usr/lib/python2.7/site-packages/pyanaconda/localization.py", line 87, in english_name
    return self._localedata.english_name or u''
  File "/usr/lib/python2.7/site-packages/pyanaconda/ui/gui/spokes/welcome.py", line 177, in initialize
    trans.english_name, trans.short_name)
  File "/usr/lib/python2.7/site-packages/pyanaconda/ui/gui/__init__.py", line 367, in run
    self._currentAction.initialize()
  File "/sbin/anaconda", line 1087, in <module>
    anaconda._intf.run()
IOError: [Errno 9] Bad file descriptor

Version-Release number of selected component:
anaconda-19.30.5-1

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:UUID=367b7403-8a9d-478b-9ad3-7f4cdbc58716 systemd.log_level=debug systemd.log_target=ksmg log_buf_len=1M BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.4-301.fc19.i686
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19-TC3

Truncated backtrace:
Traceback (most recent call last):
  File "/sbin/anaconda", line 1087, in <module>
    anaconda._intf.run()
  File "/usr/lib/python2.7/site-packages/pyanaconda/ui/gui/__init__.py", line 367, in run
    self._currentAction.initialize()
  File "/usr/lib/python2.7/site-packages/pyanaconda/ui/gui/spokes/welcome.py", line 177, in initialize
    trans.english_name, trans.short_name)
  File "/usr/lib/python2.7/site-packages/pyanaconda/localization.py", line 87, in english_name
    return self._localedata.english_name or u''
  File "/usr/lib/python2.7/site-packages/babel/core.py", line 278, in english_name
    return self.get_display_name(Locale('en'))
  File "/usr/lib/python2.7/site-packages/babel/core.py", line 250, in get_display_name
    retval = locale.languages.get(self.language)
  File "/usr/lib/python2.7/site-packages/babel/core.py", line 293, in languages
    return self._data['languages']
  File "/usr/lib/python2.7/site-packages/babel/core.py", line 231, in _data
    self.__data = localedata.LocaleDataDict(localedata.load(str(self)))
  File "/usr/lib/python2.7/site-packages/babel/localedata.py", line 111, in load
    fileobj.close()
IOError: [Errno 9] Bad file descriptor
Comment 1 Kamil Páral 2013-06-14 07:16:17 EDT
Created attachment 761216 [details]
File: anaconda-tb
Comment 2 Kamil Páral 2013-06-14 07:16:21 EDT
Created attachment 761217 [details]
File: anaconda.log
Comment 3 Kamil Páral 2013-06-14 07:16:26 EDT
Created attachment 761218 [details]
File: backtrace
Comment 4 Kamil Páral 2013-06-14 07:16:31 EDT
Created attachment 761219 [details]
File: environ
Comment 5 Kamil Páral 2013-06-14 07:16:35 EDT
Created attachment 761220 [details]
File: ifcfg.log
Comment 6 Kamil Páral 2013-06-14 07:16:39 EDT
Created attachment 761221 [details]
File: lsblk_output
Comment 7 Kamil Páral 2013-06-14 07:16:43 EDT
Created attachment 761222 [details]
File: nmcli_dev_list
Comment 8 Kamil Páral 2013-06-14 07:16:47 EDT
Created attachment 761223 [details]
File: packaging.log
Comment 9 Kamil Páral 2013-06-14 07:16:51 EDT
Created attachment 761224 [details]
File: program.log
Comment 10 Kamil Páral 2013-06-14 07:16:55 EDT
Created attachment 761225 [details]
File: storage.log
Comment 11 Kamil Páral 2013-06-14 07:17:01 EDT
Created attachment 761226 [details]
File: syslog
Comment 12 Kamil Páral 2013-06-14 07:20:21 EDT
This might be the same problem as in bug 974032 (which was then used for something else).
Comment 13 Kamil Páral 2013-06-14 07:44:58 EDT
I saw this several more times, on the same machine, on subsequent boots. I believe it is somehow related to a slow NIC. The machine picks up network connection very slow, sometimes it's not up before Anaconda starts. I tried to disconnect the cable completely and boot it several times and I saw no error. However, then I reconnected the cable, booted several times, and the error hasn't re-appeared :/ It seems very racy.
Comment 14 Brian Lane 2013-06-14 20:21:38 EDT

*** This bug has been marked as a duplicate of bug 963267 ***

Note You need to log in before you can comment on or make changes to this bug.