Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 974049 - DBusException: org.freedesktop.NetworkManager.AgentManager.SessionNotFound: Session not found
Summary: DBusException: org.freedesktop.NetworkManager.AgentManager.SessionNotFound: S...
Keywords:
Status: CLOSED DUPLICATE of bug 973068
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 19
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:50ee951917fc2d533e9d0ea94b3...
Depends On:
Blocks: F19Blocker, F19FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2013-06-13 10:54 UTC by Jan Sedlák
Modified: 2013-06-13 11:32 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-06-13 11:32:59 UTC
Type: ---


Attachments (Terms of Use)
File: anaconda-tb (184.62 KB, text/plain)
2013-06-13 10:54 UTC, Jan Sedlák
no flags Details
File: anaconda.log (2.27 KB, text/plain)
2013-06-13 10:55 UTC, Jan Sedlák
no flags Details
File: backtrace (1.37 KB, text/plain)
2013-06-13 10:55 UTC, Jan Sedlák
no flags Details
File: environ (441 bytes, text/plain)
2013-06-13 10:55 UTC, Jan Sedlák
no flags Details
File: lsblk_output (1.32 KB, text/plain)
2013-06-13 10:55 UTC, Jan Sedlák
no flags Details
File: packaging.log (13.68 KB, text/plain)
2013-06-13 10:55 UTC, Jan Sedlák
no flags Details
File: program.log (21.15 KB, text/plain)
2013-06-13 10:55 UTC, Jan Sedlák
no flags Details
File: storage.log (66.98 KB, text/plain)
2013-06-13 10:55 UTC, Jan Sedlák
no flags Details
File: syslog (57.86 KB, text/plain)
2013-06-13 10:55 UTC, Jan Sedlák
no flags Details

Description Jan Sedlák 2013-06-13 10:54:53 UTC
Description of problem:
Booted into netinst without network connection. After selecting language and clicking on "accept my fate", traceback showed up.
The following was filed automatically by anaconda:
anaconda 19.30.4-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/dbus/connection.py", line 651, in call_blocking
    message, timeout)
  File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 145, in __call__
    **keywords)
  File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 70, in __call__
    return self._proxy_method(*args, **keywords)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/network.py", line 1249, in register_secret_agent
    proxy.Register("anaconda", dbus_interface=AGENT_MANAGER_IFACE)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/network.py", line 1445, in initialize
    register_secret_agent(self)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/__init__.py", line 469, in _on_continue_clicked
    nextAction.initialize()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/__init__.py", line 68, in _on_continue_clicked
    cb()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/welcome.py", line 356, in _on_continue_clicked
    StandaloneSpoke._on_continue_clicked(self, cb)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/__init__.py", line 72, in <lambda>
    self.window.connect("continue-clicked", lambda *args: self._on_continue_clicked(cb))
DBusException: org.freedesktop.NetworkManager.AgentManager.SessionNotFound: Session not found

Version-Release number of selected component:
anaconda-19.30.4-1

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2019-TC3\x20x86_64 quiet BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
ifcfg.log:      10:52:22,313 DEBUG ifcfg: content of files (network initialization):
kernel:         3.9.4-301.fc19.x86_64
nmcli_dev_list: 
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19-TC3

Truncated backtrace:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/__init__.py", line 72, in <lambda>
    self.window.connect("continue-clicked", lambda *args: self._on_continue_clicked(cb))
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/welcome.py", line 356, in _on_continue_clicked
    StandaloneSpoke._on_continue_clicked(self, cb)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/__init__.py", line 68, in _on_continue_clicked
    cb()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/__init__.py", line 469, in _on_continue_clicked
    nextAction.initialize()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/network.py", line 1445, in initialize
    register_secret_agent(self)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/network.py", line 1249, in register_secret_agent
    proxy.Register("anaconda", dbus_interface=AGENT_MANAGER_IFACE)
  File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 70, in __call__
    return self._proxy_method(*args, **keywords)
  File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 145, in __call__
    **keywords)
  File "/usr/lib/python2.7/site-packages/dbus/connection.py", line 651, in call_blocking
    message, timeout)
DBusException: org.freedesktop.NetworkManager.AgentManager.SessionNotFound: Session not found

Comment 1 Jan Sedlák 2013-06-13 10:54:58 UTC
Created attachment 760571 [details]
File: anaconda-tb

Comment 2 Jan Sedlák 2013-06-13 10:55:02 UTC
Created attachment 760572 [details]
File: anaconda.log

Comment 3 Jan Sedlák 2013-06-13 10:55:06 UTC
Created attachment 760573 [details]
File: backtrace

Comment 4 Jan Sedlák 2013-06-13 10:55:10 UTC
Created attachment 760574 [details]
File: environ

Comment 5 Jan Sedlák 2013-06-13 10:55:14 UTC
Created attachment 760575 [details]
File: lsblk_output

Comment 6 Jan Sedlák 2013-06-13 10:55:18 UTC
Created attachment 760576 [details]
File: packaging.log

Comment 7 Jan Sedlák 2013-06-13 10:55:23 UTC
Created attachment 760577 [details]
File: program.log

Comment 8 Jan Sedlák 2013-06-13 10:55:27 UTC
Created attachment 760578 [details]
File: storage.log

Comment 9 Jan Sedlák 2013-06-13 10:55:32 UTC
Created attachment 760579 [details]
File: syslog

Comment 10 Jan Sedlák 2013-06-13 10:59:26 UTC
Proposing as blockerbug per beta criterion: "When using the dedicated installer images, the installer must be able to use HTTP, FTP and NFS repositories as package sources."

Comment 11 Radek Vykydal 2013-06-13 11:32:59 UTC

*** This bug has been marked as a duplicate of bug 973068 ***


Note You need to log in before you can comment on or make changes to this bug.