Bug 974123 - subscription-manager defaults to status and not to help
subscription-manager defaults to status and not to help
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.10
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Carter Kozak
IDM QE LIST
:
Depends On:
Blocks: rhsm-rhel510
  Show dependency treegraph
 
Reported: 2013-06-13 09:23 EDT by Sharath Dwaral
Modified: 2015-03-22 21:14 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
No description necessary
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-30 19:10:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sharath Dwaral 2013-06-13 09:23:45 EDT
Description of problem:
Entering subscription-manager without modules or options defaults to subscription-manager status. Request to reverted back to defaulting to help..

Version-Release number of selected component (if applicable):
# rpm -qa | egrep "subscription-manager|python-rhsm"
subscription-manager-debuginfo-1.8.8-1.el5
subscription-manager-gui-1.8.10-1.git.28.b41b048.el5
subscription-manager-1.8.10-1.git.28.b41b048.el5
subscription-manager-migration-data-1.11.3.1-1.git.1.78afd75.el5
python-rhsm-1.8.12-1.git.0.d747a65.el5
subscription-manager-migration-1.8.10-1.git.28.b41b048.el5
subscription-manager-firstboot-1.8.10-1.git.28.b41b048.el5

How reproducible:
always

Steps to Reproduce:
1. # subscription-manager 


Actual results:
Defaults to subscription-manager status

Expected results:
defaults to subscription-manager --help

Additional info:
Comment 2 Carter Kozak 2013-06-13 14:20:29 EDT
commit daca173f4b27232f27fabcb106bab64f4f20a02d
Author: ckozak <ckozak@redhat.com>
Date:   Thu Jun 13 09:44:10 2013 -0400

    974123: default behavior is help, no longer status
Comment 3 RHEL Product and Program Management 2013-06-14 22:37:01 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 5 John Sefler 2013-07-01 14:37:49 EDT
Verifying Version...
[root@jsefler-5 ~]# rpm -q subscription-manager
subscription-manager-1.8.11-1.el5

[root@jsefler-5 ~]# subscription-manager
Usage: subscription-manager MODULE-NAME [MODULE-OPTIONS] [--help]

Primary Modules:

  attach         Attach a specified subscription to the registered system
  list           List subscription and product information for this system
  refresh        Pull the latest subscription data from the server
  register       Register this system to the Customer Portal or another subscription management service
  release        Configure which operating system release to use
  remove         Remove all or specific subscriptions from this system
  status         Show status information for this system's subscriptions and products
  unregister     Unregister this system from the Customer Portal or another subscription management service

Other Modules:

  clean          Remove all local system and subscription data without affecting the server
  config         List, set, or remove the configuration parameters in use by this system
  environments   Display the environments available for a user
  facts          View or update the detected system information
  identity       Display the identity certificate for this system or request a new one
  import         Import certificates which were provided outside of the tool
  orgs           Display the organizations against which a user can register a system
  plugins        View and configure subscription-manager plugins
  redeem         Attempt to redeem a subscription for a preconfigured system
  repos          List the repositories which this system is entitled to use
  service-level  Manage service levels for this system
  subscribe      Deprecated, see attach
  unsubscribe    Deprecated, see remove
  version        Print version information

[root@jsefler-5 ~]# 


VERIFIED: The default response from running subscription-manager with no modules has been restored to --help.
Comment 8 errata-xmlrpc 2013-09-30 19:10:34 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1332.html

Note You need to log in before you can comment on or make changes to this bug.