Bug 974172 - Changing Quota from Disabled to Audit is triggering the "Enforcing" warning message.
Changing Quota from Disabled to Audit is triggering the "Enforcing" warning m...
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-engine-webadmin (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: 3.3.1
Assigned To: Doron Fediuck
sla
:
: 988369 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-13 11:00 EDT by Amador Pahim
Modified: 2013-11-25 06:48 EST (History)
8 users (show)

See Also:
Fixed In Version: IS9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-25 06:48:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 17012 None None None Never
oVirt gerrit 18588 None None None Never

  None (edit)
Description Amador Pahim 2013-06-13 11:00:12 EDT
Description of problem:

Upstream commit a4014474 introduced the warning message when user is changing Quota mode in DC from Disabled to Enforced:

 Change Data Center Quota Enforcement Mode
  Moving Quota to Enforce Mode
  All the templates, virtual machines, and disks must be assigned into specific  quota allocations otherwise will be unusable.
  Users should be added as quota consumers.
  Please consider using Audit mode until you define Quotas for the users.
  Are you sure you want to continue?

The issue is the same warning message happening when changing Quota mode from Disabled to Audit.


Version-Release number of selected component (if applicable):
ovirt-engine-3.3.0-0.2.master.20130609231424.gitc493152.fc18.noarch

How reproducible:
100%

Steps to Reproduce:
1. Edit DC and change Quota Mode from Disabled to Audit.

Actual results:
The message targeted to Enforced Quota Mode being showed when changing to Audit Quota Mode.

Expected results:
Remove message when changing to Audit Quota Mode OR show a proper message.
Comment 1 Doron Fediuck 2013-06-16 04:01:04 EDT
Let's provide a message for audit mode:

Change Data Center Quota Enforcement Mode
  Moving Quota to Audit Mode
  In this mode you are able to test-run your quota settings to get an indication on missing quota allocations;
  All the templates, virtual machines, and disks must be assigned into specific  quota allocations otherwise will be unusable if moved to enforcing mode.
  Users should be added as quota consumers.
  Are you sure you want to continue?
Comment 2 ofri 2013-08-13 09:01:52 EDT
*** Bug 988369 has been marked as a duplicate of this bug. ***
Comment 3 David Botzer 2013-08-27 04:24:00 EDT
3.3/is11, reopened
Ofri had already found the issue and got a patch
3.3/is11, reopened
Comment 5 Sandro Bonazzola 2013-11-25 06:48:01 EST
oVirt 3.3.1 has been released

Note You need to log in before you can comment on or make changes to this bug.