Bug 97425 - 'resolve_offset_ref' error
Summary: 'resolve_offset_ref' error
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gcc3 (Show other bugs)
(Show other bugs)
Version: 8.0
Hardware: athlon Linux
low
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-06-15 13:24 UTC by Kyriakos Sidiropoulos
Modified: 2007-03-27 04:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-17 15:58:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
source and preprocessed source (72.79 KB, application/octet-stream)
2003-06-15 13:28 UTC, Kyriakos Sidiropoulos
no flags Details

Description Kyriakos Sidiropoulos 2003-06-15 13:24:37 UTC
Description of problem:


Version-Release number of selected component (if applicable):
gcc-3.2

How reproducible:
Always

Steps to Reproduce:
1. Get 'files.tar.bz2'
2. Extract 'test.c++'
3. g++ test.c++
    
Actual results:
[Raptor@Sirca Raptor]$ g++  -save-temps test.c++
test.c++: In function `int main()':
test.c++:19: Internal compiler error in resolve_offset_ref, at cp/init.c:1886
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
[Raptor@Sirca Raptor]$

Expected results:
(self-evident...)

Additional info:
1. Preprocessed source is included in 'files.tar.bz2'
2. In all probability these problems are solved at gcc-3.3.
   So, in advance, sorry for the drag.

Comment 1 Kyriakos Sidiropoulos 2003-06-15 13:28:44 UTC
Created attachment 92406 [details]
source and preprocessed source

Comment 2 Jakub Jelinek 2003-06-17 15:58:29 UTC
Cannot reproduce with either gcc-3.2.2-5 (in RHL9), gcc-3.2.3-3 nor current
rawhide (gcc-3.3-7).
All 3 compilers just correctly complain about bugs in the testcase.


Note You need to log in before you can comment on or make changes to this bug.