Bug 974290 - anaconda does not pass 'console=ttyAMA0,115200' boot arg to bootloader config (extlinux.conf)
anaconda does not pass 'console=ttyAMA0,115200' boot arg to bootloader config...
Status: CLOSED DUPLICATE of bug 974643
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
arm Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks: ARMTracker F19ARMBlocker
  Show dependency treegraph
 
Reported: 2013-06-13 17:04 EDT by Paul Whalen
Modified: 2013-06-14 20:34 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-14 20:34:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Whalen 2013-06-13 17:04:17 EDT
Description of problem:
When installing a system using 'console=ttyAMA0,115200' in the pxeboot config the resulting installed system does not include the boot arg. 


Version-Release number of selected component (if applicable):

anaconda-19.30.5-1.fc19

How reproducible:

everytime.

Steps to Reproduce:
1. begin a pxeboot installation including the following boot arg:
append console=ttyAMA0 ip=eth0:dhcp ks=http:// rd.shell

Actual results:
After installation the system will not include the boot arg:
append: rd.md=0 root=UUID=f28329a8-cdc0-48ab-95f7-8a331ee10e9a rd.dm=0 vconsole.font=latarcyrheb-sun16 rd.lvm=0 vconsole.keymap=us rd.luks=0


Expected results:
'console=ttyAMA0' in the boot args

Additional info:
When '--append="console=ttyAMA0,115200" ' is added to the kickstart, system includes the expected boot argument. eg:
bootloader --extlinux --append="console=ttyAMA0,115200"
Comment 1 Brian Lane 2013-06-14 20:34:38 EDT

*** This bug has been marked as a duplicate of bug 974643 ***

Note You need to log in before you can comment on or make changes to this bug.