Bug 974643 - console=<foo> not passed onto installed system
console=<foo> not passed onto installed system
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthew Miller
Fedora Extras Quality Assurance
RejectedBlocker AcceptedFreezeException
:
: 974290 (view as bug list)
Depends On:
Blocks: ARMTracker F19-accepted/F19FinalFreezeException F19ARMBlocker
  Show dependency treegraph
 
Reported: 2013-06-14 13:25 EDT by Dennis Gilmore
Modified: 2013-06-21 22:30 EDT (History)
11 users (show)

See Also:
Fixed In Version: anaconda-19.30.9-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-21 22:30:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
posible untested fix (897 bytes, patch)
2013-06-15 00:25 EDT, Dennis Gilmore
no flags Details | Diff

  None (edit)
Description Dennis Gilmore 2013-06-14 13:25:02 EDT
Description of problem:
when doing a serial console install of a system with console=<foo> the console bootarg is not passed onto the installed system. tested with --extlinux config on arm but in #anaconda i was told this is not passed on to a grub2 install also.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Adam Williamson 2013-06-14 13:47:11 EDT
Just for the public record, this is expected to work and is the documented way of doing a serial console install:

https://fedoraproject.org/wiki/Anaconda_Boot_Options

console=ttyS0
    Turn on serial console support and display anaconda on serial console instead of graphical console. Settings will carry over to the installed system.
Comment 2 Adam Williamson 2013-06-14 13:47:46 EDT
https://fedoraproject.org/wiki/Fedora_19_Beta_Release_Criteria#Installation_interfaces :

"The installer must be able to complete an installation using the serial console interface."
Comment 3 Brian Lane 2013-06-14 19:41:15 EDT
commit 0b64177523 was supposed to make this persist. extlinux is new and may not have gotten the memo though. It would be nice if someone could try with grub instead of depending on 'I heard'. And logs are always a nice addition.
Comment 4 Brian Lane 2013-06-14 20:11:24 EDT
I threw console=ttyS0 into a test install, worked just fine with grub so this is bound to be because extlinux is new.
Comment 5 Brian Lane 2013-06-14 20:34:38 EDT
*** Bug 974290 has been marked as a duplicate of this bug. ***
Comment 6 Matthew Miller 2013-06-14 20:45:36 EDT
I'll take a look. This is outside the scope of the F19 feature (which is, in short, "extlinux works in cloud images"), but I'd love for it to actually be useful on ARM and in other places as well.

Dennis, just to be clear, this is an argument you're giving to the anaconda boot which should be passed on, not bootloader --append="console=ttyS0", right?
Comment 7 Dennis Gilmore 2013-06-14 23:00:49 EDT
in a kickstart install

bootloader --extlinux

results in a system not bootable post install

bootloader --extlinux --append="console=ttyAMA0" 

results in a system that is bootable. the pxe config uses console=ttyAMA0 when installing.
Comment 8 Dennis Gilmore 2013-06-15 00:25:02 EDT
Created attachment 761490 [details]
posible untested fix
Comment 9 Adam Williamson 2013-06-17 12:31:27 EDT
Discussed at 2013-06-17 blocker review meeting. As this only affects a non-default (in fact, hidden) bootloader option, it is rejected as a blocker bug. However, it's accepted as a freeze exception issue so long as the fix is completely restricted to the code for that non-default bootloader option and hence can't possibly break the important ones.
Comment 10 Fedora Update System 2013-06-20 19:37:14 EDT
anaconda-19.30.9-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/FEDORA-2013-11350/anaconda-19.30.9-1.fc19
Comment 11 Fedora Update System 2013-06-21 22:30:24 EDT
anaconda-19.30.9-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.