Bug 974478 - gnome-boxes fails with Memory fault
gnome-boxes fails with Memory fault
Status: CLOSED DUPLICATE of bug 978727
Product: Fedora
Classification: Fedora
Component: gnome-boxes (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Christophe Fergeau
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-14 05:03 EDT by Milan Bartos
Modified: 2013-10-07 19:42 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-29 05:23:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milan Bartos 2013-06-14 05:03:04 EDT
Description of problem:
gnome-boxes fails with Memory fault.


Version-Release number of selected component (if applicable):
gnome-boxes-3.6.3-1.fc18.x86_64

How reproducible:
Every time


Steps to Reproduce:
1. run gnome-boxes

Actual results:
$ gnome-boxes
GLib-GIO-Message: Using the 'memory' GSettings backend.  Your settings will not be saved or shared with other applications.

(gnome-boxes:7679): Gtk-WARNING **: Invalid icon size 0


(gnome-boxes:7679): Gtk-CRITICAL **: gtk_icon_info_load_icon: assertion `icon_info != NULL' failed

(gnome-boxes:7679): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_width: assertion `GDK_IS_PIXBUF (pixbuf)' failed

(gnome-boxes:7679): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_height: assertion `GDK_IS_PIXBUF (pixbuf)' failed

(gnome-boxes:7679): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_pixels: assertion `GDK_IS_PIXBUF (pixbuf)' failed

(gnome-boxes:7679): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_rowstride: assertion `GDK_IS_PIXBUF (pixbuf)' failed

(gnome-boxes:7679): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_n_channels: assertion `GDK_IS_PIXBUF (pixbuf)' failed
Memory fault
$ 


Expected results:
I guess it should work.
Comment 1 Christophe Fergeau 2013-06-19 09:06:02 EDT
(In reply to Milan Bartos from comment #0)
> Description of problem:
> gnome-boxes fails with Memory fault.
> 
> 
> Version-Release number of selected component (if applicable):
> gnome-boxes-3.6.3-1.fc18.x86_64
> 
> How reproducible:
> Every time
> 
> 
> Steps to Reproduce:
> 1. run gnome-boxes
> 
> Actual results:
> $ gnome-boxes
> GLib-GIO-Message: Using the 'memory' GSettings backend.  Your settings will
> not be saved or shared with other applications.

This indicates that at least dconf is not installed on your system for some reason, which could mean the boxes package is missing some dependencies. The next warnings could be cause by such issues as well...



> 
> (gnome-boxes:7679): Gtk-WARNING **: Invalid icon size 0
> 
> 
> (gnome-boxes:7679): Gtk-CRITICAL **: gtk_icon_info_load_icon: assertion
> `icon_info != NULL' failed
> 
> (gnome-boxes:7679): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_width: assertion
> `GDK_IS_PIXBUF (pixbuf)' failed
> 
> (gnome-boxes:7679): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_height: assertion
> `GDK_IS_PIXBUF (pixbuf)' failed
> 
> (gnome-boxes:7679): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_pixels: assertion
> `GDK_IS_PIXBUF (pixbuf)' failed
> 
> (gnome-boxes:7679): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_rowstride:
> assertion `GDK_IS_PIXBUF (pixbuf)' failed
> 
> (gnome-boxes:7679): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_n_channels:
> assertion `GDK_IS_PIXBUF (pixbuf)' failed
> Memory fault
> $ 
> 
> 
> Expected results:
> I guess it should work.
Comment 2 Milan Bartos 2013-06-20 01:29:36 EDT
I've installed dconf and output changed a bit:

$ gnome-boxes 

(gnome-boxes:2319): Gtk-WARNING **: Invalid icon size 0


(gnome-boxes:2319): Gtk-CRITICAL **: gtk_icon_info_load_icon: assertion `icon_info != NULL' failed

(gnome-boxes:2319): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_width: assertion `GDK_IS_PIXBUF (pixbuf)' failed

(gnome-boxes:2319): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_height: assertion `GDK_IS_PIXBUF (pixbuf)' failed

(gnome-boxes:2319): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_pixels: assertion `GDK_IS_PIXBUF (pixbuf)' failed

(gnome-boxes:2319): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_rowstride: assertion `GDK_IS_PIXBUF (pixbuf)' failed

(gnome-boxes:2319): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_n_channels: assertion `GDK_IS_PIXBUF (pixbuf)' failed
Segmentation fault
$ 


> This indicates that at least dconf is not installed on your system for some reason
It's not in Requires. So if it's really necessary, I'll fill a bug for that.
Comment 3 Zeeshan Ali 2013-06-24 09:37:52 EDT
(In reply to Milan Bartos from comment #2)
> I've installed dconf and output changed a bit:
> 
> $ gnome-boxes 
> 
> (gnome-boxes:2319): Gtk-WARNING **: Invalid icon size 0
> 
> 
> (gnome-boxes:2319): Gtk-CRITICAL **: gtk_icon_info_load_icon: assertion
> `icon_info != NULL' failed
> 
> (gnome-boxes:2319): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_width: assertion
> `GDK_IS_PIXBUF (pixbuf)' failed
> 
> (gnome-boxes:2319): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_height: assertion
> `GDK_IS_PIXBUF (pixbuf)' failed
> 
> (gnome-boxes:2319): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_pixels: assertion
> `GDK_IS_PIXBUF (pixbuf)' failed
> 
> (gnome-boxes:2319): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_rowstride:
> assertion `GDK_IS_PIXBUF (pixbuf)' failed
> 
> (gnome-boxes:2319): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_n_channels:
> assertion `GDK_IS_PIXBUF (pixbuf)' failed
> Segmentation fault
> $ 

My first guess would be that you are missing gnome-themes-standard. We should probably require that too. If not then please provide a backtrace for the first warning here. You'll need to run it as `G_DEBUG=fatal-warnings gdb gnome-boxes`.

> 
> > This indicates that at least dconf is not installed on your system for some reason
> It's not in Requires. So if it's really necessary, I'll fill a bug for that.

Yes, please.
Comment 4 Milan Bartos 2013-06-27 02:12:17 EDT
It seems that installing gnome-themes-standard fixed it. I've filled bug to that: https://bugzilla.redhat.com/show_bug.cgi?id=978727
Comment 5 Milan Bartos 2013-08-29 02:45:32 EDT
I think this bug can be closed as bug #978727 is fixed.
Comment 6 Christophe Fergeau 2013-08-29 05:23:50 EDT

*** This bug has been marked as a duplicate of bug 978727 ***

Note You need to log in before you can comment on or make changes to this bug.