Bug 974498 - Error message "We appear to be having technical difficulties" while accessing "My Applications" page
Error message "We appear to be having technical difficulties" while accessing...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Rajat Chopra
libra bugs
:
: 974790 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-14 05:47 EDT by r.reimann
Modified: 2015-05-14 19:21 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-24 10:55:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description r.reimann 2013-06-14 05:47:08 EDT
Description of problem:

After logging in i can't access the "My Applications" page. While trying i get the error message "We appear to be having technical difficulties"

Reference #a626e5fbea6d898f81423f7ac314855f
Reference #ab0f069b0d3bf1cc35836274cd52c0d7
...


How reproducible:

- Login & access My Applications
- The error occurs repeatedly since ~ 3 hours
Comment 1 Clayton Coleman 2013-06-14 18:47:01 EDT
The UI error this causes is fixed, but the underlying application needs to be corrected (assuming this is a dead gear from the migration).
Comment 2 Yujie Zhang 2013-06-16 21:27:49 EDT
*** Bug 974790 has been marked as a duplicate of this bug. ***
Comment 3 r.reimann 2013-06-18 01:46:59 EDT
Hi, is there any chance on getting this fixed anytime soon? 

It was the first time i created an application when the error occurred so it's not a migration issue as assumed above.

I know i'm trying to use a free service but running into such an issue at the very first attempt and then waiting for days to get it resolved doesn't leave me with a good first impression.
Comment 4 Xiaoli Tian 2013-06-18 06:56:53 EDT
It should be fixed soon ( maybe later today),  if your account is still not fixed after today, you could reply to the bug again.

Sorry for the inconvenience  caused,
Comment 5 Xiaoli Tian 2013-06-18 07:04:33 EDT
Ah, I thought you are hitting this bug 971136, and the fix should be already deployed, if you still have problems,  someone will help you check later.
Comment 6 Chris 2013-06-18 10:27:16 EDT
I still have the same problem. I submitted bug 974498, but it was closed as a duplicate. However, it seems to require someone to fix my specific account (instead of just fixing this other customer's account).
Comment 7 r.reimann 2013-06-19 02:59:48 EDT
(In reply to xiaoli from comment #4)
> It should be fixed soon ( maybe later today),  if your account is still not
> fixed after today, you could reply to the bug again.
> 
Replying again (as requested by xiaoli) - i just checked and the issue is still present.
Comment 8 Andy Grimm 2013-06-19 11:05:57 EDT
Based on the reference IDs, the app is notmyissue-robr.rhcloud.com.  The problem appears to be related to pending ops.  Adding Rajat Chopra to the CC list to help out with this.
Comment 10 Rajat Chopra 2013-06-19 17:33:03 EDT
Ok. Found the issue. This is a weird internal bug that we discovered recently and it sometimes causes two operations on an app to step on each other to render the application in 'spoiled' state. 
(Summary of the weird internal bug - mcollective crashes with SIGABRT and sometimes it takes more than 10 minutes to give the control back to the broker - by which time our locks time out exposing the application to next client request in the queue).


This particular application will be deleted by our 'operations' team. Please let us know if you can access your account properly now.
Comment 11 Meng Bo 2013-06-21 05:55:18 EDT
Hi Robert,

Could you check if your account is ok now? Since our OPS team has deleted your app which may cause your issue.

If the issue is gone, we will close your bug.

Thanks
Comment 12 r.reimann 2013-06-24 01:45:00 EDT
The issue is gone now, thanks.
Comment 13 Meng Bo 2013-06-24 02:57:19 EDT
@r.reimann
Thanks for your response. 


According to user's feedback.

Move the bug to verified.

Note You need to log in before you can comment on or make changes to this bug.