Bug 974543 - Anaconda is always creating new efi system partition
Anaconda is always creating new efi system partition
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
20
Unspecified Unspecified
high Severity unspecified
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: 873207
  Show dependency treegraph
 
Reported: 2013-06-14 07:51 EDT by Jan Sedlák
Modified: 2014-05-07 05:50 EDT (History)
15 users (show)

See Also:
Fixed In Version: python-blivet-0.17-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-24 13:56:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda.log (19.32 KB, text/plain)
2013-06-14 08:13 EDT, Jan Sedlák
no flags Details
anaconda.program.log (77.58 KB, text/plain)
2013-06-14 08:13 EDT, Jan Sedlák
no flags Details
anaconda.storage.log (143.64 KB, text/plain)
2013-06-14 08:13 EDT, Jan Sedlák
no flags Details
syslog (162.17 KB, text/plain)
2013-06-14 08:14 EDT, Jan Sedlák
no flags Details

  None (edit)
Description Jan Sedlák 2013-06-14 07:51:10 EDT
Description of problem:
When you have existing EFI system partition on your disk (e.g. you have Windows 8 installed on EFI) and then you install F19 from UEFI, it creates new EFI system partition even when you already have one.

Before installing F19, I had this partition layout:

Model: ATA ST500DM002-1BD14 (scsi)
Disk /dev/sda: 500GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags: 

Number  Start   End    Size   File system  Name                          Flags
 1      1049kB  316MB  315MB  ntfs         Basic data partition          hidden, diag
 2      316MB   419MB  104MB  fat32        EFI system partition          boot
 3      419MB   554MB  134MB               Microsoft reserved partition  msftres
 4      554MB   500GB  500GB  ntfs         Basic data partition

Notice that second partition is ESP. Then I booted Anaconda, shrinked fourth partition and after installation, I had this layout:

Model: ATA ST500DM002-1BD14 (scsi)
Disk /dev/sda: 500GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags: 

Number  Start   End    Size    File system  Name                          Flags
 1      1049kB  316MB  315MB   ntfs         Basic data partition          hidden, diag
 2      316MB   419MB  104MB   fat32        EFI system partition          boot
 3      419MB   554MB  134MB                Microsoft reserved partition  msftres
 4      554MB   447GB  447GB   ntfs         Basic data partition
 5      447GB   448GB  210MB   fat16        EFI System Partition          boot
 6      448GB   448GB  524MB   ext4
 7      448GB   500GB  52.0GB                                             lvm

Anaconda created second EFI system partition (this time only fat16).

Expected result:
I think that it should use existing EFI system partition.
Comment 1 Jan Sedlák 2013-06-14 08:06:12 EDT
I should add that I have used F19 TC3, anaconda version 19.30.5.
Comment 2 Jan Sedlák 2013-06-14 08:13:06 EDT
Created attachment 761234 [details]
anaconda.log
Comment 3 Jan Sedlák 2013-06-14 08:13:34 EDT
Created attachment 761236 [details]
anaconda.program.log
Comment 4 Jan Sedlák 2013-06-14 08:13:57 EDT
Created attachment 761237 [details]
anaconda.storage.log
Comment 5 Jan Sedlák 2013-06-14 08:14:19 EDT
Created attachment 761238 [details]
syslog
Comment 6 Fedora Blocker Bugs Application 2013-06-17 20:02:40 EDT
Proposed as a Freeze Exception for 19-final by Fedora user bcl using the blocker tracking app because:

 UEFI systems should share the system partition, not create new ones for each parallel install.
Comment 7 Brian Lane 2013-06-18 12:58:38 EDT
Patches from http://dlehman.fedorapeople.org/patches/20130430-efi.0/ fix this.
Comment 8 Adam Williamson 2013-06-19 15:00:26 EDT
Discussed at 2013-06-19 freeze exception review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-06-19/f19final-blocker-review-7.2013-06-19-16.01.log.txt . Accepted as a freeze exception issue: this is clearly incorrect behaviour and could conceivably even cause issues for other installed UEFI OSes. We ought to be doing what we're supposed to be doing when installing with an existing UEFI ESP.
Comment 9 Fedora Update System 2013-06-24 17:59:42 EDT
anaconda-19.30.10-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/anaconda-19.30.10-1.fc19
Comment 10 Kamil Páral 2013-06-25 04:57:43 EDT
Verified fixed with F19 RC1 Live. Great job.
Comment 11 Fedora Update System 2013-06-28 03:17:33 EDT
python-blivet-0.17-1.fc19, anaconda-19.30.13-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Adam Williamson 2013-06-28 13:28:28 EDT
Note: the fix for this may have caused https://bugzilla.redhat.com/show_bug.cgi?id=979205 .
Comment 13 Orion Poplawski 2013-10-22 16:42:50 EDT
I'm walking through a disk configuration now for F20-Beta-TC5 and it wants to create a new one for me.  Is it still desired to share a single EFI system partition?
Comment 14 Brian Lane 2013-10-22 17:26:33 EDT
I probably broke this with my bootloader patch :/
Comment 15 Kamil Páral 2013-10-23 04:06:32 EDT
Reopening per comment 13.
Comment 16 Brian Lane 2013-10-24 13:56:04 EDT
The reason for the error is different, and is fixed by the patch for bug 1021258
Comment 17 Pedro Francisco 2014-05-06 17:37:25 EDT
I'm installing http://alt.fedoraproject.org/pub/alt/live-respins/F20-i686-LIVE-DESK-20140411.iso and it still wants to create another efi system partition.

Is it just fixed for Rawhide? Or is it supposed to be fixed in updated F20?
Comment 18 Adam Williamson 2014-05-06 19:12:40 EDT
i686? We don't officially support UEFI on i686 at all.
Comment 19 Pedro Francisco 2014-05-07 05:50:24 EDT
Sorry, my mistake, I pasted the wrong filename.

I checked the local ISO, F20-x86_64-LIVE-DESK-20140411.iso would be the correct filename.

Maybe it's because the EFI filessystem is in FAT32? (Fedora creates its EFI in FAT16)

# dd if=/dev/sda1 of=efipart bs=512 count=10
$ file efipart
efipart: x86 boot sector, code offset 0x58+2, OEM-ID "MSDOS5.0", sectors/cluster 8, reserved sectors 7006, Media descriptor 0xf8, sectors/track 63, heads 255, hidden sectors 2048, sectors 614400 (volumes > 32 MB) , FAT (32 bit), sectors/FAT 593, reserved 0x1, serial number 0xXXXXXXXX, unlabeled


$ sudo parted -l /dev/sda
Model: ATA ST750LM022 HN-M7 (scsi)
Disk /dev/sda: 750GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system  Name                          Flags
 1      1049kB  316MB   315MB   fat32        EFI system partition          boot
(...)

$ sudo fdisk -l /dev/sda 

Disk /dev/sda: 698.7 GiB, 750156374016 bytes, 1465149168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: XXXXX...XXXXX

Device            Start          End   Size Type
/dev/sda1          2048       616447   300M EFI System
(...)

Note You need to log in before you can comment on or make changes to this bug.