Bug 974592 - rhq storage not discovered / not auto-imported by server
rhq storage not discovered / not auto-imported by server
Status: CLOSED WONTFIX
Product: JBoss Operations Network
Classification: JBoss
Component: Core Server (Show other bugs)
JON 3.2
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On:
Blocks: 951619
  Show dependency treegraph
 
Reported: 2013-06-14 10:07 EDT by Armine Hovsepyan
Modified: 2015-09-02 20:01 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-19 09:52:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
storage_node_autoImport (483.32 KB, image/png)
2013-06-19 07:39 EDT, Armine Hovsepyan
no flags Details

  None (edit)
Description Armine Hovsepyan 2013-06-14 10:07:42 EDT
Description of problem:
rhq storage not discovered / not auto-imported by server

Version-Release number of selected component (if applicable):
jon 3.1.2 upgraded using rhqctl to build f4a3f5e

How reproducible:


Steps to Reproduce:
1. install jon 3.1.2 (postgres)
2. upgrade jon 3.1.2 to rhq 4.8 using rhqctl upgrade --from-agent-dir agentDir --from-server-dir Jon3.1.2ServerDir
3. rhqctl stop
4. rhqctl start --storage
5. migrate data from jon 3.1.2 to Cassandra

Actual results:
Storage node not auto-discovered -> http://d.pr/i/el1h
And cassandra deamon is visible in discovery queue -> http://d.pr/i/oCQ7

Expected results:
storage node discovered and auto-inventoried 

Additional info:
Comment 1 Jay Shaughnessy 2013-06-14 12:02:49 EDT
Assuming this is a regression it must be recent as I am not seeing anything like this locally...
Comment 2 Armine Hovsepyan 2013-06-14 12:13:10 EDT
Yes, this is a regression -  was not visible for previous builds.
Comment 3 Jay Shaughnessy 2013-06-17 10:31:50 EDT
Before stopping in reproduction step 3, are you sure the agent was connected and completed its discovery?
Comment 4 Armine Hovsepyan 2013-06-17 12:30:54 EDT
I am not sure. Please move it to ON_QA if a retest is needed.
Comment 5 John Sanda 2013-06-17 21:35:44 EDT
I have not been able to reproduce this behavior, so I moving back to ON_QA to be retested.
Comment 6 Armine Hovsepyan 2013-06-18 06:42:13 EDT
Hi Jay,

Please get the screen-shots of agent before migration (http://d.pr/i/3qgw) with rhq storage pugin screen-shot (http://d.pr/i/I7sQ).

Env details will paste privately.

Regards,
Armine H.
Comment 8 Jay Shaughnessy 2013-06-18 16:10:46 EDT
I successfully upgraded from RHQ 4.5.1 to RHQ 4.8.0-SNAPSHOT.  After the upgrade the Storage node was discovered and auto-imported, and the alert template was injected and applied.

This was on Windows.  There were some bug fixes applied to get my upgrade working successfully although none had to do with the actual auto-import.  I did solve two issues that were non-windows related. First, I added the --storage-config option to the upgrade command; this allows the upgrade from pre-48 to specify initial non-default values for storage props (which I needed).  Second, I solved a problem with the agent upgrade if the agent was in the default location (no --from-agent-dir being specified).

If you are still seeing bad behavior perhaps we can go through the steps together. Let me know.
Comment 9 Jay Shaughnessy 2013-06-18 16:12:32 EDT
As an aside, the fixes I added are all in master as of:

commit 72f114cb01f3286696be68912280906b1954febe
Author: Jay Shaughnessy <jshaughn@redhat.com>
Date:   Tue Jun 18 15:59:02 2013 -0400

    Fix upgrade issues
    - fix agent upgrade of existing agent in the default location
      (i.e. no --from-agent-dir specified)
    - On Windows, ensure exit codes are passed back from the storage installer
      and rhqctl scripts.  The former is very important as otherwise errors
      in the storage installer do not prevent an attempt to upgrade/install the
      server.
Comment 10 Armine Hovsepyan 2013-06-19 07:38:23 EDT
Tried for Linux upgrade fom 4.5 to 4.8  - the same issue is present.

please get screen-shot attached.
Comment 11 Armine Hovsepyan 2013-06-19 07:39:29 EDT
Created attachment 762883 [details]
storage_node_autoImport
Comment 12 Armine Hovsepyan 2013-06-19 09:52:35 EDT
upgrade from 4.5.1 to 48 worked fine -> http://d.pr/i/UAmm. 
Previous upgrade was on 4.5snapshot which didn't work.

Conclution made - upgrade only from rhq-> rhq and jon->jon and not use snapshot versions.

Closing bug as wontfix since the scenarios issue appears are not supported.

Note You need to log in before you can comment on or make changes to this bug.