Bug 974621 - Generalize "Ubuntu Launchpad" external tracker to just "Launchpad" (incl. URLs change)
Generalize "Ubuntu Launchpad" external tracker to just "Launchpad" (incl. URL...
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
4.4
All Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: Simon Green
tools-bugs
:
Depends On: 237747
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-14 12:26 EDT by Jan Pokorný
Modified: 2014-10-12 18:51 EDT (History)
3 users (show)

See Also:
Fixed In Version: 4.4.0005
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 237747
Environment:
Last Closed: 2013-07-30 21:32:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Pokorný 2013-06-14 12:26:32 EDT
This is a follow up of historical [bug 237747].

I have no idea how Launchpad (LP) was structured back then, but nowadays
Launchpad is the place for various (upstream) projects, Ubuntu being
just one of them.  As I think it is useful to link RHBZ bugs to upstream
ones, so to make it easier for LP ones in particular, I suggest
these changes:

"Add External Bug: Tracker" dropdown menu:

- https://bugs.launchpad.net/ubuntu
+ https://bugs.launchpad.net/bugs

- Ubuntu Launchpad
+ Launchpad

(or "Launchpad (Ubuntu and other projects)" if we want to ease referring
to Ubuntu side)

Actually added Launchpad tracker

- https://bugs.launchpad.net/ubuntu/+bug/<id>
+ https://bugs.launchpad.net/bugs/<id>


Note that the current state allows to link LP bugs for other projects
as well because IDs are unique globally per LP and "/ubuntu/+bug/<id>"
URL will get redirected to "/<respective-project>/+bug/<id>" when
appropriate, _but_ the current labelling is counter-intuitive
(e.g., I rather used a comment to link Zope bug: [bug 878961 comment 4]).
Comment 4 Simon Green 2013-07-30 21:32:25 EDT
This change is now live. If there are any issues, do not reopen this bug. Instead, you should create a new bug and reference this bug.

  -- simon

Note You need to log in before you can comment on or make changes to this bug.