Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 973019 - UnicodeDecodeError: 'ascii' codec can't decode byte 0xc2 in position 0: ordinal not in range(128)
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc2 in position 0: ordin...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: pyparted (Show other bugs)
19
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
abrt_hash:0edf3649b7583f3a23ee66587fa...
:
: 974736 977491 (view as bug list)
Depends On:
Blocks: F19Blocker/F19FinalBlocker
  Show dependency treegraph
 
Reported: 2013-06-11 01:28 EDT by Nix\
Modified: 2013-06-26 00:28 EDT (History)
17 users (show)

See Also:
Fixed In Version: pyparted-3.9-3.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-26 00:28:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (262.16 KB, text/plain)
2013-06-11 01:28 EDT, Nix\
no flags Details
File: anaconda.log (28.87 KB, text/plain)
2013-06-11 01:28 EDT, Nix\
no flags Details
File: backtrace (413 bytes, text/plain)
2013-06-11 01:28 EDT, Nix\
no flags Details
File: environ (539 bytes, text/plain)
2013-06-11 01:28 EDT, Nix\
no flags Details
File: ifcfg.log (656 bytes, text/plain)
2013-06-11 01:28 EDT, Nix\
no flags Details
File: lsblk_output (2.29 KB, text/plain)
2013-06-11 01:28 EDT, Nix\
no flags Details
File: messages (126.58 KB, text/plain)
2013-06-11 01:28 EDT, Nix\
no flags Details
File: nmcli_dev_list (3.43 KB, text/plain)
2013-06-11 01:28 EDT, Nix\
no flags Details
File: program.log (32.02 KB, text/plain)
2013-06-11 01:28 EDT, Nix\
no flags Details
File: storage.log (122.57 KB, text/plain)
2013-06-11 01:29 EDT, Nix\
no flags Details

  None (edit)
Description Nix\ 2013-06-11 01:28:09 EDT
Description of problem:
1.- Start liveinst
2.- Select hard drive
3.- Select primary partition
4.- Click on sda1 -existent partition-, click on - symbol, click on > for view all partitions
The following was filed automatically by anaconda:
anaconda 19.30.3-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 297, in refresh
    label.set_text(label.get_text() % txt)
  File "/usr/lib/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 2132, in on_remove_clicked
    device.name, root_name)
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc2 in position 0: ordinal not in range(128)

Version-Release number of selected component:
anaconda-19.30.3-1.fc19.i686

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=Fedora-Live-KDE-i686-19-TC2-1 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
core_backtrace: 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.4-301.fc19.i686
packaging.log:  
product:        Fedora
release:        Fedora release 19 (Schrödinger’s Cat)
type:           anaconda
version:        19

Truncated backtrace:
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 2132, in on_remove_clicked
    device.name, root_name)
  File "/usr/lib/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 297, in refresh
    label.set_text(label.get_text() % txt)
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc2 in position 0: ordinal not in range(128)
Comment 1 Nix\ 2013-06-11 01:28:17 EDT
Created attachment 759424 [details]
File: anaconda-tb
Comment 2 Nix\ 2013-06-11 01:28:22 EDT
Created attachment 759425 [details]
File: anaconda.log
Comment 3 Nix\ 2013-06-11 01:28:26 EDT
Created attachment 759426 [details]
File: backtrace
Comment 4 Nix\ 2013-06-11 01:28:31 EDT
Created attachment 759427 [details]
File: environ
Comment 5 Nix\ 2013-06-11 01:28:35 EDT
Created attachment 759428 [details]
File: ifcfg.log
Comment 6 Nix\ 2013-06-11 01:28:39 EDT
Created attachment 759429 [details]
File: lsblk_output
Comment 7 Nix\ 2013-06-11 01:28:44 EDT
Created attachment 759430 [details]
File: messages
Comment 8 Nix\ 2013-06-11 01:28:51 EDT
Created attachment 759431 [details]
File: nmcli_dev_list
Comment 9 Nix\ 2013-06-11 01:28:56 EDT
Created attachment 759432 [details]
File: program.log
Comment 10 Nix\ 2013-06-11 01:29:02 EDT
Created attachment 759433 [details]
File: storage.log
Comment 11 Nix\ 2013-06-11 01:47:35 EDT
If you select a pre-existent partition, later personal partitioning, all screen of anaconda turn grey and crash.
Comment 12 Adam Williamson 2013-06-17 22:17:31 EDT
*** Bug 974736 has been marked as a duplicate of this bug. ***
Comment 13 Adam Williamson 2013-06-17 22:22:14 EDT
Proposing as a final FE as a crasher in a fairly normal partitioning operation. Is this related to some property of the partion, perhaps a volume label containing a non-ASCII character or something like that?
Comment 14 Vratislav Podzimek 2013-06-19 08:00:06 EDT
This is a blivet issue. Patch posted to anaconda-patches.
Comment 15 Adam Williamson 2013-06-19 14:22:24 EDT
Discussed at 2013-06-19 freeze exception review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-06-19/f19final-blocker-review-7.2013-06-19-16.01.log.txt . Accepted as a freeze exception (at least) as a crasher in the installer. There's a reasonable argument for this being a blocker, but as there's a patch already we're expecting it'll just make it into 19.30.9 and make the discussion academic.

The patch is https://lists.fedorahosted.org/pipermail/anaconda-patches/2013-June/004692.html , to track review status.
Comment 16 Nix\ 2013-06-20 02:57:27 EDT
Non ASCII characters in disk label used, only Fedora 18 system the old partitioned system, no less no more.
Comment 17 Nix\ 2013-06-20 03:31:35 EDT
Bug present in Fedora 19 TC6-1 KDE LiveCD.
The label of the existent partion is: Fedora Linux 19 for i686
Trying of delete / or swap, crash anaconda with this bug. Using Spanish for installation and setx es in terminal before liveinst command
Comment 18 Adam Williamson 2013-06-20 03:39:35 EDT
Yes, that's expected. The fix is still pending review. It is not included in TC6.
Comment 19 Kamil Páral 2013-06-21 06:23:33 EDT
We received many more reports of this. Proposing as a blocker.
Comment 20 Adam Williamson 2013-06-21 17:58:33 EDT
+1 blocker, if we're getting multiple reports of this (or closely-related bugs). anaconda team, can you make sure there's someone looking into all of these UnicodeDecodeError s? Thanks!
Comment 21 Adam Williamson 2013-06-24 12:28:20 EDT
Add another See Also, 973384 . There's also https://bugzilla.redhat.com/show_bug.cgi?id=965556 , but that's 'utf8' codec rather than 'ascii' codec.
Comment 22 Adam Williamson 2013-06-24 12:47:19 EDT
It seems that several of the 'see also' bugs were dupes of each other, but they are *not* the same as this bug. So far as open, different UnicodeDecodeError bugs go, we now have this one (973019), 973384, and 965556.
Comment 23 Adam Williamson 2013-06-24 13:13:22 EDT
*** Bug 977491 has been marked as a duplicate of this bug. ***
Comment 24 Adam Williamson 2013-06-24 13:14:09 EDT
tflink reproduced this with F19 TC6 Desktop live in Japanese:

"I started an install using F19 final TC6 x86_64 live desktop, selecting Japanese language. The install was to a VM with 2 vdisks containing a previous F19 install to sw RAID1. I hit this while in custom partitioning, right after deleting the old swap partition"
Comment 25 Adam Williamson 2013-06-24 13:24:30 EDT
Discussed at 2013-06-24 blocker review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-06-24/f19final-blocker-review-8.2013-06-24-16.00.log.txt . Accepted as a blocker per criterion "The installer must be able to create and install to any workable partition layout using any file system offered in a default installer configuration, LVM, software, hardware or BIOS RAID, or combination of the above" (in the case of apparently several non-English languages).
Comment 26 Fedora Update System 2013-06-24 16:10:40 EDT
pyparted-3.9-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/pyparted-3.9-3.fc19
Comment 27 Adam Williamson 2013-06-24 16:11:19 EDT
http://adamwill.fedorapeople.org/20130624-desktop-x86_64.iso ought to fix this (we hope). Can people who are able to reproduce this bug please test and report back ASAP? Thanks!
Comment 28 Adam Williamson 2013-06-24 16:30:51 EDT
I can reproduce this by doing an all-defaults install of F19 TC6 Live to a VM then booting it again, choosing Japanese, doing custom partitioning, removing one existing partition (swap) then selecting another existing partition (/boot). I'll see if I can confirm the fix.
Comment 29 Adam Williamson 2013-06-24 16:37:00 EDT
I can't reproduce following the same procedure with http://adamwill.fedorapeople.org/20130624-desktop-x86_64.iso , so looks like the fix worked here too!
Comment 30 Tim Flink 2013-06-24 16:46:20 EDT
(In reply to Adam Williamson from comment #29)
> I can't reproduce following the same procedure with
> http://adamwill.fedorapeople.org/20130624-desktop-x86_64.iso , so looks like
> the fix worked here too!

Same here. I can't reproduce the crash from 977491 (duped to this bug) with this live iso but I can reproduce 100% on the TC6 desktop live image.
Comment 31 Nix\ 2013-06-25 01:53:27 EDT
(In reply to Adam Williamson from comment #29)
> I can't reproduce following the same procedure with
> http://adamwill.fedorapeople.org/20130624-desktop-x86_64.iso , so looks like
> the fix worked here too!

Work for me the updated package from https://admin.fedoraproject.org/updates/pyparted-3.9-3.fc19.

1.-Starting a LiveCD
2.-#rpm -Uvh to pyparted-3.9-3.fc19 rpm downloaded
3.-liveinst
4.-delete a previous partition created for a previous installation, works for me

karma +1 added
Comment 32 Josef Skladanka 2013-06-25 09:45:17 EDT
Works for me with RC1, at least Adam's reproducer from comment #28 is not raising any exceptions.
Comment 33 Fedora Update System 2013-06-26 00:28:01 EDT
pyparted-3.9-3.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.