Bug 974744 - [abrt] ibus-1.5.2-5.fc19: bus_dbus_impl_dispatch_message_by_rule: Process /usr/bin/ibus-daemon was killed by signal 6 (SIGABRT)
[abrt] ibus-1.5.2-5.fc19: bus_dbus_impl_dispatch_message_by_rule: Process /us...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
abrt_hash:75db545dfce1b8ef1c186df1d5b...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-15 05:19 EDT by kakoskin
Modified: 2014-04-08 12:14 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-24 21:52:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (15.52 KB, text/plain)
2013-06-15 05:19 EDT, kakoskin
no flags Details
File: cgroup (140 bytes, text/plain)
2013-06-15 05:19 EDT, kakoskin
no flags Details
File: core_backtrace (2.04 KB, text/plain)
2013-06-15 05:19 EDT, kakoskin
no flags Details
File: dso_list (2.61 KB, text/plain)
2013-06-15 05:19 EDT, kakoskin
no flags Details
File: environ (922 bytes, text/plain)
2013-06-15 05:20 EDT, kakoskin
no flags Details
File: limits (1.29 KB, text/plain)
2013-06-15 05:20 EDT, kakoskin
no flags Details
File: maps (12.79 KB, text/plain)
2013-06-15 05:20 EDT, kakoskin
no flags Details
File: open_fds (1.51 KB, text/plain)
2013-06-15 05:20 EDT, kakoskin
no flags Details
File: proc_pid_status (931 bytes, text/plain)
2013-06-15 05:20 EDT, kakoskin
no flags Details

  None (edit)
Description kakoskin 2013-06-15 05:19:45 EDT
Description of problem:
Received this report when first loging in to KDE after installing it on a fresh install of FC19 TC3 with only Gnome as a desktop.

Version-Release number of selected component:
ibus-1.5.2-5.fc19

Additional info:
reporter:       libreport-2.1.4
backtrace_rating: 4
cmdline:        /usr/bin/ibus-daemon --replace --xim --panel disable
crash_function: bus_dbus_impl_dispatch_message_by_rule
executable:     /usr/bin/ibus-daemon
kernel:         3.9.5-301.fc19.x86_64
runlevel:       N 5
uid:            1000
var_log_messages: Jun 15 11:50:42 localhost abrt[6490]: Saved core dump of pid 1598 (/usr/bin/ibus-daemon) to /var/tmp/abrt/ccpp-2013-06-15-11:50:41-1598 (37322752 bytes)

Truncated backtrace:
Thread no. 1 (8 frames)
 #4 bus_dbus_impl_dispatch_message_by_rule at dbusimpl.c:1887
 #5 bus_dbus_impl_connection_filter_cb at dbusimpl.c:1564
 #6 on_worker_message_about_to_be_sent at gdbusconnection.c:2414
 #7 _g_dbus_worker_emit_message_about_to_be_sent at gdbusprivate.c:502
 #8 continue_writing at gdbusprivate.c:1496
 #9 continue_writing_in_idle_cb at gdbusprivate.c:1557
 #14 gdbus_shared_thread_func at gdbusprivate.c:278
 #15 g_thread_proxy at gthread.c:798

Potential duplicate: bug 850539
Comment 1 kakoskin 2013-06-15 05:19:50 EDT
Created attachment 761541 [details]
File: backtrace
Comment 2 kakoskin 2013-06-15 05:19:53 EDT
Created attachment 761542 [details]
File: cgroup
Comment 3 kakoskin 2013-06-15 05:19:56 EDT
Created attachment 761543 [details]
File: core_backtrace
Comment 4 kakoskin 2013-06-15 05:19:59 EDT
Created attachment 761544 [details]
File: dso_list
Comment 5 kakoskin 2013-06-15 05:20:02 EDT
Created attachment 761545 [details]
File: environ
Comment 6 kakoskin 2013-06-15 05:20:06 EDT
Created attachment 761546 [details]
File: limits
Comment 7 kakoskin 2013-06-15 05:20:09 EDT
Created attachment 761547 [details]
File: maps
Comment 8 kakoskin 2013-06-15 05:20:13 EDT
Created attachment 761548 [details]
File: open_fds
Comment 9 kakoskin 2013-06-15 05:20:16 EDT
Created attachment 761549 [details]
File: proc_pid_status
Comment 10 fujiwara 2013-06-20 22:19:13 EDT
(In reply to kakoskin from comment #0)
> Thread 1 (Thread 0x7f5193012700 (LWP 1600)):
> #0  0x0000003046035819 in __GI_raise (sig=sig@entry=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:56
> #1  0x0000003046036f28 in __GI_abort () at abort.c:90
> #2  0x000000304846bbc6 in g_assertion_message (domain=domain@entry=0x4195d3 "IBUS", file=file@entry=0x419a9f "dbusimpl.c", line=line@entry=1887, func=func@entry=0x419fe0 <__PRETTY_FUNCTION__.24438> "bus_dbus_impl_dispatch_message_by_rule", message=<optimized out>) at gtestutils.c:1912
> #3  0x000000304846bc24 in g_assertion_message_expr (domain=domain@entry=0x4195d3 "IBUS", file=file@entry=0x419a9f "dbusimpl.c", line=line@entry=1887, func=func@entry=0x419fe0 <__PRETTY_FUNCTION__.24438> "bus_dbus_impl_dispatch_message_by_rule", expr=expr@entry=0x419e78 "skip_connection == NULL || BUS_IS_CONNECTION (skip_connection)") at gtestutils.c:1923
> #4  0x0000000000409f91 in bus_dbus_impl_dispatch_message_by_rule (dbus=dbus@entry=0x229b010, message=message@entry=0x7f518c003450, skip_connection=skip_connection@entry=0x2343980) at dbusimpl.c:1887
> #5  0x000000000040a417 in bus_dbus_impl_connection_filter_cb (dbus_connection=<optimized out>, message=0x7f518c003450, incoming=<optimized out>, user_data=0x229b010) at dbusimpl.c:1564
> #6  0x00000030498b390f in on_worker_message_about_to_be_sent (worker=<optimized out>, message=0x236a000, user_data=0x23c18b0) at gdbusconnection.c:2414
> #7  0x00000030498c8148 in _g_dbus_worker_emit_message_about_to_be_sent (message=0x236a000, worker=0x7f517c002280) at gdbusprivate.c:502
> #8  continue_writing (worker=0x7f517c002280) at gdbusprivate.c:1496
> #9  0x00000030498c8349 in continue_writing_in_idle_cb (user_data=<optimized out>) at gdbusprivate.c:1557
> #10 0x0000003048447e06 in g_main_dispatch (context=0x2323470) at gmain.c:3054


I cannot reproduce your backtrace.
Are you still able to reproduce your backtrace?
Comment 11 kakoskin 2013-06-23 12:44:51 EDT
No. The problem appeared only once after installing KDE with yum install @kde-desktop, loging out of Gnome and into KDE without rebooting. 

I didn't see this in a subsequent reinstall.

Note You need to log in before you can comment on or make changes to this bug.