Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 974778 - Wrong locale set by g-s-d with single quote
Summary: Wrong locale set by g-s-d with single quote
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-settings-daemon
Version: 19
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Bastien Nocera
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
: 974789 (view as bug list)
Depends On:
Blocks: F19Blocker, F19FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2013-06-15 18:04 UTC by Michael S.
Modified: 2013-06-19 01:29 UTC (History)
12 users (show)

Fixed In Version: gnome-settings-daemon-3.8.3-3.fc19
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-06-18 06:22:09 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
GNOME Bugzilla 701322 0 None None None Never
Red Hat Bugzilla 919855 0 unspecified CLOSED [abrt] gnome-settings-daemon-3.7.91-1.fc19: getenv: Process /usr/libexec/gnome-settings-daemon was killed by signal 11 (... 2021-02-22 00:41:40 UTC

Internal Links: 919855

Description Michael S. 2013-06-15 18:04:44 UTC
After installation of g-s-d in updates-testing ( gnome-settings-daemon-3.8.3-2.fc19.x86_64 ), I found out that my locales are wrong :

$ env | grep LC   
LC_NUMERIC='fr_FR.utf8'
LC_MEASUREMENT='fr_FR.utf8'
LC_PAPER='fr_FR.utf8'
LC_MONETARY='fr_FR.utf8'
LC_TIME='fr_FR.utf8'

the '' are wrong, and that's causing lots of issues.

This is caused by /usr/libexec/gnome-settings-daemon-localeexec and the latest backported patch. 

$ gsettings get org.gnome.system.locale region
'fr_FR.utf8'

I think the wrapper script should filter the '.

Comment 1 Michael S. 2013-06-15 18:13:30 UTC
Seems to be fixed upstream :

b0ca46dc389ebe9201f8c9bf6c046602900d22b8

Comment 2 Adam Williamson 2013-06-16 16:06:32 UTC
Proposing as a final release blocker to make sure we don't pull this into anything, will affect normal system use most likely.

Comment 3 Fedora Update System 2013-06-16 20:22:39 UTC
gnome-settings-daemon-3.8.3-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/gnome-settings-daemon-3.8.3-3.fc19

Comment 4 Fedora Update System 2013-06-17 17:01:10 UTC
Package gnome-settings-daemon-3.8.3-3.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gnome-settings-daemon-3.8.3-3.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-11030/gnome-settings-daemon-3.8.3-3.fc19
then log in and leave karma (feedback).

Comment 5 Michael S. 2013-06-17 17:01:28 UTC
As asked by adam williamson, the main issue caused by tthis are :
- perl software spew 10 to 15 lines of warning, saying they cannot find the local
- man pages are not readable
- mosh, that I use to connect to server, seemed to be broken
- screen ( on a remote session ) was not able to correctly display UTF8

Comment 6 Adam Williamson 2013-06-17 17:06:23 UTC
Discussed at 2013-06-17 blocker review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-06-17/f19final-blocker-review-6.2013-06-17-16.01.log.txt . Per misc's notes that this breaks lots of different apps, we accept this as a blocker under criterion "All applications listed under the Applications menu or category must withstand a basic functionality test and not crash after a few minutes of normal use." on the basis that it's almost certainly affecting something in that set.

Comment 7 Fedora Update System 2013-06-18 06:22:09 UTC
gnome-settings-daemon-3.8.3-3.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Kurt Miller 2013-06-19 01:29:08 UTC
*** Bug 974789 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.