Bug 974789 - [abrt] policycoreutils-devel-2.1.14-45.fc19: locale.py:547:setlocale:Error: unsupported locale setting
[abrt] policycoreutils-devel-2.1.14-45.fc19: locale.py:547:setlocale:Error: u...
Status: CLOSED DUPLICATE of bug 974778
Product: Fedora
Classification: Fedora
Component: policycoreutils (Show other bugs)
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2013-06-15 16:41 EDT by Kurt Miller
Modified: 2013-06-18 21:29 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2013-06-18 12:09:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
File: backtrace (380 bytes, text/plain)
2013-06-15 16:41 EDT, Kurt Miller
no flags Details
File: core_backtrace (164 bytes, text/plain)
2013-06-15 16:41 EDT, Kurt Miller
no flags Details
File: environ (2.20 KB, text/plain)
2013-06-15 16:41 EDT, Kurt Miller
no flags Details

  None (edit)
Description Kurt Miller 2013-06-15 16:41:13 EDT
Description of problem:
to reproduce: 

su root
grep nvidia-modprobe /var/log/audit/audit.log | audit2allow -M mypol


Version-Release number of selected component:

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python -Es /bin/audit2allow -M mypol
dso_list:       python-libs-2.7.5-1.fc19.x86_64
executable:     /bin/audit2allow
kernel:         3.9.5-301.fc19.x86_64
runlevel:       N 5
uid:            0

Truncated backtrace:
locale.py:547:setlocale:Error: unsupported locale setting

Traceback (most recent call last):
  File "/bin/audit2allow", line 33, in <module>
    locale.setlocale(locale.LC_ALL, '')
  File "/usr/lib64/python2.7/locale.py", line 547, in setlocale
    return _setlocale(category, locale)
Error: unsupported locale setting

Local variables in innermost frame:
locale: ''
category: 6
Comment 1 Kurt Miller 2013-06-15 16:41:16 EDT
Created attachment 761694 [details]
File: backtrace
Comment 2 Kurt Miller 2013-06-15 16:41:21 EDT
Created attachment 761695 [details]
File: core_backtrace
Comment 3 Kurt Miller 2013-06-15 16:41:23 EDT
Created attachment 761696 [details]
File: environ
Comment 4 Daniel Walsh 2013-06-18 12:09:34 EDT
You have  a weird environment,  Your LC variables look wrong.  I had to hack my environment to even get it to happen.


THese should not be set at all but definitely not to ''

In order to get this to happen, I had to 
export LC_TIME="''"
Comment 5 Kurt Miller 2013-06-18 14:44:17 EDT
Thank you Daniel for taking a look at the report. It appears something in gnome is doing this. If I ssh into the system my local values are set correctly.

The system is at home, but I can see with 'ps e' that something in gnome is doing this:

0  1000  1761  1583  20   0 918276 23944 poll_s Sl   ?          0:01 /usr/libexec/gnome-settings-daemon LC_PAPER='' <cut rest of env>
0  1000  1857     1  20   0 525288  3864 poll_s Sl   ?          0:00 /usr/libexec/gsd-printer LC_PAPER='' <cut rest of env>

The parent process for gnome-settings-daemon is gnome-session. The enviroment for it looks ok to me:

4  1000  1583  1569  20   0 712200 11228 poll_s Ssl  ?          0:00 gnome-session XDG_VTNR=1 XDG_SESSION_ID=1 HOSTNAME=tardis IMSETTINGS_INTEGRATE_DESKTOP=yes SHELL=/bin/bash TERM=dumb HISTSIZE=1000 GNOME_KEYRING_CONTROL=/run/user/1000/keyring-xxx QT_GRAPHICSSYSTEM_CHECKED=1 IMSETTINGS_MODULE=none USER=kurt USERNAME=kurt MAIL=/var/spool/mail/kurt PATH=/usr/lib64/ccache:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/home/kurt/.local/bin:/home/kurt/bin DESKTOP_SESSION=gnome QT_IM_MODULE=xim PWD=/home/kurt XMODIFIERS=@im=none GNOME_KEYRING_PID=1578 LANG=en_US.utf8 GDM_LANG=en_US.utf8 GDMSESSION=gnome HISTCONTROL=ignoredups KRB5CCNAME=DIR:/run/user/1000/krb5cc_xxx XDG_SEAT=seat0 HOME=/home/kurt SHLVL=1 LOGNAME=kurt CVS_RSH=ssh DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-UKkhmNYIJS,guid=xxx LESSOPEN=||/usr/bin/lesspipe.sh %s WINDOWPATH=1 XDG_RUNTIME_DIR=/run/user/1000 DISPLAY=:0 CCACHE_HASHDIR= XAUTHORITY=/run/gdm/auth-for-kurt-xxx/database _=/usr/bin/gnome-session

So what is mangling the LC_* env vars?
Comment 6 Kurt Miller 2013-06-18 21:29:08 EDT
For clarity, documenting this is a duplicate of 974778.

*** This bug has been marked as a duplicate of bug 974778 ***

Note You need to log in before you can comment on or make changes to this bug.