Bug 974791 - [abrt] mate-document-viewer-1.6.0-5.fc18: g_settings_set_property: Process /usr/bin/atril was killed by signal 5 (SIGTRAP)
[abrt] mate-document-viewer-1.6.0-5.fc18: g_settings_set_property: Process /u...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mate-document-viewer (Show other bugs)
18
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Wolfgang Ulbrich
Fedora Extras Quality Assurance
abrt_hash:94631833e7f4900bd8d2aaf903d...
: Reopened
Depends On: 988944
Blocks: depchain
  Show dependency treegraph
 
Reported: 2013-06-15 17:16 EDT by Wilbert Isaac Cortés González
Modified: 2013-08-17 20:39 EDT (History)
3 users (show)

See Also:
Fixed In Version: mate-document-viewer-1.6.1-5.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-17 20:30:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (34.13 KB, text/plain)
2013-06-15 17:17 EDT, Wilbert Isaac Cortés González
no flags Details
File: cgroup (127 bytes, text/plain)
2013-06-15 17:17 EDT, Wilbert Isaac Cortés González
no flags Details
File: core_backtrace (1.31 KB, text/plain)
2013-06-15 17:17 EDT, Wilbert Isaac Cortés González
no flags Details
File: dso_list (9.53 KB, text/plain)
2013-06-15 17:17 EDT, Wilbert Isaac Cortés González
no flags Details
File: environ (4.19 KB, text/plain)
2013-06-15 17:17 EDT, Wilbert Isaac Cortés González
no flags Details
File: limits (1.29 KB, text/plain)
2013-06-15 17:17 EDT, Wilbert Isaac Cortés González
no flags Details
File: maps (39.28 KB, text/plain)
2013-06-15 17:17 EDT, Wilbert Isaac Cortés González
no flags Details
File: open_fds (1.52 KB, text/plain)
2013-06-15 17:17 EDT, Wilbert Isaac Cortés González
no flags Details
File: proc_pid_status (781 bytes, text/plain)
2013-06-15 17:17 EDT, Wilbert Isaac Cortés González
no flags Details
File: xsession_errors (1.29 KB, text/plain)
2013-06-15 17:17 EDT, Wilbert Isaac Cortés González
no flags Details

  None (edit)
Description Wilbert Isaac Cortés González 2013-06-15 17:16:59 EDT
Version-Release number of selected component:
mate-document-viewer-1.6.0-5.fc18

Additional info:
reporter:       libreport-2.1.4
backtrace_rating: 4
cmdline:        atril /home/lain/advanced_rails.pdf
crash_function: g_settings_set_property
executable:     /usr/bin/atril
kernel:         3.9.5-201.fc18.i686.PAE
runlevel:       N 5
uid:            1000
var_log_messages: Jun 14 21:14:55 navi abrt[14053]: Saved core dump of pid 14035 (/usr/bin/atril) to /var/tmp/abrt/ccpp-2013-06-14-21:14:54-14035 (47685632 bytes)

Truncated backtrace:
Thread no. 1 (7 frames)
 #2 g_settings_set_property at gsettings.c:492
 #3 object_set_property at gobject.c:1357
 #4 g_object_constructor at gobject.c:1868
 #6 g_object_new_valist at gobject.c:1835
 #8 g_settings_new at gsettings.c:869
 #9 ev_window_setup_document at ev-window.c:1372
 #15 gtk_main at gtkmain.c:1257
Comment 1 Wilbert Isaac Cortés González 2013-06-15 17:17:07 EDT
Created attachment 761697 [details]
File: backtrace
Comment 2 Wilbert Isaac Cortés González 2013-06-15 17:17:11 EDT
Created attachment 761698 [details]
File: cgroup
Comment 3 Wilbert Isaac Cortés González 2013-06-15 17:17:15 EDT
Created attachment 761699 [details]
File: core_backtrace
Comment 4 Wilbert Isaac Cortés González 2013-06-15 17:17:19 EDT
Created attachment 761700 [details]
File: dso_list
Comment 5 Wilbert Isaac Cortés González 2013-06-15 17:17:23 EDT
Created attachment 761701 [details]
File: environ
Comment 6 Wilbert Isaac Cortés González 2013-06-15 17:17:26 EDT
Created attachment 761702 [details]
File: limits
Comment 7 Wilbert Isaac Cortés González 2013-06-15 17:17:31 EDT
Created attachment 761703 [details]
File: maps
Comment 8 Wilbert Isaac Cortés González 2013-06-15 17:17:35 EDT
Created attachment 761704 [details]
File: open_fds
Comment 9 Wilbert Isaac Cortés González 2013-06-15 17:17:38 EDT
Created attachment 761705 [details]
File: proc_pid_status
Comment 10 Wilbert Isaac Cortés González 2013-06-15 17:17:42 EDT
Created attachment 761706 [details]
File: xsession_errors
Comment 11 Wolfgang Ulbrich 2013-06-16 04:30:53 EDT
You're using KDE, right?
The issue is caused by a missing gsettings schema (org.mate.lockdown), which is include the mate-desktop package.
Can you install it?
yum install mate-desktop

And please can you post the output of yum, because i wanna know which dependencies yum installs on a KDE desktop without a MATE installation?
This is import for me to decide if i should add this runtime require to mate-document-viewer or not.

Thank you
Comment 12 Fedora Update System 2013-06-16 06:46:32 EDT
mate-document-viewer-1.6.0-6.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/mate-document-viewer-1.6.0-6.fc18
Comment 13 Fedora Update System 2013-06-17 21:37:37 EDT
Package mate-document-viewer-1.6.0-6.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing mate-document-viewer-1.6.0-6.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-11115/mate-document-viewer-1.6.0-6.fc18
then log in and leave karma (feedback).
Comment 14 Fedora Update System 2013-06-26 22:03:18 EDT
mate-document-viewer-1.6.0-6.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 15 Christoph Wickert 2013-07-26 14:30:33 EDT
Please remove the dependency on mate-desktop again, you are forcing people to install half of mate if they only want a certain component. Instead, fix bug 988944. You can then savly drop the dependency as the schemas are part of the gnome-desktop-libs package which is pulled in automatically through the dependency on libmate-desktop-2.
Comment 16 Christoph Wickert 2013-07-26 15:43:48 EDT
(In reply to Christoph Wickert from comment #15)
> You can then savly drop the dependency as the schemas are part
> of the gnome-desktop-libs package which is pulled in automatically through
> the dependency on libmate-desktop-2.

Actually this is wrong, libmate-desktop2 is not pulled in automatically, so you still need to require mate-desktop-libs explicitly. Sorry, my bad.
Comment 17 Wolfgang Ulbrich 2013-07-27 09:10:45 EDT
You have to talk with Dan about the mate-desktop package split, but i did say to him that i see no reason not to do this.
Comment 18 Fedora Update System 2013-08-08 07:15:48 EDT
mate-document-viewer-1.6.1-5.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/mate-document-viewer-1.6.1-5.fc18
Comment 19 Fedora Update System 2013-08-08 07:16:04 EDT
mate-document-viewer-1.6.1-5.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/mate-document-viewer-1.6.1-5.fc19
Comment 20 Fedora Update System 2013-08-09 13:08:55 EDT
Package mate-document-viewer-1.6.1-5.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing mate-document-viewer-1.6.1-5.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-14504/mate-document-viewer-1.6.1-5.fc18
then log in and leave karma (feedback).
Comment 21 Fedora Update System 2013-08-17 20:30:43 EDT
mate-document-viewer-1.6.1-5.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 22 Fedora Update System 2013-08-17 20:39:12 EDT
mate-document-viewer-1.6.1-5.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.