Bug 974845 - [abrt] system-config-printer-libs-1.4.1-6.fc19: jobviewer.py:1734:notify_printer_state_reason:TypeError: GObject.__init__() takes exactly 0 arguments (3 given)
[abrt] system-config-printer-libs-1.4.1-6.fc19: jobviewer.py:1734:notify_prin...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: system-config-printer (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
abrt_hash:4995c0ff4c80a854fa609fe6b9d...
:
: 975648 975968 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-16 09:14 EDT by Daniel Bossert
Modified: 2013-06-29 14:16 EDT (History)
5 users (show)

See Also:
Fixed In Version: system-config-printer-1.4.1-7.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-29 14:16:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (989 bytes, text/plain)
2013-06-16 09:14 EDT, Daniel Bossert
no flags Details
File: core_backtrace (235 bytes, text/plain)
2013-06-16 09:14 EDT, Daniel Bossert
no flags Details
File: environ (727 bytes, text/plain)
2013-06-16 09:14 EDT, Daniel Bossert
no flags Details

  None (edit)
Description Daniel Bossert 2013-06-16 09:14:25 EDT
Version-Release number of selected component:
system-config-printer-libs-1.4.1-6.fc19

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python /usr/share/system-config-printer/scp-dbus-service.py
executable:     /usr/share/system-config-printer/scp-dbus-service.py
kernel:         3.9.1-301.fc19.x86_64
runlevel:       N 5
uid:            1000

Truncated backtrace:
jobviewer.py:1734:notify_printer_state_reason:TypeError: GObject.__init__() takes exactly 0 arguments (3 given)

Traceback (most recent call last):
  File "/usr/share/system-config-printer/jobviewer.py", line 2112, in still_connecting
    self.notify_printer_state_reason (reason)
  File "/usr/share/system-config-printer/jobviewer.py", line 1734, in notify_printer_state_reason
    notification = Notify.Notification (title, text, 'printer')
TypeError: GObject.__init__() takes exactly 0 arguments (3 given)

Local variables in innermost frame:
tuple: (1, u'HOME-HP-Color-LaserJet-CM1312nfi-MFP', u'connecting-to-device')
text: u'Drucker \xbbHOME-HP-Color-LaserJet-CM1312nfi-MFP\xab ist ggf. nicht angeschlossen.'
self: <JobViewer object at 0x15f3550 (jobviewer+JobViewer at 0xfa08e0)>
level: 1
reason: <statereason.StateReason (REPORT,HOME-HP-Color-LaserJet-CM1312nfi-MFP,connecting-to-device)>
title: 'Nicht angeschlossen?'
urgency: <enum NOTIFY_URGENCY_NORMAL of type PyNotifyUrgency>
Comment 1 Daniel Bossert 2013-06-16 09:14:30 EDT
Created attachment 761830 [details]
File: backtrace
Comment 2 Daniel Bossert 2013-06-16 09:14:33 EDT
Created attachment 761831 [details]
File: core_backtrace
Comment 3 Daniel Bossert 2013-06-16 09:14:37 EDT
Created attachment 761832 [details]
File: environ
Comment 5 Jiri Popelka 2013-06-19 06:49:56 EDT
*** Bug 975648 has been marked as a duplicate of this bug. ***
Comment 6 Jiri Popelka 2013-06-20 04:19:32 EDT
*** Bug 975968 has been marked as a duplicate of this bug. ***
Comment 7 Fedora Update System 2013-06-20 04:54:54 EDT
system-config-printer-1.4.1-7.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/system-config-printer-1.4.1-7.fc19
Comment 8 Fedora Update System 2013-06-20 14:04:08 EDT
Package system-config-printer-1.4.1-7.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing system-config-printer-1.4.1-7.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-11366/system-config-printer-1.4.1-7.fc19
then log in and leave karma (feedback).
Comment 9 Fedora Update System 2013-06-29 14:16:34 EDT
system-config-printer-1.4.1-7.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.